Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.5.0 - Page 382

post #5716 of 15260

I am hoping it comes out soon as we are writing the review for Audio360.org and want to publish the most current information on the dX50

post #5717 of 15260

Gotta say I keep getting gobsmacked with every new song that comes on. Which is pretty awesome:)

 

I have 1.2.2 atm. I think I wait a while before messing with it, even if iBasso releases new version.

post #5718 of 15260
Quote:
Originally Posted by Frank I View Post
 

I am hoping it comes out soon as we are writing the review for Audio360.org and want to publish the most current information on the dX50

I can understand that. I only wish that those who have had problems, had as few a problem I have had, which is almost zero. I don't know why there are some but I think it is corrupt software. It happened on one FW I did and I figured it out and it wasn't the direct problem of the DX50 but what the FW was "telling" it. I downloaded the FW again, extracted and all was fine. 

post #5719 of 15260
Quote:
Originally Posted by sensui123 View Post

A very good improvement.  O2 pairs great with the DX50 from what I listened to with the HD650.  I'm sure it'd be the same with your Westone.

I've heard people say the C5 is like the O2 and I'll be pairing the C5 with the DX50 and the Westone 4r.

I also have the O2 so we'll see. I really want to compare the DX50/C5 and the DX50/BH2, I won't have the C5 until next week though.
Edited by kskwerl - 11/1/13 at 3:45pm
post #5720 of 15260
Quote:
Originally Posted by Mihis View Post
 

Never used a silicone case with any gear I've had. Why cover something so sturdy and why buy something that requires cover from the start? Gotta say I just love this sharp edged beast. Already.

 

 

why? all the usual reasons... keeps it from getting scratched, better grip, and some shock protection for drops.

 

not a necessity by any means but i prefer a lightweight slim case (like silicon) for portables

post #5721 of 15260
Quote:
Originally Posted by jamato8 View Post
 

I can understand that. I only wish that those who have had problems, had as few a problem I have had, which is almost zero. I don't know why there are some but I think it is corrupt software. It happened on one FW I did and I figured it out and it wasn't the direct problem of the DX50 but what the FW was "telling" it. I downloaded the FW again, extracted and all was fine. 

John ar you saying everyone who has a problem on this board has corrupt software. I  not buying into that.   Our other reviewer has a different setup than mine  and is having similar problems. It funny how we can blame the software and maybe it could be for some  an software issue, but  there are so many people having  issues on this thread  and EVEYONE software cannot be corrupt. This is also a first batch player.  I am hoping for another firmware update but we will be writing this review next week and getting it published. I need to report what I am hearing and that is why we are doing a dual review. It sound good when it works properly but it needs to work all the time properly.

post #5722 of 15260
Quote:
Originally Posted by Frank I View Post
 

John ar you saying everyone who has a problem on this board has corrupt software. I  not buying into that.   Our other reviewer has a different setup than mine  and is having similar problems. It funny how we can blame the software and maybe it could be for some  an software issue, but  there are so many people having  issues on this thread  and EVEYONE software cannot be corrupt. This is also a first batch player.  I am hoping for another firmware update but we will be writing this review next week and getting it published. I need to report what I am hearing and that is why we are doing a dual review. It sound good when it works properly but it needs to work all the time properly.

Of course not. Obviously there have been some units that are defective, which is true for about anything ever made by a human. But I do think there is a software problem at times and I have experienced it. I guess I could have phrased what I wrote differently but I also think that with what is in this thread, it is obvious that both defective units have occurred as well as software. 

post #5723 of 15260
Thread Starter 
Today suffering from scanititus, I made the mistake of switching 64gb Sandisk microSD cards and when putting the original back, no more music, genres, database stuff showing. Then I went on the internal mem through the USB and guess what; internal memory had the footprint of the previous card so it never erased the stuff that was in there. To be honest I don't know how the scanning really works but more than one card just do not seem to work that well.
post #5724 of 15260

The reason I am saying if it was the software in this case it would be consistent but it plays goofy at times like one day all the way through  then it will skip songs then I would play that same album all the way through and it wont skip. The artwork is missing on most albnums and not on there. Some albums ar emitting in the DX50 but are on the card. Lots of different things popping up.  I also am hearing lots of hiss  different albums. I am also using a high quality scan disc card.

post #5725 of 15260
Quote:
Originally Posted by Frank I View Post
 

The reason I am saying if it was the software in this case it would be consistent but it plays goofy at times like one day all the way through  then it will skip songs then I would play that same album all the way through and it wont skip. The artwork is missing on most albnums and not on there. Some albums ar emitting in the DX50 but are on the card. Lots of different things popping up.  I also am hearing lots of hiss  different albums. I am also using a high quality scan disc card.

 

I also experienced the hissing, but it went away when I switched to Hi-gain (i dont quite understand the logic, isnt it supposed to hiss more in Hi-gain?)

The sd card scan is a hit and miss, sometimes it works, sometimes it doesnt, and the first time I plugged in, there was no sound, needed to do a factory reset.

 

The player is exceptional when it works. But like what Frank says, it needs to work all the time or it's no good as a player.

post #5726 of 15260
Quote:
Originally Posted by jamato8 View Post

I can understand that. I only wish that those who have had problems, had as few a problem I have had, which is almost zero. I don't know why there are some but I think it is corrupt software. It happened on one FW I did and I figured it out and it wasn't the direct problem of the DX50 but what the FW was "telling" it. I downloaded the FW again, extracted and all was fine. 

Since updating my firmware to v1.2.2, I have had no issues at all. ( Except twice I accidentally hit the DELETE option when trying to add a tune to my playlist)
Hopefully, iBasso will add an "Are you sure" confirmation page for folks with larger fingers!
post #5727 of 15260
Quote:
Originally Posted by jamato8 View Post

I can understand that. I only wish that those who have had problems, had as few a problem I have had, which is almost zero. I don't know why there are some but I think it is corrupt software. It happened on one FW I did and I figured it out and it wasn't the direct problem of the DX50 but what the FW was "telling" it. I downloaded the FW again, extracted and all was fine. 

After updating my firmware to v1.2.2, I have had no issues at all except for accidentally hitting DELETE twice when trying to add some tunes to a playlist mad.gif Hopefully in the future iBasso will add an "Are you sure?" confirmation page to the delete option for us klutzes.
Edited by HiFlight - 11/1/13 at 5:41pm
post #5728 of 15260

This card does NOT fit the DX50 correct?

 

http://www.amazon.com/gp/product/B004XIB9T6/ref=oh_details_o01_s00_i00?ie=UTF8&psc=1

 

I read SDXC and it isnt micro :( LOL

post #5729 of 15260

So, to those DX50 owners who are still deciding which amp to pair with their DX50, I have just updated my review on the C5, and have just added a segment (near the bottom) - giving my opinion on the pairing, and several pictures of the DX/C5 combo for size comparisons:)

 

http://www.head-fi.org/products/jds-labs-c5-headphone-amplifier/reviews/9328

 

 

:beerchug: 


Edited by SkyBleu - 11/1/13 at 6:17pm
post #5730 of 15260

Anyone else trued the DX50 with the RE400s? Not a good sound, bass bleeds right into the mids and its all a mess

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0