Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.5.0 - Page 171

post #2551 of 14782
Quote:
Originally Posted by doki81 View Post

how did you remove it? straight pull out?
 
you know you are suppose to click it in and the card will eject by itself....right?

LOL if someone manage to just pull it out.... but honestly this was what came across my mind when I read that as I can't imagine how otherwise it can be tight.
post #2552 of 14782

Providing the member is removing the card correctly (clicking it in before hand) the only thing I can think of is the DX50 outer casing might not be aligned properly with the card slot, (this has been a known issue on Hisound players) which would make the card hard to remove.

post #2553 of 14782
Quote:
Originally Posted by FatmanSize48 View Post

I read the first 20 pages of the thread and think I'll pick up a LNIB model so I don't have to wait. I'd just like to confirm that ALAC files play smoothly before paying.

plays for me.
post #2554 of 14782
Quote:
Originally Posted by ngyu View Post

how long did the past batches take to ship? Any one from Canada have one? I know the 4th batch is supposed to ship this friday (27th). 

I believe they ship with fedex to CONUS and Canada so probably 3 to 4 days depending on custom clearance.
post #2555 of 14782
Quote:
Originally Posted by kkcc View Post


I believe they ship with fedex to CONUS and Canada so probably 3 to 4 days depending on custom clearance.

 

thanks. how big was the customs hit? i hate those customs fees, especially with UPS. 

post #2556 of 14782
Eject and pull out . . . Ok.
post #2557 of 14782

Well .. after having the DX-50 for several days now.. I can say it has good and bad.. the good is when I am just sitting there listening to all my FLAC based music with my new PSB Headphones and everything around me is just silent..  However the bad is getting to be really frustrating and I was wondering if in fact my unit is somewhat defective..

 

Current situation is:

 

Loaded firmware 1.1.6 for second time (this is a 3rd shipment DX so it already came with 1.1.5 on it) and after doing all the things suggested by folks here, I even reloaded (and reformatted) my 32 GB SD micro card with music again..  So with great anticipation, I plugged in my headphones and started it up.. lo and behold.. the SD scan message came on,, yeah for that.. however it only lasted a few seconds at best.. sure enough, the screens only showed one album (I had loaded around 20) and not even all the songs from that album.. restarted the device and only one other album showed up..   (in album view both times)   so I checked directory view and sure enough all the albums (with all the songs for each) were listed  and now I had to go through the tedious task of going to each album in directory view.. pick a song (upon which the scan sd message would come up for a few moments ) and then the album and all its songs were ready to go.. but I had to do that for each and every album I had loaded..

 

Pretty sure that isn't what was intended but just stuck for any other way to get this to function properly..

 

So... Any and all suggestions will be listened to and attempted in order to get this to be the player it should be

 

Thanks

Don J

post #2558 of 14782
Quote:
Originally Posted by donaldj68 View Post

Well .. after having the DX-50 for several days now.. I can say it has good and bad.. the good is when I am just sitting there listening to all my FLAC based music with my new PSB Headphones and everything around me is just silent..  However the bad is getting to be really frustrating and I was wondering if in fact my unit is somewhat defective..

Current situation is:

Loaded firmware 1.1.6 for second time (this is a 3rd shipment DX so it already came with 1.1.5 on it) and after doing all the things suggested by folks here, I even reloaded (and reformatted) my 32 GB SD micro card with music again..  So with great anticipation, I plugged in my headphones and started it up.. lo and behold.. the SD scan message came on,, yeah for that.. however it only lasted a few seconds at best.. sure enough, the screens only showed one album (I had loaded around 20) and not even all the songs from that album.. restarted the device and only one other album showed up..   (in album view both times)   so I checked directory view and sure enough all the albums (with all the songs for each) were listed  and now I had to go through the tedious task of going to each album in directory view.. pick a song (upon which the scan sd message would come up for a few moments ) and then the album and all its songs were ready to go.. but I had to do that for each and every album I had loaded..

Pretty sure that isn't what was intended but just stuck for any other way to get this to function properly..

So... Any and all suggestions will be listened to and attempted in order to get this to be the player it should be

Thanks
Don J

Seem it hasn't scan the album into the db at all. Just try another factory reset and insert sd then select scan again to start afresh. Else some file/tag/hiddeb systen files etc might be screwing up your scanning.
post #2559 of 14782
Quote:
Originally Posted by ngyu View Post
 

 

thanks. how big was the customs hit? i hate those customs fees, especially with UPS. 

 

Quote:
Originally Posted by kkcc View Post


I believe they ship with fedex to CONUS and Canada so probably 3 to 4 days depending on custom clearance.

 

DHL package came on the 3rd day from when it was shipped I believe. Almost no tax, but brokerage fees came out to be like $14. FedEx would charge around $10. UPS would charge about $40.

FedEx customs clearance is always same day, as with UPS, and DHL. Only CP/EMS may be delayed because there isn't a third party brokerage agent to broker the package through that day. Also, even if the package gets cleared that morning, it may not make it to Canada Post delivery point cut off which is very early in the morning, so it sits at the port til the next day. The good thing about CP is that there is no brokerage fee, and you only pay the tax on it which isn't even $5 in BC. PLUS, you may not even get tagged on the tax because they're very inconsistent about taxing low $ packages.


Edited by Girls Generation - 9/23/13 at 11:13pm
post #2560 of 14782
Is it me or is the sound less harsh and bright. I've had it for about a week now
post #2561 of 14782
Quote:
Originally Posted by spurxiii View Post

Is it me or is the sound less harsh and bright. I've had it for about a week now
you've probably gotten used to the sound.
post #2562 of 14782

Have DX50 on hand for 1 week and I let it random play overnight everyday.

I think the treble is less sibilant (but not obvious) now.

Mid largely stays the same, which I'd prefer to be more forward.

Bass becomes more controlled.

 

Or maybe it's the headphone getting break-in? lol

(DT1350, bought for ~3 months)

post #2563 of 14782
Quote:
Originally Posted by Don Lehrer View Post
 

Hi, I received my DX50 today and I muss say I´m loving it!!! It is quite a change from Cowon, ipod and Sansa Clip. I have to test it with my headphones. I´m glad I did get it no regrets and looking forward to get more impressions.

 

I have the cowon s9 too and waiting for the DX50 to arrive next week..

post #2564 of 14782
Quote:
Originally Posted by spurxiii View Post

Is it me or is the sound less harsh and bright. I've had it for about a week now

 

Definitely not just now as many had reported the same.  Not sure if everyone got their brain burned in as the above poster conjured or the caps got formed and sounded different after a week or two... To be honest I don't even remember what mine sounded like brand new 3 weeks ago.  What I know is I am still loving the sound :)

post #2565 of 14782
Quote:
Originally Posted by kkcc View Post
 

 

Definitely not just now as many had reported the same.  Not sure if everyone got their brain burned in as the above poster conjured or the caps got formed and sounded different after a week or two... To be honest I don't even remember what mine sounded like brand new 3 weeks ago.  What I know is I am still loving the sound :)

 

I remember quite some harshness when I first whacked them on and tried all my phones through them. It was definately clearer and presented more detail than my iphone but certainly harsher. That bit of harshness is all but gone now and all I get is smooth velvety sound and the clarity with detail is still there

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0