Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.5.0 - Page 137

post #2041 of 14997

i have got my dx50 today

post #2042 of 14997
Quote:
Originally Posted by purk View Post
 

Yes, it should be.  However, I continue to have problems mounting the iBasso as mass storage drive.  My laptop & desktop keep not recognizing it as a USB device.  Has anyone else experienced similar problems?  BTW, I reboot my computer as well as turning the DX50 off several times and problem persists.  

 

Yes I get that problem as well. The only time it's been able to recognize it was when I used the usb cable that was provided with the DX50. The one I usually use for devices with that kind of plug doesn't work which is quite strange.

post #2043 of 14997
Quote:
Originally Posted by purk View Post
 

Yes, it should be.  However, I continue to have problems mounting the iBasso as mass storage drive.  My laptop & desktop keep not recognizing it as a USB device.  Has anyone else experienced similar problems?  BTW, I reboot my computer as well as turning the DX50 off several times and problem persists.  

 

ur dx50 need to be on and then only the pc/mac will regconize it..

post #2044 of 14997
Quote:
Originally Posted by purk View Post
 

Yes, it should be.  However, I continue to have problems mounting the iBasso as mass storage drive.  My laptop & desktop keep not recognizing it as a USB device.  Has anyone else experienced similar problems?  BTW, I reboot my computer as well as turning the DX50 off several times and problem persists.  

 

Holy crap, just saw your profile and you have MDR-R10, Qualia 010 AND the Orpheus!!!

post #2045 of 14997
Quote:
Originally Posted by mingus View Post
 

i deleted 2 folders: album_img and LOST.DIR and tried the update twice - no go, update failed. not getting invalid image tho. seems like its updating then just fails. I also did a factory reset before trying.

 

was there any text appeared on the screen when it failed? if possible why don't u take a pic of the screen when you determine the update 'failed', probably some of the guys could help to identify the problem.

post #2046 of 14997

i got the message updates fail during the update but after reset the device.... it show 1.16

post #2047 of 14997
Quote:
Originally Posted by IceOgre View Post


So is the hiss present when using the line out with a separate amp?

 

To clarify:

 

1)  I do hear a hiss with both the TG334 and the Heir 4AI.  Like everyone else, the hiss lessens on gain settings 2 and 3.  Almost non-existent on 3.

2)  There is no hiss with low noise floor amps like Pico Slim and Pico Power, the background is completely black.

 

God this thing sounds good amped, totally different beast.

post #2048 of 14997
Quote:
Originally Posted by sensui123 View Post
 

 

To clarify:

 

1)  I do hear a hiss with both the TG334 and the Heir 4AI.  Like everyone else, the hiss lessens on gain settings 2 and 3.  Almost non-existent on 3.

2)  There is no hiss with low noise floor amps like Pico Slim and Pico Power, the background is completely black.

 

God this thing sounds good amped, totally different beast.

 

+1

:beerchug:

post #2049 of 14997
Quote:
Originally Posted by mingus View Post
 

i deleted 2 folders: album_img and LOST.DIR and tried the update twice - no go, update failed. not getting invalid image tho. seems like its updating then just fails. I also did a factory reset before trying.

 

i would suggest to re-download the update file from one of the mirrors provided by one of the members and try running the update again. maybe the update file that u downloaded is corrupted. 

post #2050 of 14997

Here you go...the DL they sent me today:

 

http://www.ibasso.com/download/DX50Firmware_V1.1.6.zip

post #2051 of 14997
No hiss no matter what phone I try at whatever level
post #2052 of 14997
Quote:
Originally Posted by spurxiii View Post

No hiss no matter what phone I try at whatever level

 

That blows. Send it back.

post #2053 of 14997

Guys... read the readme.txt....

post #2054 of 14997
Quote:
Originally Posted by rawrster View Post
 

 

Yes I get that problem as well. The only time it's been able to recognize it was when I used the usb cable that was provided with the DX50. The one I usually use for devices with that kind of plug doesn't work which is quite strange.

 

I can connect ok and transfer files, I make sure the player is turned on before connecting. I suggest people having problems try another USB port making sure the unit is turned on before connecting. as when I tried with the unit off the very first time, the driver did not install correctly. (I am using the supplied cable btw) Another thing to note is transferring to microsd whilst the player is connected isn't the fastest speeds I've seen, though capable enough.

I would possibly suggest anyone dumping a huge amount of files in one go to use a card reader.


Edited by H20Fidelity - 9/18/13 at 8:42pm
post #2055 of 14997
Quote:
Originally Posted by H20Fidelity View Post
 

 

I can connect ok and transfer files, I make sure the player is turned on before connecting. I suggest people having problems try another USB port making sure the unit is turned on before connecting. as when I tried with the unit off the very first time, the driver did not install correctly. (I am using the supplied cable btw) Another thing to note is transferring to microsd whilst the player is connected isn't the fastest speeds I've seen, though capable enough.

I would possibly suggest anyone dumping a huge amount of files in one go to use a card reader.

 

Absolutely! Use a card reader to transfer a ton of files...it's MUCH faster. 

 
I don't understand the problems with updating the unit...? Put it in root, pull out USB cable, go to Settings, Advanced, Update Firmware, let it run, ( I had to reboot twice by holding down the power button), then go back and Factory Reset. Reboot one more time then done...
 
Here's the Readme.txt
 
Instruction For Firmware upgrade:
1, extract the zip file, and copy the update.img into the DX50;
2, select Settings--->Advanced--->System update (the system update option appears after the DX50 has the update.img inside);
3, click OK to start the firmware update;
4, after the firmware update completed, select Settings--->Advanced--->Factory Reset to reset the DX50;
5, delete the update.img.
 
Steve from NYC
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0