Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.5.0 - Page 990

post #14836 of 14843

iBasso site down for about a week. Are they still up-and-running ? Was looking to buy the DX50 DAP + a portable amp off them.

post #14837 of 14843
Quote:
Originally Posted by CoiL View Post
 


rockbox is totally different open source OS with different UI. I tried it and for me it`s too messy and sounds worse than Sound Unlocked 1.3.3 @ flac-only / irr off / cpu-default.

Quote:
Originally Posted by gmahler2u View Post
 

Thank you for the valuable info.  I'll keep my schiit happy with...:biggrin:  (.5 off flac only 312)

 

BTW, SU is just original iBasso 1.5.0 FW with couple of SQ tweaks.

post #14838 of 14843

At the end of each month iBasso apparently doesn't pay for it's website for the next month and it goes down.  Then it comes back up.  Weird.  

 

You can use the Sound Unlocked 1.3.3 with all "extras" set to OFF and that will be close to 1.5 stock.sound.

 

I, too, did not like Rockbox.  UI and sound did not please me.  Sound Unlocked has all of the good things that come with 1.5, with just a few tweaks that make it better (and no eq adjustments that artificially alter things).  

 

As for buying an iBasso, I bought mine from a 2nd-party retailer here in the US.  Don't know how that would work in Asia. 

post #14839 of 14843

I got mine from a seller here. Saved a lot of money from buying new and it was in mint condition.

post #14840 of 14843
Quote:
Originally Posted by chailee80 View Post
 

Sounds like a strange issue, i get no distortion when i plug my headphones (ultrasone signature dj) into my line out. The only slight issue i encountered was when i did plug my cans in i didnt get both channels because the plugs rings didnt quite line up because it was a 4 pole 3.5mm plug. Pulling the plug out a little bit fixed the issue. However plugging that same cable into the headphone out gives me no issues and i do not have to pull it out a little bit to get normal sound.

I also tried my ultrasone dj1 pro's which have a regular 3.5mm plug in the line out and i hear no noticeable distortion.

Yea, my DX50 suddenly has this problem. Hopefully it gets resolved soon. Does anyone else have an issue with the line out?

post #14841 of 14843
Quote:
Originally Posted by medmitry View Post
 
Quote:
Originally Posted by Yanec View Post
 

 

Comparing it to the STX means the DX50 is really shining!

 

What is the differences in sound signature due to in .3 vs .4 vs .5 ? What filters or libraries did you remove/modify and what was their effect?

 

Last version means that nothing more can be done to improve the sound even further in the direction of neutrality and pure professional flat signature - am I right? Nothing left to take out of the path in terms to improve the sound tract?

 

Cheers!

I can't give you simple answers :) (PM you later)

 

Quote:
Originally Posted by CoiL View Post
 

Oh forgot... I hope You are kind enough and still have energy to add 24h backlight ON setting instead 10min. Would be great to use it on table stand like this ;)

 

I remember it.

BTW it can be done in your personal version of SU :)

Would you be able to PM me as well? I'm curious about the differences myself.

post #14842 of 14843
Hi guys, so after not touching my DX50 for nearly a month I decided to take it out and install Sound Unlocked on it. As I had totally forgotten on how to install custom firmware on it... I sorta screwed up. I had rockbox (set to boot up to rockbox only via a .zip I installed) installed on it and I accidentally installed stock_recovery.zip without uninstalling the .zip I mentioned. So now I'm stuck with rockbox and the stock recovery, unable to flash any .zips or .imgs into ny device. I tried using rkbatchtool, but I can't seem to get the drivers installed. This is what is shown in my device manager:

And when I try to install the rockchip driver for it, it just gives me this:


Does anyone know how do I fix this? Thanks.

EDIT: My device manager also mentions something about a code 43.

EDIT 2: -.- It turned out that my computer had an error. Switched to a different computer and everything went smoothly. Anyway, does anyone know what is causing that error on my computer?
Edited by hikari50 - Today at 2:07 am
post #14843 of 14843
The FW 1.5.0 sounds quite pleasant to me.

I bought it used, and just found out the back screws are missing and how easy is it to pop open the back. Should I be worry about it, it will be more solid if the screws were on.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0