Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.5.0 - Page 9

post #121 of 14846
Quote:
Originally Posted by Jpfe8851 View Post



+1

When I moved away from using iTunes to rip my songs, I had to spend a good deal of time cleaning out legacy Apple junk form the tags and fixing Album art. Before doing that, I had all sorts of database scan issues, and freezes with my DX100, AK100 and even Poweramp stability on my Android phone. Highly recommend cleaning out your tags no matter what your flavour of DAP.

PS. Got an email from iBasso. The second batch is being dispatched today and Monday.

Am I only one from the first batch who never got any shipping status or tracking ?

post #122 of 14846
Quote:
Originally Posted by santhoshr View Post

Am I only one from the first batch who never got any shipping status or tracking ?
I just got it today. Shoot them an email.
post #123 of 14846
can anybody confirm how file browser works with micro sd?

am i able to have to folders on the sd card one as flac & one as mp3 and the dx50 browse by file then play the album i choose?
post #124 of 14846
Quote:
Originally Posted by doki81 View Post

what do you mean by cleaning the tags?
I'm going to assume you know what ID3 tags are. If not, use your favourite search engine to read up on them.

By Cleaning your Tags, I mean to get rid of nonstandard tag entries, not just the contents but removing the entry too. I've found some rippers including Apple's embedded one in iTunes, adds some tags that some players don't recognise. Apple assumes your ripped file will only be player on an apple device. Best getting rid of these.

That can be done with any decent tag editor. I use DBPoweramp and Media Monkey to successfully edit my track tags. Also, cleaning involves filling important tags like artist, album artist, track number, Title as well as file name, track number, consistent album names, compilation tag where applicable, gapless properties and so on.... Finally ensure your album art is not oversized and in a standard format like jpeg.
post #125 of 14846
I called DHL with my tracking number. They no longer deliver on weekends in the US, but my estimated delivery date is Monday. Also, a signature is required. If no one will be there (and you feel the neighborhood is safe), you can leave a signed note with the tracking number and they will leave the parcel without a signature.
post #126 of 14846

Try this Tag Editor

 

http://www.mp3tag.de/en/

post #127 of 14846
Quote:
Originally Posted by lin0003 View Post


I just got it today. Shoot them an email.

Did that, got reply with tracking no. Went to DHL site, it says: Shipment information received! Looks like last minute shipment after my mail, anyway looking forward to DX50!

post #128 of 14846
Quote:
Originally Posted by kryten123 View Post
 

Try this Tag Editor

 

http://www.mp3tag.de/en/

 

Excellent one!

I use it together with this:

http://sourceforge.net/projects/iaae/

(Album Art Extractor)

post #129 of 14846

I am so glad I didn't pull the trigger on the X3 over the DX50. It looks amazing.

post #130 of 14846

Anyone knows how it performs vs a rockboxed ipod?

post #131 of 14846
Thread Starter 
Quote:
Originally Posted by huckfinn View Post

Anyone knows how it performs vs a rockboxed ipod?

I am planning to test that once I got mine. I will be comparing my iMod versus the DX50 as soon as I get it of course. biggrin.gif
post #132 of 14846

Just received my dx50 today (first batch). Looks and feels good. If I can get it to work properly I will be comparing it with my cuurent set-up (ipod nano + ibasso PB2). ButI 'm having a lot of trouble to get it working consistently. I'm playing alac and flac files. The file is playing but no sound sometimes. Very frustating because the same files will play sometimes and sometimes not. No clue why.

btw funny thing: the back/play/forward buttons are from right to left.

post #133 of 14846
Quote:
Originally Posted by armeko View Post

Just received my dx50 today (first batch). Looks and feels good. If I can get it to work properly I will be comparing it with my cuurent set-up (ipod nano + ibasso PB2). ButI 'm having a lot of trouble to get it working consistently. I'm playing alac and flac files. The file is playing but no sound sometimes. Very frustating because the same files will play sometimes and sometimes not. No clue why.
btw funny thing: the back/play/forward buttons are from right to left.
Not funny! I don't know how these guys can screw basic thing such as this! Considering you are referring to physical buttons.
post #134 of 14846
Quote:
Originally Posted by armeko View Post
 

Just received my dx50 today (first batch). Looks and feels good. If I can get it to work properly I will be comparing it with my cuurent set-up (ipod nano + ibasso PB2). ButI 'm having a lot of trouble to get it working consistently. I'm playing alac and flac files. The file is playing but no sound sometimes. Very frustating because the same files will play sometimes and sometimes not. No clue why.

btw funny thing: the back/play/forward buttons are from right to left.

 

Definitely not for my unit....Right button is FW, Centre is Play/Stop, Left is RW

Didn't have the "no sound" issue but I'm not using ALAC.  MP3. FLAC, WAV of various bit rates all working fine for me.

 

Only three issues I have had with my 8 hr or so usage: 1) some wacky ordering of tracks in folder/album.  2) a quirky behavior where if you play say the 5th tracks in a folder, press FW, it would always go to the 1st track inside the folder.  Subsequent FW will go to next track correctly. This doesn't happen in Album mode - only  happen in Folder nav.  3) left right channel is suddenly reversed , back to normal after restarting, had this ONE time and cannot reproduce this.

 

No hang/freeze/restart.  UI is surprisingly fluid and responsive.


Edited by kkcc - 9/6/13 at 10:08am
post #135 of 14846

Mine just completely froze up just now, can't even shut it down.

 

Update: I contacted ibasso and got a reply right away. If you hold the power button for 7 seconds it will reset. This also got rid of the strange/inconsistent behaviour earlier. Smooth interface now. Sound is on the bright side, but it also showed the limitations of my ue700. The grado325is and hifiman 500 performed quite well.


Edited by armeko - 9/6/13 at 11:08am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0