Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.5.0 - Page 744

post #11146 of 14968

i got mine with 1.2.5 and upgraded with each new FW without any issues with Volume

post #11147 of 14968
Quote:
Originally Posted by geagle View Post

Personally, I believe that headphones and source quality make the most difference in sound quality, followed by amps and (quite a bit further down the road) cables… I've bought a lot of amps, and, really, the main job of an amp is to get out of the way and, well, amplify the signal… there may be sound signature differences, some of them have hardware boosts to treble/bass/crossfeed/soundstage (and these do work, but they also alter the sound - if you like the alterations, fine, your ears should be the best judge), but, to my ears, amps usually do NOT completely change the fundamental characteristics of a headphone (unless, maybe, you go balanced - I have no experience with that, but Sorensiim reported very good results with his Noble K10, with improvements in soundstage too - on the other the K10 is already a TOTL CIEM, of course:smile: ).

If I were you, I would look into upgrading my headphones, first, either by going to ljokerl's large thread on IEMs (if you want to stick with IEMs) and selecting one particularly suited to your preferences and within your budget (and comparing it to what you already have), or changing altogether and getting some open headphones.

Best of luck in your search!

PS: if you really are set on getting an amp, you might want to try C&C BH2 - there's a large thread on that too tat you might want to have a look at, it's cheap (<$100), has a couple of hardware switches which enhance both bass and treble and soundstage, and it's really good for the money. There are a lot of better amps, but they also all cost a lot more:wink_face:  (and I actually found myself using it more often than my Arrow 4G or my Pico Power, with N6 IEMs with FW 1.2.6, while with 1.2.8 I don't use an amp - needless to say, YMMV, and I still think that you'd be better off by upgrading your 'phones:smile:  first)
Thank guys, I think I will try with some cheap solutions like C&C BH2 or Portable version of O2 first (There is a guy in my country makes a portable version of O2 which has the same sound signature as original one but only cost $50) and save my money for future IEM upgrade.
post #11148 of 14968
Quote:
Originally Posted by eduardo1969 View Post

I totally agree.I want to buy another set of headphones for using with the p5 ,but a bit more comfortable and for home use .
But I really don't know what to choose ,that much I like them ....
And I don't want to by an amp when sound is not so good with the new spare headsets....
Thinking of akg k545..for better soundstage but I don't want to lose the way bass sounds on the p5

 

I agree with you that p5 could be more comfortable for home use. I don't have experience with the akg k545, but am curious if this combination have a better soundstage than the p5 - dx50.

post #11149 of 14968
Quote:
Originally Posted by Shinigami View Post
 

Anyone here have experienced a sudden increase in volume with the 1.2.8 FW? I have read a report that some dx50 owners have experienced this in older FWs. This is actually what I am afraid of and this whats holding me back ...I am planning to use my SE535 and i don't want my eardrums get busted because of this issue. Thanks a lot

 

I did yesterday (well, my gf did). Beats me what made it do it, but it was pretty weird. I tried to reproduce it so i could see what did that, but nothing. It is pretty worrying, considering i'm using my IM70's with the DX50 now, and a sudden spike on volume could hurt like hell...

post #11150 of 14968
For testing a headphone or a dap i usally listen to a 3d sound example on youtube you can search by" 3d virtual hearcut barbershop " ,don't know if the link is working ..
With this i hear exacly the places of the people
Do anybody know another clip ? to test the soundstage?

http://www.youtube.com/watch?v=8IXm6SuUigI
post #11151 of 14968

While I haven't been having any issues with my DX50 for like a couple months now, I do say i wish they'd either remove the feature iBasso added to where it saves where a track stopped at when the device was turned off, or at least fix it to function more seamlessly.  It seems to save its location a little too well, and almost 100% of the time I never play a song from where it is when I turn it on but I do often restart the song.  Can't just push play anymore and expect it to start from the beginning, and you can't hit back either and then hit play as that actually goes back to the previous song.

 

What's more interesting that if you never do continue where you left off on that particular song, the device saves this so that even if you went onto play different songs and then returned to the original song the device turned on at and push play it still starts it from where it was at when you last turned the device off.  This is rather annoying, I feel it should clear this information the second you play something else.  

 

It's a feature I'd much rather not even have, or at least have a nice option to turn it off all together.  Only option iBasso provided is downgrading firmwares.  :(

post #11152 of 14968
Mannn... My DX50 still skips the first like second and a half of a song... Anyone know how to fix?
post #11153 of 14968
Dx50 paired with RSA shadow isn't what I hoped. Using shure 535, dx50 sounds better without it.
Anyone else amping with the shadow?
Bass is muddy to my ears, sounds cleaner without...
post #11154 of 14968
Quote:
Originally Posted by wickson View Post

Dx50 paired with RSA shadow isn't what I hoped. Using shure 535, dx50 sounds better without it.
Anyone else amping with the shadow?
Bass is muddy to my ears, sounds cleaner without...

That was my finding as well. I have since sold my Shadow.
post #11155 of 14968
Quote:
Originally Posted by HiFlight View Post

That was my finding as well. I have since sold my Shadow.

What amp are you using now, if any?
The for sale section seems flooded with RSA shadows lately.
Might wait to unload it.
post #11156 of 14968
Quote:
Originally Posted by wickson View Post

Dx50 paired with RSA shadow isn't what I hoped. Using shure 535, dx50 sounds better without it.
Anyone else amping with the shadow?
Bass is muddy to my ears, sounds cleaner without...

 

I have my Shadow/DX50 paired up with my Shure SE846.  I love it.  It sounds better than the Shadow paired with my Sony F series.  I also tried a vamp at a meet, I liked the shadow better. I don't find the low end muddy at all. Maybe I'll try it with some of my other IEMs and see what I find.

post #11157 of 14968
I prefer my P51 mustang with DX50 than shadow
post #11158 of 14968
Quote:
Originally Posted by Kukyo View Post

I did yesterday (well, my gf did). Beats me what made it do it, but it was pretty weird. I tried to reproduce it so i could see what did that, but nothing. It is pretty worrying, considering i'm using my IM70's with the DX50 now, and a sudden spike on volume could hurt like hell...

Thanks for the report. Guess thats it, as much as i want to buy dx50, due to this issue, i decided i will no longer dx50. I'll just wait for dx90 and x5. Thanks a lot smily_headphones1.gif
post #11159 of 14968

Am I the only one having issues with the playback order on 1.2.8? :frown:

post #11160 of 14968
Quote:
Originally Posted by Sorensiim View Post
 

Using the analog line out if the active speakers have analog inputs :smile: 

 

 

I'm working on a plan for doing the same thing. I have everything I need, except the speakers.

I couldn't live with that. I just jumped on a pretty good deal for these puppies. Now the waiting game begins...

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0