Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.5.0 - Page 738

post #11056 of 14841
Thread Starter 
Quote:
Originally Posted by SkyBleu View Post
 

Yeah, possibly, but it is dying at a slightly faster rate! Like, I used to charge my DX50 once a week, now it's like twice a week...Unless..I'm actually using it more lol

 

I might grab a Samsung battery as some of you say good things about it, but has anyone tried the long-life Mugen Power batteries?


Interesting, I was never able to go by with one weekly charge so congrats for it lasting that long. I used to sweat the small stuff before but realized that I don't have that many electronic items that last as long, my iPhone is a joke I charge it daily else it'll go flat. One thing is for sure, I prefer having an external battery instead of internal, at least this way you can exchange it with whatever you want (options).

post #11057 of 14841
Quote:
Originally Posted by SkyBleu View Post

I might grab a Samsung battery as some of you say good things about it, but has anyone tried the long-life Mugen Power batteries?

The high capacity battery packs won't fit. They're thicker than the standard capacity batteries.
post #11058 of 14841
Quote:
Originally Posted by musicheaven View Post
 


Interesting, I was never able to go by with one weekly charge so congrats for it lasting that long. I used to sweat the small stuff before but realized that I don't have that many electronic items that last as long, my iPhone is a joke I charge it daily else it'll go flat. One thing is for sure, I prefer having an external battery instead of internal, at least this way you can exchange it with whatever you want (options).

Yeah, that is true. My Nexus 4's battery life is an absolute joke as well. Before the day even ends, it already requires a charge, so I suppose that I should be at least happy that my DX lasts a bit longer. I suppose an external battery pack is something I should look into.

 

Quote:

Originally Posted by ratinox View Post


The high capacity battery packs won't fit. They're thicker than the standard capacity batteries.
 

Thanks for notifying and confirming:)

post #11059 of 14841

i just noticed something , when i don't use gapless mode i hear clicks between songs.

if i do i don't weird.

post #11060 of 14841

just updated to 1.2.8 and found my bass totally gone. Am I missing something here? Pls advise. Thank you.

post #11061 of 14841
+1

Would like to have a sensitive L/R channel balance slider. Micro adjustment of channel balances for my unbalanced ears biggrin.gif

And of course, crossfade option would be nice.

On a further note, playlist doesnt seem to work for me anymore ln 1.2.8. Sounded pretty much the same as 1.2.6, with perhaps a tiny tiny tiny bit stronger low freq bass.

Quote:
Originally Posted by xnuthecaveman View Post

Agree, a poll would be good. It worked for Fiio

Aside from the request, aside from the already mentioned, please add L/R balance control wink.gif
post #11062 of 14841
Happens to all DX50. This was documented quite a while ago.
Quote:
Originally Posted by ScreenKiller View Post

i just noticed something , when i don't use gapless mode i hear clicks between songs.
if i do i don't weird.
post #11063 of 14841
Quote:
Originally Posted by michaelang View Post
 

just updated to 1.2.8 and found my bass totally gone. Am I missing something here? Pls advise. Thank you.

 

I didn't notice it at first, but that was my finding as well when I A/Bed it with 1.2.5. Non-EQed, it didn't seem to go very low at all.

post #11064 of 14841
Quote:
Originally Posted by musicheaven View Post
 

I got a question for all of you out there with the FW 1.2.8.

 

Did you have this problem: A song just finished, another started and the volume, all out of the blue, increased at a good pace to what seems to be max but when looking at the volume level indicator, it is no where close to max.

Fortunately I had my HD600 on so the volume got loud but not to the point of going deaf, I took them out nonetheless. I am not too happy about that. :mad: 

 

Unfortunately I can't reproduce it all the time, it seems random. Not sure what to do at this point, maybe going back to 1.2.7 and definitively leave a message to iBasso.

 

edit: kept 1.2.8 and going through the LO/amp route again.

 

That´s happend to me with different FWs, even with 1.2.7 while using an USB memory with an OTG cable.

 

Quote:

Originally Posted by TheMaestro335 View Post


This has happened to me on every firmware I have tried! Until ibasso isolates the problem it will continue to appear.

Please do something about it iBasso!!!

Quote:
Originally Posted by TheMaestro335 View Post


Interesting because this only happens to me when I put the player in shuffle mode. But the increase in volume could make you deaf. So this could be potentially a very serious problem.

 

  I like this amazing player but I´m afraid this is a serious problem.!!!

Quote:
Originally Posted by musicheaven View Post
 

If my memory serves me well, it might have happened one time with an older firmware but they were aware of it and fixed it. It never happened again.

I have already reloaded the firmware twice but like you said, I am going to do it again, take no chances.

+1

post #11065 of 14841

If you guys find the edges of the DX50 too sharp, I can't recommend enough the iBasso $8 rubber case. It's super smooth and fits snug.

And unlike the firmware updates, it does not change the sound ;)

post #11066 of 14841
Quote:
Originally Posted by DeepGroove View Post
 

If you guys find the edges of the DX50 too sharp, I can't recommend enough the iBasso $8 rubber case. It's super smooth and fits snug.

And unlike the firmware updates, it does not change the sound ;)

I found my silicone case to give my DX50 a more pronounced treble and a more resilient bass response. ;)

post #11067 of 14841
Quote:
Originally Posted by SkyBleu View Post
 

I found my silicone case to give my DX50 a more pronounced treble and a more resilient bass response. ;)

I found it dampened the sound a bit...:veryevil:

Cheers!:beerchug:

-HK sends

post #11068 of 14841

how long will the fw update take? i do it for the first time and when i hit "yes" to update, all that happens is i get the "see you soon" screen and thats all. it stays on with this screen. is that the usual behavior? 

post #11069 of 14841
Quote:
Originally Posted by sofastreamer View Post
 

how long will the fw update take? i do it for the first time and when i hit "yes" to update, all that happens is i get the "see you soon" screen and thats all. it stays on with this screen. is that the usual behavior? 

For me, it usually shuts off (as you said), and then it boots up again in a black background, with yellow text, and it runs/shows its progress, and once its done, the player will reboot back to the usual load-up.

post #11070 of 14841

i fixed it yet. had to do a factory reset first for any reason. update works now.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0