Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.5.0 - Page 699

post #10471 of 15133
Some albums are sorted Alphabetically, does that mean they are tagged incorrectly?
post #10472 of 15133

a bug maybe? the way it lows the amp secction. and because on Hi gain its just thowing all the power without any restriction. so, im guessing on the restriction is the bug.

it is all thinking i have made, please anyone with knowledge can give us a hand.

What firmware you are using?

im thinking, on next week when my dx50 arrives, im upgrading to the 1.2.7 out of the box

post #10473 of 15133
Quote:
Originally Posted by Marco Angel View Post

a bug maybe?

Not a bug, just basic electronics and headphones that are too sensitive for DX50's amplifier.
post #10474 of 15133
Quote:
Originally Posted by Marco Angel View Post
 

a bug maybe? the way it lows the amp secction. and because on Hi gain its just thowing all the power without any restriction. so, im guessing on the restriction is the bug.

it is all thinking i have made, please anyone with knowledge can give us a hand.

What firmware you are using?

im thinking, on next week when my dx50 arrives, im upgrading to the 1.2.7 out of the box

your dx50 is coming next week? did you order from ibasso themselves?

if you got one of the 14th batch they come with 1.2.6 OTB.

post #10475 of 15133
Quote:
Originally Posted by ScreenKiller View Post

your dx50 is coming next week? did you order from ibasso themselves?
if you got one of the 14th batch they come with 1.2.6 OTB.
i bought it from mp4nation, so I'm guessing I'm not receiving the latest.
beside the firmware, how do you can see which batch is it?
post #10476 of 15133
Quote:
Originally Posted by Marco Angel View Post

i bought it from mp4nation, so I'm guessing I'm not receiving the latest.
beside the firmware, how do you can see which batch is it?

I'm not sure if the batch number is actually kept anywhere but IBasso, many companies use Rev. 1-2-3 numbers to denote hardware changes. I have not seen any of those on the Dap.Otherwise the firmware should give you an estimate of the batch number. I ordered mine from mp4 nation also. It took a while, they were waiting on IBasso, but when they got the units they sent it 2 day air DHL.
Mine was loaded with the latest firmware at the time. Since it looks like they are waiting on an Ibasso shipment again, my guess is your will be fresh from the oven and still warm.biggrin.gif

Cheers,
Shawn
post #10477 of 15133
Quote:
Originally Posted by Marco Angel View Post
 

Power wise is no relevant when paired vs a sensitive ear-inear. What i think it changes on your setup is the warmness form the external amp (or it signature)

Im quite fine using an X3 and waiting to the dx50 with my sony ex600 =)
What changes do you hear on your dx50 vs dx50-amp?

 

 

Quote:
Originally Posted by MusicFiMan View Post
 

HI,

on low gain i hear like the LOW gotten all the mids to get higher and all the clearness has gone. after i switch to HIGH, i hear exactly as i hear without the amp, all the cleanses is back and sound stage is exactly has i hear it without the amp it self.  it seems like something bugs the low gain in the amp but gets cleared on HIGH. strange thing or logic if you understands what happens when IEMs' with Sensitivity: 107 dB SPL @1mW meets the amp with Input Impedance:10KOhms.

 

Appropriate the help on this.

Wait,are you guys talking about the DX50's gain setting or the gain setting of the external amp?

post #10478 of 15133
Quote:
Originally Posted by Skp44 View Post


I'm not sure if the batch number is actually kept anywhere but IBasso, many companies use Rev. 1-2-3 numbers to denote hardware changes. I have not seen any of those on the Dap.Otherwise the firmware should give you an estimate of the batch number. I ordered mine from mp4 nation also. It took a while, they were waiting on IBasso, but when they got the units they sent it 2 day air DHL.
Mine was loaded with the latest firmware at the time. Since it looks like they are waiting on an Ibasso shipment again, my guess is your will be fresh from the oven and still warm.biggrin.gif

Cheers,
Shawn

Since launch, there has been a grand total of 0 (zero, none, nada, zilch) hardware changes on the DX50 so I think we can safely skip the batch talk now :smile:

post #10479 of 15133

hummm, it seems my order just update into a "preorder" status, im contacting mp4nation so can tell me what is going on, it was supposed to ship today via fedex =/

I guess im reciving from the latest batch

post #10480 of 15133
Quote:
Originally Posted by Sorensiim View Post

Since launch, there has been a grand total of 0 (zero, none, nada, zilch) hardware changes on the DX50 so I think we can safely skip the batch talk now smile.gif

No hardware revisions is a good thing. Just a little FYI to anyone using SDXC cards, I got a couple of more affordable Kingston 128gb cards and had trouble using them. Detection problems, and just not reliable. I was ready to write them off, but a friend told me to try formatting them with a free utility available at sdcard.org. Worked great, both cards are operating properly!

Cheers,
Shawn
post #10481 of 15133
Quote:
Originally Posted by Sorensiim View Post
 

 

 

Wait,are you guys talking about the DX50's gain setting or the gain setting of the external amp?

about the gain settings on the dx50.
 im testing how it behave on my in-ear and headphones =)

post #10482 of 15133
Quote:
Originally Posted by Marco Angel View Post
 

about the gain settings on the dx50.
 im testing how it behave on my in-ear and headphones =)

If you connect your headphones through the line out on the the DX50 to an amplifier, the gain setting on the DX50  has no effect (although the volume does)… if the gain setting on the DX50 DOES have an effect, this means that you're connecting the DX50's phone out to the amplifier, which is double-amping, and is not really very good:wink_face:

post #10483 of 15133
Quote:
Originally Posted by geagle View Post
 

If you connect your headphones through the line out on the the DX50 to an amplifier, the gain setting on the DX50  has no effect (although the volume does)… if the gain setting on the DX50 DOES have an effect, this means that you're connecting the DX50's phone out to the amplifier, which is double-amping, and is not really very good:wink_face:


yeah, that's what I thought when I read his post...

post #10484 of 15133

No replay gain on next update.. (I don't think it will be there for some time..)

 

#######

Hi,
We dont have plan to add the replaygain.
 
Sincerely
iBasso Audio
 
2014/1/24

Hi,

 
I would like to ask if you are planning to include 'replaygain' in the next update?
 
 
post #10485 of 15133
Quote:
Originally Posted by Varoudis View Post

No replay gain on next update.. (I don't think it will be there for some time..)

That's a pity given how simple it is to implement on the playback side: read ReplayGain tag (track or album versions) from file, adjust output volume by that value, repeat for next track. Not having ReplayGain is one of two things I consider to be significant failings in the player.

The other is any kind of sane playlist support.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0