Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.2.8
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.2.8 - Page 298

post #4456 of 12681

Mine's dead. :(

 

 

dx50a.jpg 

post #4457 of 12681

ooooooch nasty :(

post #4458 of 12681
Quote:
Originally Posted by Marleybob217 View Post

Is it me, or does the DX50 have trouble correctly driving > quad-driver-IEMs? The 2 BA IEM BA200 sounds really nice from the DX50. It doesn't sound worse, then when connected to my audinst hud-mx1. But my 4 BA cIEM the BA4f, sounds fairly bad on the DX50. Very small soundstage, overall less clarity and seperation compared to my audinst hud-mx1. But the closed headphone from german maestro sounds good through the DX50 albeit a little bright.

I'm really itching towards buying a good, small portable amp with for the DX50. I'm looking mainly at the iBasso D-Zero and C&C BH, does anyone else have some input on the matter? No >$200 amps please smily_headphones1.gif 

Oh, and if anyone knows of a Europe based seller, that would be awesome. Sorry for derailing.

The D-Zero is a very nice match and neatly fits the back of the DX50.
post #4459 of 12681
Quote:
Originally Posted by HiFlight View Post


The D-Zero is a very nice match and neatly fits the back of the DX50.

That makes so much sense, an inexpensive dap paired with an inexpensive amp providing nice match, sounds like a perfect match. :L3000:

post #4460 of 12681
Quote:
Originally Posted by Pottsy2 View Post
 

Mine's dead. :(

 

 

dx50a.jpg

Wooooo, that looks nasty. Never seen it going so bad. You said earlier you had it working and you were listening to music. What happened since that time and now, have you done anything to it, like updating the firmware?

post #4461 of 12681
Quote:
Originally Posted by Pottsy2 View Post
 

Mine's dead. :(

 

 

dx50a.jpg 

:D
Sorry, but this looks too funny!
Tried pulling the battery out?

post #4462 of 12681
Quote:
Originally Posted by musicheaven View Post
 

That makes so much sense, an inexpensive dap paired with an inexpensive amp providing nice match, sounds like a perfect match. :L3000:

 

Quote:
Originally Posted by HiFlight View Post


The D-Zero is a very nice match and neatly fits the back of the DX50.

The CEO from cosmic ears, actually reported that my cIEM model and this dac/amp has very nice synergy. So he's actually sending one to me, so I can test it!

 

The added dac of the D-zero is really redundant in this setup, but if the synergy works, who am I to complain.

post #4463 of 12681
Anyone experiencing a weird sound when going from song to song be it manually or automatically? It does not happen every time but a few times every hour.
post #4464 of 12681
Quote:
Originally Posted by musicheaven View Post
 

Wooooo, that looks nasty. Never seen it going so bad. You said earlier you had it working and you were listening to music. What happened since that time and now, have you done anything to it, like updating the firmware?

No, I simply turned it off last night (where it was fine) and turned it on this morning and it was broken. All screens are like that, including the recovery menu. I have tried full reset, battery out etc, but it just looks like a nasty and irretrievable hardware failure.

 

post #4465 of 12681
Quote:
Originally Posted by Marleybob217 View Post
 

Is it me, or does the DX50 have trouble correctly driving > quad-driver-IEMs? The 2 BA IEM BA200 sounds really nice from the DX50. It doesn't sound worse, then when connected to my audinst hud-mx1. But my 4 BA cIEM the BA4f, sounds fairly bad on the DX50. Very small soundstage, overall less clarity and seperation compared to my audinst hud-mx1. But the closed headphone from german maestro sounds good through the DX50 albeit a little bright.

 

I'm really itching towards buying a good, small portable amp with for the DX50. I'm looking mainly at the iBasso D-Zero and C&C BH, does anyone else have some input on the matter? No >$200 amps please :) 
Oh, and if anyone knows of a Europe based seller, that would be awesome. Sorry for derailing.

 

European sellers are few and far between :) Advancedmp3 in the UK have it listed on their site at a preorder cost of 199£ sterling but don't know when it will arrive in stock,Mp4audio in Germany sell for a tasty fee of 299euros.. I cancellled my order with Ibasso and placed an order with Headphoniaks in Spain for 210euros,works out a small bit more than buying direct from Ibasso but when in the EU I would nearly rather pay a small bit extra knowing you wont get stung by customs charges when its imported into your country...

 

Another reason I preferred an EU seller is that if anything did go wrong with the dap,I could just send it to them and have it replaced,refunded etc..

 

Hope this helps...

post #4466 of 12681
Quote:
Originally Posted by Maxloire View Post

Anyway bro.. I paired my dx50 with brainwavz b2, do you think i need a portable amp?.. I'm eyeing to fiio e12 and jds c5.. Does it make any sq improvement?

I suggest you check out Tralucent T1. HUGE improvement in SQ smily_headphones1.gif
post #4467 of 12681
Quote:
Originally Posted by Pottsy2 View Post

No, I simply turned it off last night (where it was fine) and turned it on this morning and it was broken. All screens are like that, including the recovery menu. I have tried full reset, battery out etc, but it just looks like a nasty and irretrievable hardware failure.



If you tried everything including battery removal you might be stuck with either returning the dap for a replacement or refund. With that kind of screen, it makes it hard to even reload the firmware. I am curious though do you also get this screwy screen if you put the dap in recovery mode?
post #4468 of 12681
Looks like my DX50's dead too.

Screen off:


Screen on:
post #4469 of 12681
Quote:
Originally Posted by wizard327 View Post


I suggest you check out Tralucent T1. HUGE improvement in SQ smily_headphones1.gif


Why spend all that $$  (twice the price, not twice the sound) when BH2 is a wonderful pairing with the DX50

post #4470 of 12681

my Dx50 has been hanging since i tried upgrading firmware 1.20.   Is there any way to do hard reset?   On/Off and removing battery seems useless.   Appreciate any advise to bring it back to life..... Thanks.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.2.8