New Posts  All Forums:Forum Nav:

Two broken Nu-Forces!

post #1 of 3
Thread Starter 
So, I love these headphones (Nu-Force NE 700 M), but I have now gotten two messed up pairs. Besides not being too loud (I have to have it at 75% at least), the left ear in the 1st one was broken after a few days (taking care of them too, keeping them in case etc.), and the second one, Siri keeps coming up with the volume control button, and I am not clicking it. Just putting this out there, though I've read great reviews. I hate to say this but my Skullcandy 50/50s I had were more reliable than this.
post #2 of 3

The second one isn't broken.  The problem is that the headphones you have and your iPod use different headset standards.  The Nuforce is using the older OMTP standard while Apple devices use CTIA (which is now pretty much the industry standard).

 

You will need something like this: http://www.lunashops.co.uk/goods.php?id=1073

 

Or this one:  http://www.amazon.com/Sony-EC250-Headphones-Adaptor-1249-0456/dp/B009HW15UG/ref=sr_1_1?ie=UTF8&qid=1377663537&sr=8-1&keywords=sony+ec250

 

If you don't care about using the microphone, you can go to Radio Shack and get a short inline volume control cable or 90 degree plug adapter, they'll do the same thing.

post #3 of 3
Quote:
Originally Posted by Bobz216 View Post

So, I love these headphones (Nu-Force NE 700 M), but I have now gotten two messed up pairs. Besides not being too loud (I have to have it at 75% at least), the left ear in the 1st one was broken after a few days (taking care of them too, keeping them in case etc.), and the second one, Siri keeps coming up with the volume control button, and I am not clicking it. Just putting this out there, though I've read great reviews. I hate to say this but my Skullcandy 50/50s I had were more reliable than this.

 

Are you using the new and improved version? Or the old version?

New Posts  All Forums:Forum Nav: