or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Valab NOS dac sound output distorting
New Posts  All Forums:Forum Nav:

Valab NOS dac sound output distorting

post #1 of 3
Thread Starter 
Awoke to my Valab NOS dac hissing very loudly with a clicking sound ,my heart sunk,turned down the amp,played some music ...the most horrible distorted sound emitted,this is via optical input.the dac is about 2 years old and has always been left on.Advice needed ,what could the problem be and would i be able to fix it with ok soldering skills,or try to send it back for repair.
post #2 of 3

I have similar problem.

 

My valab dac suddenly dead no sound coming out

 

Even though when I turn on the light still on

 

Tried to contact KEVIN from VALAB but no response. 

 

Dunno if he still around or maybe he did not want to do any repair

post #3 of 3
Thread Starter 

Hi i discovered the problem was that one of the Phillips tda1543 chips had died affecting both sides of the audio,even though there are 8 of them, 4 on each side .Through a process of elimination eg i removed one at a time until the distortion stopped i  then replaced with new from ebay for £4. and its now working fine ,its a bit awkward getting access to the chips because they are underneath the printed circuit board that is separate from the surrounding pcb with some nuts and bolts going through to the chassis ,the chips have some contact adhesive on the top of them the nuts and bolts pull the upside down chips towards the chassis creating a heat sink ,care needs to be taken to pries the chips from the chassis prior to sliding the pcb out , then remove one at a time replace the pcb power up and check the sound ,as you remove each chip the output volume goes down ,you will notice when the faulty one is removed ,if this is the same fault as you have i hope this helps .I also got no reply from Kevin ,but not surprising as there is only about £20. profit in it for him .

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Valab NOS dac sound output distorting