New Posts  All Forums:Forum Nav:

Fiio X3 Nightmare - Page 5

post #61 of 74
Quote:
Originally Posted by atwaterkent View Post
 

I'm just checking in on this thread and I see that the X3 still has file management problems. I have received messages from Fiio saying that MY problem is just an isolated problem that no one else is having ..... uh huh, yeah ,right ... Their solution is to send my X3, the 64 GB card and the files (I have over 2000 complete CDs ripped to FLAC) that I am have difficulty loading to china for them to solve the problem...... I'll get right on that....

 

I see now they have a X5 device....so those of us who purchased the X3 are just left out in the cold....

I doubt I will be purchasing any Fiio products in the future.... I have a tiny $35 SANSA clip player that works just fine....buy one save money....

AK

 

Quote:
Originally Posted by atwaterkent View Post
 

This is a response to "hard head" above. Whether or not Fiio is TRYING to fix the problems with their product is not the issue. The issue is that it has problems and they are still selling it...and getting ready to sell another product.... Apple ..... who cares about what Apple does or doesn't do ... if you are dumb enough to buy outrageous priced Apple products to be kewl then keep on tokin .....

 

Their next firmware update will include an updated management system according to the FiiO team.

I was part of the X5 tour and the X5 also seems to have some problem either recognizing some files, or not reading tags correctly, etc. they will fix both X3 and X5 by the time the X5 international release is up (i.e. March...).

 

I'm very interested in the X5 (which is why I sold the X3 recently) but if the library doesn't get generated correctly after the new upgrade, then...

post #62 of 74
Quote:
Originally Posted by atwaterkent View Post

I'm just checking in on this thread and I see that the X3 still has file management problems. I have received messages from Fiio saying that MY problem is just an isolated problem that no one else is having ..... uh huh, yeah ,right ... Their solution is to send my X3, the 64 GB card and the files (I have over 2000 complete CDs ripped to FLAC) that I am have difficulty loading to china for them to solve the problem...... I'll get right on that....

I see now they have a X5 device....so those of us who purchased the X3 are just left out in the cold....
I doubt I will be purchasing any Fiio products in the future.... I have a tiny $35 SANSA clip player that works just fine....buy one save money....
AK

1. What you posted is no secret. It's all in my reply a few posts above yours.
2. The X3 does have some file recogniton problems but your special brand of "nothing on this thing works" is indeed unique to you.
3. What's wrong with sending a defective unit in along with the songs to reproduce the problem? You speak as though it's a big deal when it just means including an mSD card. But I see you would rather convince yourself that you have paid full retail price for a piece of junk and would rather brag about this everywhere than accept a legitimate offer to get it fixed.
4. We never advertised the x5 as the solution to the x3's problems. There will be a firmware update that will address database problems--on BOTH the x3 and x5. But it won't be enough to fix all the problems you've reported on YOUR unit.

Tell you what, if ever you decide to send the x3 in for repair (with the offending mSD card included) I will personally pay for shipping both ways. This is a one time offer to you only. You have nothing to lose, seeing as you aren't using the unit at all. If you refuse this last offer... well you know how seriously anyone will take your complaints from now on.
post #63 of 74

I'd rather resurrect this thread than start an entirely new one, so I'm going to go ahead and ask a question regarding my new purchase. If I browse through categories such as Artist or Album I see all of the different artists and albums I have, but when I go into the subcategory, there are no files present. Is this a common issue or am I alone? Also, my device has firmware 2.1, which I noticed came out in 2013. Is there any newer firmware and if so, where can I find it? Otherwise I haven't found any other major issues and I am pretty happy with the purchase.

post #64 of 74

I solved my similar issue by formatting the card first on my PC, then on the player itself. Also, my guess is, whatever issues you may have, all of them are going to be resolved once Fiio rewoks their file management system as promissed.

post #65 of 74

what has worked for me is to erase de usrlocal files from x3, unplug, reset, remove and insert micro SD, and then manually update library

post #66 of 74
I'll be sure to give these suggestions a try and report back as soon as I'm finished with classes.
post #67 of 74

I see that a lot of people (not in the peoples republic) still have file management issues with the X-3. the FIIO statement about 5000 units being sold ... in country without complaints is probably true. Good chance you get either shot or imprisoned for life for speaking out against any industry in the peoples republic !

post #68 of 74
Quote:
Originally Posted by atwaterkent View Post

I see that a lot of people (not in the peoples republic) still have file management issues with the X-3. the FIIO statement about 5000 units being sold ... in country without complaints is probably true. Good chance you get either shot or imprisoned for life for speaking out against any industry in the peoples republic !

http://www.head-fi.org/t/675035/fiio-x3-nightmare/60#post_10251749

Still no interest in actually fixing your X3, I see. God forbid your X3 should actually come back from FiiO playing everything properly because life would be too boring if there's nothing to complain about biggrin.gif
post #69 of 74
I just got my X3 today and it comes with firmware v2.1 (latest firmware). I format a Kingston class 10 32Gb micro SD card on my X3 as Fiio recommended then I loaded the card with a mixture of mp3 and flac files via my Windows 7 laptop. I then loaded the micro SD card into the X3 with my fingers crossed and yes....the "browse files" works as it should. I then took it a step further and manually update the database and yes...it was updating for 1 or 2 minutes then.... BAM....it just refuse to update and I realize that X3 just hang. I reboot X3 and repeated the same process for a few more times with the same hanging issue. Can Fiio please let me know which part of the process I'm doing wrong? Am I using the wrong card? Did I buy the wrong player???

Update: All the problems above solved after updating to v3.0 firmware.
Edited by Francisk - 6/12/14 at 12:16am
post #70 of 74
Quote:
Originally Posted by Francisk View Post

I just got my X3 today and it comes with firmware v2.1 (latest firmware). I format a Kingston class 10 32Gb micro SD card on my X3 as Fiio recommended then I loaded the card with a mixture of mp3 and flac files via my Windows 7 laptop. I then loaded the micro SD card into the X3 with my fingers crossed and yes....the "browse files" works as it should. I then took it a step further and manually update the database and yes...it was updating for 1 or 2 minutes then.... BAM....it just refuse to update and I realize that X3 just hang. I reboot X3 and repeated the same process for a few more times with the same hanging issue. Can Fiio please let me know which part of the process I'm doing wrong? Am I using the wrong card? Did I buy the wrong player???

Dear Francisk,

The X3 library update does have its bugs currently. However atwaterkent was experiencing issues beyond library update issues that couldn't be explained by firmware bugs alone. That's why we suggested that he take the player back to FiiO for inspection.

In your case it would seem that there are one or more music files in the collection you imported that the X3's database function cannot digest as of firmware version 2.1. We are working hard on correcting this and should have a new firmware this month that corrects this issue. In the meantime I suggest you use the browse files function to access your music.
post #71 of 74

Thanks for your prompt response Joe Bloggs and I truly appreciate that. Ok then, I'll stick to file browsing for the mean time and wait for the next firmware update that will get rid of the library update bugs...for good hopefully. Besides this problem, the X3's sound quality is very good driving my Etymotic ER4S, Phonak PFE232 and I'm very impressed that it's able to drive my Sennheiser HD600 (300 ohms) without breaking a sweat. Thumbs up to FiiO for the good sound quality at an affordable price.


Edited by Francisk - 4/3/14 at 5:29am
post #72 of 74

So it's been a couple of months. Were the issues mentioned before resolved, or not yet but it's getting close? Because I'm also curious about buying a portable hi-res audio player on the cheap and am hoping this one works out well.

post #73 of 74
Quote:
Originally Posted by hiddenninja View Post
 

So it's been a couple of months. Were the issues mentioned before resolved, or not yet but it's getting close? Because I'm also curious about buying a portable hi-res audio player on the cheap and am hoping this one works out well.

Yes hiddenninja, all the issues that I've reported on v2.1 firmware have been solved in the new v3.0 firmware which makes my FiiO X3 behave and sound like a totally new player. Thumbs up to the FiiO team that did a fantastic job on the new firmware. You can now confidently purchase the FiiO X3 without any regret.

post #74 of 74
No problems here except a set of cans the X3 will drive! Bought the HD650's there great for home use now I have to find a pair for portable use I've read the forums so I have models to check out. I'm glad I purchased the X3
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: FiiO