Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › FiiO e17 buzzing/static sound
New Posts  All Forums:Forum Nav:

FiiO e17 buzzing/static sound

post #1 of 7
Thread Starter 

I've had this for about 3 months now and every once in a while, there is constant static/buzzing sound.  It still does it without any inputs and just my headphones plugged in.  Do I need to send it back?

post #2 of 7

Does that happen when it is connected to PC and fixed itself once you unplug / replug the USB cable? If it is, then it is an OS problem and not the E17's.


Edited by ClieOS - 7/23/13 at 7:58pm
post #3 of 7
Thread Starter 

Already said it still happens when there are no inputs.

post #4 of 7
Thread Starter 

Now the sound just keeps going without stopping. I've already tried unplugging it and turning it off. Getting pretty annoying.

post #5 of 7
Thread Starter 

Using other earphones have the same result.

post #6 of 7
Thread Starter 

Well I figured out what caused it. It was my home modem being too close.

post #7 of 7
Quote:
Originally Posted by shrkz View Post
 

Well I figured out what caused it. It was my home modem being too close.

 

Is your case been resolved for good? So it could be the modem proximity causing the interference...interesting. I'll check my house modem location later as my E17 is experiencing the same problem now. 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › FiiO e17 buzzing/static sound