Head-Fi.org › Forums › Equipment Forums › Computer Audio › Foobar 2K and sample rate switches - leaves audio cut off after switch.
New Posts  All Forums:Forum Nav:

Foobar 2K and sample rate switches - leaves audio cut off after switch.

post #1 of 9
Thread Starter 

Ok so I am having problems with Foobar. I have a DAC that handles multiple sample rates and switches between them based on the sample rate of the source material.


In Foobar I am using WASAPI even style, and have all DSP settings turned off. The problem I am experiencing is when I play a song that has a different sample rate than what was playing previously, my DAC switches, but Foobar does not wait for it to switch and immediately starts playback as my DAC is switching. This leaves the first few seconds of the song cut off.


This happens either when


--I had previously played a bunch of songs at one sample rate and then in a new listening session put on songs with a different sample rate.




--When I have songs in a playlist with different sample rates.


I had used Audirvana on my Mac previously and it had a setting called "Sample Rate Switching Latency" that would delay playback for a few seconds after a sample rate switch in order to prevent problems just like this.


Does anyone have a solution? Because currently my only solution is to start playback to get the sample rate to switch, stop playback, and then restart playback now that the DAC has switched. Obviously this does not fix the problem of having different sample rates in one playlist.




post #2 of 9

So it's basically a problem with the hardware, because any added delay would break foobar's gapless playback.


Right now I can only think of one thing: try increasing the buffer size to at least twice the needed switching delay.


Also try changing the Advanced - Playback - WASAPI - Hardware buffer in ms. Could also try push mode instead of event.



If that doesn't work try the sox resampler plugin. It really is excellent.

Edited by xnor - 7/22/13 at 3:39pm
post #3 of 9

just upsample everything like a proud barbarian.

post #4 of 9
Originally Posted by castleofargh View Post

just upsample everything like a proud barbarian.


post #5 of 9
Thread Starter 

I suppose it is a "problem" with my hardware, however, its hard to call the PWD Mk II a problematic DAC.

I could upsample everything with my DAC, but then wouldn't I loose the "digital lens" feature that makes the PWD mkII's USB so great?


I just wish foobar could send the sample rate switch before it started streaming audio. Every player that I have used on Mac does not have this problem. 

post #6 of 9

So have you tried adjusting buffers?


Btw, does the same problem happen with ASIO?

post #7 of 9

bumping for an answer..
I am getting odd sample rate switching cut offs also, but this is the only thread where someone has the same issue, except I am using a dacmagic 100 with a usb to spdif audio interface. I thought a usb to spdif would fix the cut off issue but I am wondering if it is my usb ports... I am not sure what I should do at this point. I have tried adjusting usb streaming mode settings, asio settings, nothing helps

post #8 of 9

you're certainly not the only one, it's in fact a common problem but you really get bothered by it only if you shuffle your library ^_^. and some people who don't have the issue simply don't know that they're not in bit perfect and windows resamples everything to a given value before sending the signal to the DAC. so the DAC never has a different resolution and thus never needs to reset anything to change the resolution.

and the obvious answer is to do like those guys, perhaps preferably using the sox plug in with foobar or whatever you're using. if almost all your music is in 44, then you can use sox to convert all to 44.1khz on the fly. and just turn it off when you want to listen to an entire highres album if you think it's better that way.

or you take the opposite road and you convert everything to a high sample rate. both option are really the same trick and should get rid of the noise because you get rid of sample rate switches.


if there is a universal alternative I don't know of it.

post #9 of 9

although not a good solution, i put a timing of silence in front of each song, so the hardware has time to change sampling before being played, currently at 1 second


but its bad for gapless

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Foobar 2K and sample rate switches - leaves audio cut off after switch.