Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › No sound off of Schiit Mangi/Modi stack
New Posts  All Forums:Forum Nav:

No sound off of Schiit Mangi/Modi stack

post #1 of 11
Thread Starter 

Hello,

 

I heard great things from the Magni/Modi and being new to the world of audio, i figured this was a good stack to start with. It arrived, i set it all up and have done everything i can think off, and i can get no sound at all from them. 

 

The Magni/Modi light up fine. The computer detects the device fine and installs the drivers, i set the device as default and the volume mixer seems to show sound going through it, but there is no sound at all on the headsets, no matter the volume on the computer or the amp. I'm using PYST RCA cables, standard USB 2.0 cable, sennheiser hd 598 headphones (which work fine through any other audio device).

 

I've tried it through 2 separate windows 7 computer, a windows vista laptop and a different windows xp laptop and all four of them have the exact same problem. I have also tried 2 separate USB cables and another headset (a friends hd 558s), all of which work fine otherwise.

 

I've been onto the retailer who sent me out a replacement modi as he believed it was defective, but i have the exact same problem with the new one. The retailer doesn't think its the magni as he got me to remove the RCA cables and to touch the ends of the plugs to the units which caused buzzing through the headphones. (So sound is getting through the amp anyway)

 

Does anybody have any ideas? I think i've tried everything, but would greatly appreciate any help with this before i decide to cut my loses and just return them.

 

Edit: I just noticed there that if i touch the end of the plugs that i can hear the computer sound under the buzz (whatever musics playing etc), although its low and muffled and overshadowed by the buzzing. It then goes away if the RCA cable is plugged in any bit at all. Don't know if this helps.


Edited by Dizzytoes - 7/1/13 at 12:33pm
post #2 of 11

Could you please describe a few more things for us?

 

1.)  What cable are you using to hook up the Modi DAC?

2.)  What cable are you using to hook up the Magni Amp?

3.)  What volume settings have you checked in your Device Manager to ensure that the PC volume is at full?

 

Example:

PC ( running Foobar2000 with volume at 85% ) --> Schiit Modi via USB --> Schiit Modi via RCA to RCA Interconnectos --> Headphones

 

I think it is important to disable other enabled audio devices when you want to select the Schiit stack in Device Manager.  For example if you have another device hooked up the audio may try to play through both the Schiit stack and the other device.

post #3 of 11
Thread Starter 
Quote:
Originally Posted by NA Blur View Post

Could you please describe a few more things for us?

 

1.)  What cable are you using to hook up the Modi DAC?

2.)  What cable are you using to hook up the Magni Amp?

3.)  What volume settings have you checked in your Device Manager to ensure that the PC volume is at full?

 

Example:

PC ( running Foobar2000 with volume at 85% ) --> Schiit Modi via USB --> Schiit Modi via RCA to RCA Interconnectos --> Headphones

 

I think it is important to disable other enabled audio devices when you want to select the Schiit stack in Device Manager.  For example if you have another device hooked up the audio may try to play through both the Schiit stack and the other device.

1 & 2) Using Schiits PYST RCA cables. http://schiit.com/cart/index.php?main_page=product_info&cPath=0&products_id=12

3) Made sure all of them are at full volume, and just doubled checked again!

 

Example:

PC (Using itunes 10, with 100% volume) --> Schiit modi via USB 2.0 --> Schiit Magni with PYST RCA to RCA connectors --> Headphones

 

And looking at playback devices in the sound settings in control panel it only seems to be going through the modi, but i disabled the rest there and no luck. 

post #4 of 11

You may need the ASIO audio drive.

 

Grab the "Signed USB 2.0 Driver" here:

http://www.gracedesign.com/products/m903/m903.htm

 

Be sure to select the ASIO device once it is installed in your Device Manger.

post #5 of 11
Thread Starter 

Seems the installer won't pick up the device, which is strange because windows is picking it up fine! I've tried plugging it in/out, restarting and enabling/disabling all other audio devices, but it still gives that same error. It seems to pick it up fine in the USB Descriptor Dumper though, but not in any of the rest.

post #6 of 11

Try a few other USB ports.  Perhaps you are using a USB 3.0 port and not 2.0?

 

You can also look up how to disable the power management on USB Hub devices which can help.

post #7 of 11
Thread Starter 

Yeah was mainly using USB 3, thought it was all the same! Still no luck though, tried every USB 2 port i have, including ones i know for fact work. Even with power management off.

post #8 of 11

Did the stack come with a USB cable or are you using one of your own?  Perhaps try another cable?  Try a different power outlet.  Turn the volume up on the stack.

 

To me it sounds like the sound is coming from the PC to the DAC, but you should test each section of the chain to determine what part is causing the issue.

 

Are all of the power LEDs on for both the DAC and Amp?

 

Is your headphone jack seating all of the way into the jack on the amp?

 

When you turn the volume up on the amp to say 60% can you hear the amp hum a bit louder?

 

Make sure in the Sound and Audio Devices section of the Control Panel for Windows that all of the volumes in "Advanced" are at least 80%.

 

Make sure the "Mute" checkbox is not accidentally checked in there as well.

 

When you listen using your headphones straight from your PC can you hear the music?

 

Did you actually install the ASIO drivers I mentioned in a previous post?

 

You can bypass the DAC and just try the amp.  Do this via the Y-splitter from your PC headphone jack and run it into the amp.  Make sure the volume on the amp is all of the way down at first so you do not blow your headphones / eardrums.  If the amp can control the volume and you get sound then the amp is probably fine as mentioned from the retailer.


Edited by NA Blur - 7/2/13 at 8:45am
post #9 of 11

A few other users have had some success by continually disabling and then enabling the DAC in Device Manger.  After a few tries the PC will finally recognize the DAC.

 

Other approaches use XP Compatability Mode, but this is only available to Pro users.

 

Schiit as a driver page.  Try installing the drivers from their site.

 

http://schiit.com/drivers/


Edited by NA Blur - 7/2/13 at 9:54am
post #10 of 11
Thread Starter 

Did the stack come with a USB cable or are you using one of your own?  Perhaps try another cable?  Try a different power outlet.  Turn the volume up on the stack.

 

Using my own, tried 2 separate ones which is all i have at this moment.

 

To me it sounds like the sound is coming from the PC to the DAC, but you should test each section of the chain to determine what part is causing the issue.

 

Sadly this is the first piece of equipment like this i've bought, so i literally have nothing else compatible with these units but the units themselves. 

 

Are all of the power LEDs on for both the DAC and Amp?

 

Check!

 

Is your headphone jack seating all of the way into the jack on the amp?

 

Check!

 

When you turn the volume up on the amp to say 60% can you hear the amp hum a bit louder?

 

No, there is no hum or buzzing at all unless i'm messing with the RCA cables regardless of volume.

 

Make sure in the Sound and Audio Devices section of the Control Panel for Windows that all of the volumes in "Advanced" are at least 80%.

 

All at 100%!

 

Make sure the "Mute" checkbox is not accidentally checked in there as well.

 

Check.

 

When you listen using your headphones straight from your PC can you hear the music?

 

Yep, can hear perfectly fine from my terrible onboard audio!

 

You can bypass the DAC and just try the amp.  Do this via the Y-splitter from your PC headphone jack and run it into the amp.  Make sure the volume on the amp is all of the way down at first so you do not blow your headphones / eardrums.  If the amp can control the volume and you get sound then the amp is probably fine as mentioned from the retailer.

 

I don't have a y-splitter, all that came with my headphones is a 6.3mm to 3.5mm adapter. I'll pick up a y-splitter to test tomorrow, i'll also pick up some cheap RCA cables as they're about the only thing i have not tested at this point.

 

 

 
Quote:
Originally Posted by NA Blur View Post

A few other users have had some success by continually disabling and then enabling the DAC in Device Manger.  After a few tries the PC will finally recognize the DAC.

 

Other approaches use XP Compatability Mode, but this is only available to Pro users.

 

Schiit as a driver page.  Try installing the drivers from their site.

 

http://schiit.com/drivers/

 

Tried enabling/disabling multiple times, along with plugging it in and out. Gave XP compatibility mode a try along with running as administrator, no luck either. Same problem as before, it doesn't pick up any usb audio device, which is very strange since device manager is picking it up fine as a usb audio device. Same deal with the Schiit drivers, not picking anything up.

post #11 of 11

Having the exact same issue, did anyone find a solution?

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Dedicated Source Components
Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › No sound off of Schiit Mangi/Modi stack