Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Cowon D2 stereo jack troubles
New Posts  All Forums:Forum Nav:

Cowon D2 stereo jack troubles

post #1 of 4
Thread Starter 

I've been using my trusty D2 (along with my TripleFi 10) for many years now, and it has finally failed me. When connecting the earphones' stereo jack and pushing it all the way through, I only get sound from one channel. When releasing it a bit to a half-stuck position it plays stereo again, but there are of course constant disconnections and it's not very viable.

 

Is this fixable? I would love to continue using it. It seems that new offerings from Cowon do not constitute improvements in SQ and certainly not power (37mW for the D2, 29-30mW for their new ones.. ) and I have an awesome leather case for it.

post #2 of 4

Sound like the jack is either worn, dirty or has come loose from the board.

 

A worn jack would need to be replaced, you can try cleaning the jack with some contact cleaner / methyl hydrate and a quality Q-Tip.

Most likely the jack has broken it's solder connection from the board and would need to be resoldered. It seems to be quite common with the Cowon's and there are many threads over at iaudiophile.net about it, if your handy with an iron you can fix it yourself.

beerchug.gif

post #3 of 4
Thread Starter 

Took it to a stereo lab and it's the amp that's broken rather than the jack. :/ Trying to see if it's possible to order a replacement. 

post #4 of 4

Wow that's too bad, I hope you can get a replacement/fix for it, or if not, a New Player... biggrin.gif

Good Luck!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Cowon D2 stereo jack troubles