Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Astell & Kern AK120 impression thread
New Posts  All Forums:Forum Nav:

Astell & Kern AK120 impression thread - Page 49

post #721 of 730
Quote:
Originally Posted by Klonatans View Post
 


The latest one, v. 2.40. The same (in terms of reliability) when it was running on v. 2.30.

You have the AK120 right? Thta is what I have, I'm using FW Version 1.40.

post #722 of 730
Quote:
Originally Posted by mrmoto050 View Post

You have the AK120 right? Thta is what I have, I'm using FW Version 1.40.
Nope, I have the AK100 Mk2.
post #723 of 730
Quote:
Originally Posted by Klonatans View Post


Nope, I have the AK100 Mk2.

Oh sorry, mis-understood because this is AK120 impression thread. Sounds like something is not right for sure, but don't know much about the AK100 except the MK2 had a different impedance.

post #724 of 730
Quote:
Originally Posted by mrmoto050 View Post

Oh sorry, mis-understood because this is AK120 impression thread. Sounds like something is not right for sure, but don't know much about the AK100 except the MK2 had a different impedance.
I'm sorry too to post here about Ak100 Mk2. I was just asking here a week ago about comparisons between AK100 and Ak120 in terms of UI stability as both models share the same soft. Still interested in SQ improvement if changing from one to another.
post #725 of 730
Quote:
Originally Posted by Klonatans View Post


I'm sorry too to post here about Ak100 Mk2. I was just asking here a week ago about comparisons between AK100 and Ak120 in terms of UI stability as both models share the same soft. Still interested in SQ improvement if changing from one to another.

@Klonatans No worries, I haven't heard the AK100, but I do have the AK120. It works seamlessly and has a very detailed and wide soundstage. I believe the issue with the AK100 was the impedance match(too high) with some iems. It also had a single DAC whereas the 120 has a mono Dual setup. I have not had one issue with the AK120 it's very stable.

post #726 of 730
Quote:
Originally Posted by Klonatans View Post


I'm sorry too to post here about Ak100 Mk2. I was just asking here a week ago about comparisons between AK100 and Ak120 in terms of UI stability as both models share the same soft. Still interested in SQ improvement if changing from one to another.

To me, 100 mk2 sounds best with earlier FWs 2.01 to 2.2 depending on how much warmth you want. When dialed in, it's similar to the 120 but the 120 does everything just that little bit better, from res to focus to scale to dimensionality. With some of the earlier FWs the 120 was a little glassy or bright which caused some to prefer the 100 mk2 but it's just great sounding with the right FW. I've settled on 1.3. As for navigation. I don't have issue with either one but the 120 is a little better there as well. I think that's where the final fw may be best but the one previous seems slightly less filled sounding.

 

I have no stability issues with either unit. Iffy cards can cause things like that. I'd try using only the internal memory for a bit to see if the issue still occurs. If not introduce cards one at a time and see if it's related. I'd also reload the FW and then do a full reset from the advanced settings menu.


Edited by goodvibes - 5/15/15 at 2:25pm
post #727 of 730
Quote:
Originally Posted by goodvibes View Post
 

To me, 100 mk2 sounds best with earlier FWs 2.01 to 2.2 depending on how much warmth you want. When dialed in, it's similar to the 120 but the 120 does everything just that little bit better, from res to focus to scale to dimensionality. With some of the earlier FWs the 120 was a little glassy or bright which caused some to prefer the 100 mk2 but it's just great sounding with the final 2 FWs. As for navigation. I don't have issue with either one but the 120 is a little better there as well. I think that's where the final fw may be best but the one previous seems slightly less filled sounding.

 

I have no stability issues with either unit. Iffy cards can cause things like that. I'd try using only the internal memory for a bit to see if the issue still occurs. If not introduce cards one at a time and see if it's related. I'd also reload the FW and then do a full reset from the advanced settings menu.


Thank you for sharing your impressions. I received my AK100 Mk2 with 2.30 FW and now use the 2.40, so I have no experience with earlier versions. As to stability issues I'm sure that the problem lies in reading micro SD cards (my unit is equipped with two full 128GB micro SDs) as I didn't experience any issues when using it with internal memory only.

 

I'm a bit tempted to try the AK120 as many users tell that it sound wise tops the younger model. Morover it doubles (and in case of Titan version quadruples) memory amount.

 

How would you compare battery life of both models?

post #728 of 730

Similar. Not too many have heard the MK2 vs the original but yes the 120 is better. 

post #729 of 730
I have a pretty significant problem with my AK120. it seemingly sets the volume to 75 at random times after startup. Has anyone else experienced this ? I have forgotten to check a few times and nearly blew my eardrums apart frown.gif

I have sent this to their support email... no response... which after reading about their less than stellar customer service, didn't surprise me.

Darren
dgcrane
post #730 of 730

dgcrane, never had that before. Baffling... One suggestion would be to try to reset the machine and reflash firmware, to see if it changes anything? Or perhaps switch firmwares?


Edited by Zaroff - 5/15/15 at 3:33pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Astell & Kern AK120 impression thread