Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › Issues with the FiiO E7
New Posts  All Forums:Forum Nav:

Issues with the FiiO E7

post #1 of 6
Thread Starter 

I recently purchased a FiiO E7, and it has been working perfectly up until now.

 

I was exploring the settings on the device, and switched the "Charge USB" setting to "off".  The thing just shuts down.  Now, whenever I go to turn it on, it displays "FiiO" like normal, then lasts less then a second before saying "bye bye" and turning off, even when plugged in.  Has anyone else had this problem, and do you have a solution?  Thanks.

post #2 of 6

Have you tried resetting  it, between the headphones jacks is a small recessed button, us a toothpick or paper clip, press into the hole until you feel a click. Hope that fixes it for you.

 

http://www.frontrowelectronics.com/pdf/fiio_e7_manual.pdf
 

post #3 of 6

Yes, please try the reset button.

 

Do not worry about CHG off. Even if USB CHg was off. The moment the unit ran out of power, the settings would all reset, and thus the unit would take in power again.

post #4 of 6

Has this issue been fixed?  I'm curious as I just bought the E07K and would like to know if it happens to me in the future.

 

Cheers,

 

M.

post #5 of 6
Quote:
Originally Posted by rider4life View Post

Has this issue been fixed?  I'm curious as I just bought the E07K and would like to know if it happens to me in the future.

 

Cheers,

 

M.

"Welcome to Head-Fi! Sorry about your wallet"

 

From my observations.

 

As FiiO devices with the digital displays use more advanced user interfaces. There are some system hang up and weirdness sometimes. I have had this happen on both the E17 and E07K.

 

They are usually fixed with a power off and on. Or a replug into the computer. Sometimes if something does happen actually. Using the reset pin should fix it.

 

What I explained above will fix the mass majroity of the problems. The rest of the problems (if the unit didnt come DOA already) will be just failure and the warranty does cover it.

 

A few recent batches of ANDES have shown up DOA to their users due to the high success of ANDES. Agents of FiiO ordered a lot and many were sitting in storage waiting to ship out. The batteries drained to 0 causing them unable to ever recharge/work. The issue should have been fixed and if not, Support works with you. The units that arrive DOA get free return shipping back to any AUTHORIZED supplier(only if you bought from authorized dealer).

post #6 of 6

Thanks for the info bowei.  So far my E07K is working splendidly so here's hoping things stay the same! :)

 

Cheers,

 

M.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › Issues with the FiiO E7