or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X5 Thread
New Posts  All Forums:Forum Nav:

The Fiio X5 Thread - Page 639

post #9571 of 19490
Has anyone else had the problem where you turn the X5 on, play some music, plug it in to charge, fall asleep, wake up, try to turn on X5, and the X5 hangs at the end of the boot sequence and fails to go into the menu?

I've had this happen a few times. The 1st couple, I reflashed the firmware. Just now, I ejected the TF card and it finally progressed from the boot sequence to the main menu only to give the "battery exhausted" message and shut down. This is after charging it overnight, trying to boot it up this morning, shutting it down with a 10 second power button press, and leaving it in my bag untouched for the rest of the day.

Heading over to bugzilla to log this if nobody else has...
post #9572 of 19490
@jbloggs, @JamesFiiO

I was going to submit a bug to the X5 bugzilla for the freeze when starting after charging bug I mention in my post above, but there are a crazy amount of ridiculous bugs on there! I mean, come on - a bug for punching holes in the silicon case for TF cards. WTF??? Bugzilla should be for firmware bugs and feature requests! Also, there seem to be a lot of obsolete bugs and feature requests that should be set to FIXED.

So... I didn't file the bug after all. I'm hoping this gets your attention and helps with a bit of Bugzilla clean-up smily_headphones1.gif.
post #9573 of 19490
Quote:
Originally Posted by Muenchener View Post

All I'm saying is that the user should not have to figure things out of thin air and online research. If you feel you are guilty of having done a lousy job with the learning curve that should not exist in the first place, be my guest. I respect whatever feelings you may have about it. I don't want to spoil anything for you, believe me.


If the X5 have some very specific settings than can go wrong if not followed, Fiio is responsible for making those requisites very clear to the end user. They didn't.


And the X5 is a very nice DAP, I've said it like twenty times already.

I agree the documentation is terrible for a pain free new user experience.

I see it as common sense, but with the caveat that I did my research and had previous Fiio experience before going in. It could be as simple as including in big bold letters "format TF cards using the X5" like most camera manufacturers do. Or, the X5 does not recognize "put_messed_up_tag_info_here". Or, do not pull the card when accessing. Or, do not over drain the battery. Whatever it is a little documentation goes a long way.

That would relieve a lot of stress on their support team so they can focus on real bugs.
post #9574 of 19490
Quote:
Originally Posted by nmatheis View Post

@jbloggs, @JamesFiiO

I was going to submit a bug to the X5 bugzilla for the freeze when starting after charging bug I mention in my post above, but there are a crazy amount of ridiculous bugs on there! I mean, come on - a bug for punching holes in the silicon case for TF cards. WTF??? Bugzilla should be for firmware bugs and feature requests! Also, there seem to be a lot of obsolete bugs and feature requests that should be set to FIXED.

So... I didn't file the bug after all. I'm hoping this gets your attention and helps with a bit of Bugzilla clean-up smily_headphones1.gif.

Perhaps try to contact Fiio Support on their web site or direct through PM. Joe and James have both been very responsive through PM when I had an issue.

Yes, the bugzilla is a gong show.
post #9575 of 19490
Quote:
Originally Posted by x RELIC x View Post


I agree the documentation is terrible for a pain free new user experience.

I see it as common sense, but with the caveat that I did my research and had previous Fiio experience before going in. It could be as simple as including in big bold letters "format TF cards using the X5" like most camera manufacturers do. Or, the X5 does not recognize "put_messed_up_tag_info_here". Or, do not pull the card when accessing. Or, do not over drain the battery. Whatever it is a little documentation goes a long way.

That would relieve a lot of stress on their support team so they can focus on real bugs.

James@Fiio should read what you wrote and start to apply it yesterday. Most of the complains, support tickets, RMA's and product returns are basically about lack of information and the subsequent myriad of frustrations that emerge for not knowing the dirty little secrets of X5's immature firmware. 

post #9576 of 19490
Quote:
Originally Posted by zilch0md View Post
 

 

I haven't cancelled my X5 order - I placed it this morning and I'm expecting it to arrive on Friday.

 

I'm just apprehensive...

 

:-)

This morning when I was about to head out the door form work my X5 froze on the welcome screen... I didn't realize at the time that there was a small recessed reset button inside a hole on the top of the X5,  so I locked it up in my cupboard (I stay in camp for work) and brought my iPod touch 5th gen and pico slim.  I looked up the X5's manual online on the way to work and found where the reset button was.  When I got back to camp the X5 was still on the welcome screen, so I reset it which took about 10 seconds to reboot.

 

I enjoyed the Pico Slim/iPod 5th gen. for months with my SE846 and W40's, but as soon as I turned it on this morning it sounded a bit veiled and not very full bodied.  After rebooting the X5 I plugged the Slim back into the lo and immediately noticed much better detail retreival, as well as fuller bodied sound.  

 

I do find the X5's ho is better than the Slim/5th gen., but when using the X5's line out with a decent amp it make a huge improvement in sq.

 

So, if you are like me and can live with a few glitches in exchange for much better sq when using the lo then I think you will love your X5... Now I also have a dx90 on the way which should be here on Friday so hopefully I won't have to worry about using the iPod anymore:)

 

Hope you like your X5 as much as I do. 

post #9577 of 19490
Quote:
Originally Posted by nmatheis View Post

Has anyone else had the problem where you turn the X5 on, play some music, plug it in to charge, fall asleep, wake up, try to turn on X5, and the X5 hangs at the end of the boot sequence and fails to go into the menu?

I've had this happen a few times. The 1st couple, I reflashed the firmware. Just now, I ejected the TF card and it finally progressed from the boot sequence to the main menu only to give the "battery exhausted" message and shut down. This is after charging it overnight, trying to boot it up this morning, shutting it down with a 10 second power button press, and leaving it in my bag untouched for the rest of the day.

Heading over to bugzilla to log this if nobody else has...

Mine froze this morning on the welcome screen...When I got back from work it was still on the welcome screen.  I read about the reset button in the online manual on the way to work and tried it when I got back, and now it is working fine again.

post #9578 of 19490
Quote:
Originally Posted by Dave74 View Post

Mine froze this morning on the welcome screen...When I got back from work it was still on the welcome screen.  I read about the reset button in the online manual on the way to work and tried it when I got back, and now it is working fine again.

Reset hole didn't work for me. I had to take out the TF card and boot it up.
post #9579 of 19490
Quote:
Originally Posted by nmatheis View Post


Reset hole didn't work for me. I had to take out the TF card and boot it up.

Funny, I tried holding the power button for about 10 seconds and taking out the TF card, the only thing that worked for me was the reset button.

post #9580 of 19490
Quote:
Originally Posted by Muenchener View Post
 

James@Fiio should read what you wrote and start to apply it yesterday. Most of the complains, support tickets, RMA's and product returns are basically about lack of information and the subsequent myriad of frustrations that emerge for not knowing the dirty little secrets of X5's immature firmware. 

 

Honest question for you Muenchener (and I'm sure it's one that many other members of this thread echo)

 

Can you give it a rest with the innuendo and caustic comments?  You've said your piece (over, and over, and over, and over .......... ).

 

Again - like my previous post to krayziehustler - why don't we put things in perspective:

 

  1. This is Fiio's 2nd DAP - first the X3, now the X5.  How mature do you expect the software and firmware to be?  They don't have the years experience that most of the major DAP makers do.
  2. There were a heap of reviews before the X5 was released that pretty accurately described it's shortcomings.  If you didn't properly research the product - the issue is yours, not Fiio's.
  3. Fiio has repeatedly connected with their customer base, and acted to improve the UI and features of the X5.  They've released a heap of updates so far - and look as though they will continue to do so.  They're learning all the time - and this will be giving them valuable experience for not only future updates, but also future DAPs.  How about giving them a chance - instead of being a typical keyboard warrior and sniping behind the safety of a keyboard.  Instead of comparing them to DAP makers who've had years of experience (and who have massive resources) - how about looking at how far they've come?
  4. Just because there are features you think are indispensable doesn't mean the rest of us share this rating of what they should or shouldn't be doing.  Fiio are a business - and they need to fix the things that the majority want.  To do anything else is irresponsible to their own shareholders.

 

I'd challenge you to do two things:

  • Find another Hi-Res DAP in the sub $400 range that has features that are even remotely close to what the X5 is giving us.
  • Find (and link) where Fiio has deliberately misled any of the X5 buyers.  Then think about your comment above!

 

Enough is enough (IMO).  File a bug or contact Fiio directly.  But please stop the cheap shots.  Fiio don't deserve it - and I'd hate to think they would stop (or cut back) their interaction with the community because of "the few".

post #9581 of 19490
^^^THIS^^^

I wish everyone would stop their whining and be constructive. I researched my purchase with the X3 and X5. Sure, they've got their quirks, but I knew that ahead of time since Fiio sent out pre-release review units to then head-fi community. How many other companies do that with their first and second products in a new market segment? I say kudos to Fiio and boo to the whiners!
post #9582 of 19490
I think, from my side, the only 'issue' I have is the well reported battery bar, catches you with your trousers down...

I will happily say that I am listening to music a lot more since getting the X5, but - that comes with the lucky lottery of when / if the battery will shoot from showing 3/4 full to empty frown.gif

Other than that, I wish the E12 also had some kind of 'gauge' for battery life - OT, I know but, are there 'any' amp only amps (so, we'll overlook FiiO's own E7 / E17 / E18) that have a battery gauge? (multicolored LEDs or otherwise)?

Thanks.
post #9583 of 19490
Quote:
Originally Posted by Duncan View Post

I think, from my side, the only 'issue' I have is the well reported battery bar, catches you with your trousers down...

I will happily say that I am listening to music a lot more since getting the X5, but - that comes with the lucky lottery of when / if the battery will shoot from showing 3/4 full to empty frown.gif

Other than that, I wish the E12 also had some kind of 'gauge' for battery life - OT, I know but, are there 'any' amp only amps (so, we'll overlook FiiO's own E7 / E17 / E18) that have a battery gauge? (multicolored LEDs or otherwise)?

Thanks.

Duncan, did you know the e12's red LED comes on when the battery is low, you have about 10 minutes after that. I find the X5 battery lifespan closely matches the e12 when paired together so I just charge them together and never had one run out before the other.
post #9584 of 19490
Quote:
Originally Posted by nmatheis View Post

@jbloggs, @JamesFiiO

I was going to submit a bug to the X5 bugzilla for the freeze when starting after charging bug I mention in my post above, but there are a crazy amount of ridiculous bugs on there! I mean, come on - a bug for punching holes in the silicon case for TF cards. WTF??? Bugzilla should be for firmware bugs and feature requests! Also, there seem to be a lot of obsolete bugs and feature requests that should be set to FIXED.

So... I didn't file the bug after all. I'm hoping this gets your attention and helps with a bit of Bugzilla clean-up smily_headphones1.gif.

 

I had noticed that the X5 Bugzilla doesn't appear to have been maintained in awhile. We haven't heard much about new firmware developments for some time, either. Hopefully, it just means that FiiO are working on some big updates for the next releases.

post #9585 of 19490
Quote:
Originally Posted by Age8E View Post

I had noticed that the X5 Bugzilla doesn't appear to have been maintained in awhile. We haven't heard much about new firmware developments for some time, either. Hopefully, it just means that FiiO are working on some big updates for the next releases.

I think they've got all hands on deck for the latest X3 official FW release. A lot of guys chomping on the bit over there.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X5 Thread