or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X5 Thread
New Posts  All Forums:Forum Nav:

The Fiio X5 Thread - Page 591

post #8851 of 19490
Quote:
Originally Posted by HarryHardcase View Post
 

X5, FW 2.0.

 

Before I post this as a bug, can someone confirm the following is correct:

 

1) Play a song, any song, by navigating to it through Category mode.

 

2) Navigate back to the Main Menu by pressing the Back key repeatedly.

 

3) Navigate to and choose Now Playing.

 

You should now be viewing the currently playing song.

 

At this point, if I press the Back button, it returns me to the Main Menu.  Is that the same for everyone?  There's no way of navigating from within Now Playing directly to the file hierarchy?  You have to navigate manually to the song via Folder or Category mode, right?

 

I can't believe some of the stuff that's been upvoted.  There are some basics that haven't been properly implemented and people have put Playlist Creation at the top of the list?  Nuts.  We're on our way to another Snakes On A Plane folks.

The same for me. Yes, it's a PITA that the UI works like that. I'd very much prefer for that to work as it should than to have playlists creation.

In a few days, I have discovered several important flaws that I can't imagine how they get to still be around in firmware 2.0. They should have not even been in firmware 1.0.

At this level of DAPs, a right firmware is even more important that the hardware. Apple's iOS vs Google's Android are a living proof of that.

post #8852 of 19490
Quote:
Originally Posted by HarryHardcase View Post
 

X5, FW 2.0.

 

Before I post this as a bug, can someone confirm the following is correct:

 

1) Play a song, any song, by navigating to it through Category mode.

 

2) Navigate back to the Main Menu by pressing the Back key repeatedly.

 

3) Navigate to and choose Now Playing.

 

You should now be viewing the currently playing song.

 

At this point, if I press the Back button, it returns me to the Main Menu.  Is that the same for everyone?  There's no way of navigating from within Now Playing directly to the file hierarchy?  You have to navigate manually to the song via Folder or Category mode, right?

 

I can't believe some of the stuff that's been upvoted.  There are some basics that haven't been properly implemented and people have put Playlist Creation at the top of the list?  Nuts.  We're on our way to another Snakes On A Plane folks.


Yes, this is the way it is with mine too... It is a bit frustrating, but if you want to navigate to another song in the same folder, you can use the wheel while in "Now playing" screen and it will show you the other songs in the current category or folder you are playing.

post #8853 of 19490
Quote:
Originally Posted by pe3ucTop View Post
 

Thanks. It looks really nice, but, just like I expected I can definitely say that the reversed scrolling is counter-intuitive to me.

 


With the access to the graphics we are getting it seems like we can only make changes to the pictures displaying 6 different distinct states(100%, 80%, 60%, 40%, 20% and 0). That is to say I don't think we can currently mod it to show exact %. I've made a mod of CH23's last version with %'s, but it is effectively the same thing you are getting now, just different presentation. If there's interest, I can share it...

 

Same here, the reversed scrolling is not for me

post #8854 of 19490
Quote:
Originally Posted by jbr1971 View Post
 

 

Great job on putting that together. Cant' wait to try it out.

 

Would you be able to let us know which files you made changes in? I can diff the files myself to see what changes you made.

 

Thanks.


the following files were edited:

 

x5\coordinate\launcher.ini

 

 

x5\litegui\theme1\launcher\

 

post #8855 of 19490
Quote:
Originally Posted by HarryHardcase View Post
 


Emphasis mine. It's definitely the preferred method, for one simple reason: filenames are limited to certain characters, and exclude many.  Tags, on the other hand, do not have this limitation.  I've already come across several of my tracks with underscores or strange "x in a box" symbols where special characters should be.  Colons and question marks are definitely amongst those characters that are not being properly displayed, and I haven't investigated my foreign albums yet.

 

Time to open a Bugzilla account and add my voice to the others, I guess…

 

If you create a case on Bugzilla for this, please let me know as I will go and add my support to it.

post #8856 of 19490
Quote:
Originally Posted by pe3ucTop View Post
 

Thanks. It looks really nice, but, just like I expected I can definitely say that the reversed scrolling is counter-intuitive to me.

 

https://www.dropbox.com/s/fz2iwlo87ri4ohf/x5.fw

 

here's a version with the scrolling "unreversed"

post #8857 of 19490
Quote:
Originally Posted by HarryHardcase View Post

X5, FW 2.0.

Before I post this as a bug, can someone confirm the following is correct:

1) Play a song, any song, by navigating to it through Category mode.

2) Navigate back to the Main Menu by pressing the Back key repeatedly.

3) Navigate to and choose Now Playing.

You should now be viewing the currently playing song.

At this point, if I press the Back button, it returns me to the Main Menu.  Is that the same for everyone?  There's no way of navigating from within Now Playing directly to the file hierarchy?  You have to navigate manually to the song via Folder or Category mode, right?

I can't believe some of the stuff that's been upvoted.  There are some basics that haven't been properly implemented and people have put Playlist Creation at the top of the list?  Nuts.  We're on our way to another Snakes On A Plane folks.

totally! This should be something to change fast. Anything in the Bugzilla about this?
post #8858 of 19490

I just drained the x5's battery to the point where it just shut down for the first time. It seems like the indicators are not exactly 0-20-40-60-80-100%. When I was going out it showed 60%(3 bars). About an hour later it was at 2 bars and 45minutes later it showed 1 bar and maybe 15 minutes later I got a message saying "battery low, shutting down"(or something of the sort). So in less than 2 hours it went from 60 to 0. Has this happened to anybody else? To me it seems like the battery indicator might not be linear.

post #8859 of 19490
Quote:
Originally Posted by CH23 View Post
 

 

https://www.dropbox.com/s/fz2iwlo87ri4ohf/x5.fw

 

here's a version with the scrolling "unreversed"

Thanks man :)

post #8860 of 19490

Is there anyone who could dump all the images from the firmware so I could edit them for a cool theme I've been thinking about?

post #8861 of 19490
Quote:
Originally Posted by CH23 View Post
 

 

https://www.dropbox.com/s/fz2iwlo87ri4ohf/x5.fw

 

here's a version with the scrolling "unreversed"


thanks CH23...  I do like this version the best.. good work :-)

post #8862 of 19490
Quote:
Originally Posted by kdub View Post


Funny thing I was just at Headphone Bar today in Vancouver to spend more audition time with the Fiio X5 vs my previously bought E18. This time I didn't noticed as much of a difference compared to last time. Not sure why. The soundstage seemed a lot larger the first time I compared. So not feeling as bad now with the E18 purchase. However by surprise I also audition the Senn HD650 vs my NAD viso HP50 on the JDS C5D and was pleasantly surprised that the sound from this external DAC/AMP actually sounded better in every category to me vs X5? Can this really be true? Curious if anyone else has compared Fiio X5 vs JDS C5D and can share their comments and opinion. Thanks!

I was actually considering the C5D and would love to hear further impressions against the X5 as well.

post #8863 of 19490

the question is:  which firmware of the x5 were you listening to?

post #8864 of 19490
Quote:
Originally Posted by pe3ucTop View Post
 

I just drained the x5's battery to the point where it just shut down for the first time. It seems like the indicators are not exactly 0-20-40-60-80-100%. When I was going out it showed 60%(3 bars). About an hour later it was at 2 bars and 45minutes later it showed 1 bar and maybe 15 minutes later I got a message saying "battery low, shutting down"(or something of the sort). So in less than 2 hours it went from 60 to 0. Has this happened to anybody else? To me it seems like the battery indicator might not be linear.


Yes, the same behavior.

post #8865 of 19490
Quote:
Originally Posted by chengsta View Post
 

the question is:  which firmware of the x5 were you listening to?


Official FW 2.0.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X5 Thread