or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X5 Thread
New Posts  All Forums:Forum Nav:

The Fiio X5 Thread - Page 443

post #6631 of 19490
Quote:
Originally Posted by JamesFiiO View Post
 

 

yes, we had have a short vocation. and the new shipment will start from tomorrow but we may not updating it daily again.. 

 

That's disappointing, I pre-ordered back in Feb and the date was originally set for the 4th April but then delayed to the 11th April due to awaiting stock from you guys. By the looks of it, I guess the date will now be delayed again to next Friday. I guess I'll continue to keep my eye on this thread while waiting, but the recent posts hasn't been all that encouraging tbh.

post #6632 of 19490
Quote:
Originally Posted by JamesFiiO View Post
 

1、The maximum number of songs that can be added to the library database is in the range of 5800 (with songs being all in individual files) to 6200 (with songs being grouped together with a .cue file).
With 8000 songs in the database there is higher likelihood of running out of internal memory, so the upper limit was lowered.
(Limit is not dependent on such things as length of song title or artist name)

 

 

 

Thanks for the explanation. Do you think there would be a work around if not a file based database solution? If there was a Play All from the folder view this wouldn't be an issue for me though.

post #6633 of 19490
Latest firmware FW1.22beta can be found here
https://www.dropbox.com/s/kjypmwp2p3y0f9y/x5FW1.22.zip

List of changes over FW1.21beta:
1. Fixed bug in shuffle mode where the songs are not shuffled in the case of playing from one song to the next.
2. Track position now shows while fast forwarding and rewinding.
3. One can now press the power button to turn on the X5 while it is charging (as opposed to having the press the OK button before).
4. Fixed regression in 1.21 where playback volume of FLAC and DSD are lower than normal.
5. Added track position display for .aac files (note: .aac files do not have time indexes so only the current track position (and not track length) can be displayed, and it is not possible to fast forward or rewind.
6. Fixed regression in FW1.21 where the file formats of some music files are not displayed correctly.
7. Fixed issue with 24bit AIFF playback (there was noise playing back such files)
8. Improved stability of OTG storage connection.
9. Fixed issue where external storage could not be re-detected after removal if the OTG cable were left connected to the X5.
10. Fixed issue where the UI sometime froze briefly after disconnecting OTG storage.
11. Improved gapless playback.
12. Numerous other bug fixes.
Edited by Joe Bloggs - 4/10/14 at 8:12am
post #6634 of 19490
Quote:
Originally Posted by Pekku View Post
 

Has anyone else ever encountered a problem where the X5 just skips to the next song during another? There's one particular mp3 I have that every time, without fail, will just skip to the next @ the 0:45 mark. It plays back properly on my computer and phone.

 

EDIT: Hang on, I deleted and copied the album over again and the problem is gone. Weird.

hey pekku, i experienced a similar problem where songs randomly skip tracks in my TF2 card slot. i narrowed down the problem by trying to transfer songs from my PC to my X5 via PC connection to the X5 and it frequently crashes and comes up with "try again" option where try again works but it will pop out "try gain" again later on. i switched 2 different SD cards and same problem. i duplicated the same test on my TF1 card slot and no such issue AT ALL. no skipping no try again BS haha so i come to the conclusion that the TF2 card slot is defective, currently awaiting a replacement.

 

Side note:

OS: Win7

SDcards: Kingston 64gb microsdcard x2 formatted to fat32

testcard: sandisk 32gb microsdcard

IEMs: ASG-2

 

hope this helps, you might wanna try to duplicate my test to  narrow down the issue :) good luck

post #6635 of 19490
Quote:
Originally Posted by fumoffuXx View Post
 

hey pekku, i experienced a similar problem where songs randomly skip tracks in my TF2 card slot. i narrowed down the problem by trying to transfer songs from my PC to my X5 via PC connection to the X5 and it frequently crashes and comes up with "try again" option where try again works but it will pop out "try gain" again later on. i switched 2 different SD cards and same problem. i duplicated the same test on my TF1 card slot and no such issue AT ALL. no skipping no try again BS haha so i come to the conclusion that the TF2 card slot is defective, currently awaiting a replacement.

 

Side note:

OS: Win7

SDcards: Kingston 64gb microsdcard x2 formatted to fat32

testcard: sandisk 32gb microsdcard

IEMs: ASG-2

 

hope this helps, you might wanna try to duplicate my test to  narrow down the issue :) good luck

 

Awesome work, I believe my problem was of a completely different nature though, I never had any problems transferring files to the X5 via storage mode. It's just that very rarely, there will be a track that causes the X5 to skip to the next song, every time, on the same time. I managed to "fix" this issue earlier by deleting and copying the offending file again, no idea what really caused it though. Maybe something to do with something happening during the copy process. However, you did remind me to try out my TF2 slot! I'm only using a single card right now and I never occurred to me the other slot might be defective, thanks a lot for that!

post #6636 of 19490

I wonder if playlists get supported, if you could make a playlist of all of the songs on the player and get around the database limit that way...


Edited by krayziehustler - 4/10/14 at 5:07am
post #6637 of 19490
Quote:
Originally Posted by Brooko View Post
 

 

Valid point - but .......

 

There is a medium for reporting bugs, suggesting improvements etc (https://app.devzing.com/FiiO/bugzilla/).  Fiio are actively using it, and it keeps all the ideas for improvements in one place.  it also allows people to elevate the awareness of the fault.  The more popular requests should (hopefully) be treated with greater importance.

 

The issue that you need to keep in mind is that Fiio are selling to a big audience, and everyone has different wants / needs.  Some they can support - some will take time.

 

What doesn't help is the few (extremely vocal) people posting over and over about the same faults - and how it's affecting them.  Yes your entitled to an opinion, and yes you've voiced it.  Now do something about it please.  Choices:
 - file the fault on their bugzilla, and get like minded people to elevate it

 - wait for the fix

 - or sell the unit (there would be plenty of buyers available at the moment, and you wouldn't lose much)

 

But it would be kind of nice if we didn't have to read the same thing over and over again from the vocal minority.  This thread has already exploded out of control with many posts echoing the same thing.  My advice - do something about it or move on.  It's a DAP - it's not a life changing choice ;)


Well spoken!

post #6638 of 19490
Quote:
Originally Posted by Pekku View Post
 

 

Awesome work, I believe my problem was of a completely different nature though, I never had any problems transferring files to the X5 via storage mode. It's just that very rarely, there will be a track that causes the X5 to skip to the next song, every time, on the same time. I managed to "fix" this issue earlier by deleting and copying the offending file again, no idea what really caused it though. Maybe something to do with something happening during the copy process. However, you did remind me to try out my TF2 slot! I'm only using a single card right now and I never occurred to me the other slot might be defective, thanks a lot for that!

haha good good, well...sometimes a bad copy may happen like..perhaps the copy of the file did not copy completely but assumed that it was complete. it happens but rarely hehe

post #6639 of 19490

...super-excited...mine's out for delivery today :D...

post #6640 of 19490

I downloaded the new 1.22beta firmware and its great! Gapless is working perfectly. FLAC files are now the correct volume and DSD files play great. The only thing is that the EQ isn't working. Can anyone else confirm, maybe I'm doing something wrong.

post #6641 of 19490
Quote:
Originally Posted by alwass89 View Post
 

I downloaded the new 1.22beta firmware and its great! Gapless is working perfectly. FLAC files are now the correct volume and DSD files play great. The only thing is that the EQ isn't working. Can anyone else confirm, maybe I'm doing something wrong.

 

1, The EQ is not valid when the sample rate is higher than 48K ( not includes 48K)

 

2, We are testing the 1.23beta right now.

 

3, For beta version, I saw someone complained about some bugs to the public, in case other people may misunderstanding the situation, it is best not to report any bugs to public cause it is beta version, otherwise we have will not release beta version again.

post #6642 of 19490
Quote:
Originally Posted by krayziehustler View Post
 

 

Thanks for the explanation. Do you think there would be a work around if not a file based database solution? If there was a Play All from the folder view this wouldn't be an issue for me though.

 

sorry not. the play all must be support by the database. anyway, we still have change to increase the maximum song number in the future. but it can't be unlimited.

post #6643 of 19490

appreciate what u have done for the x5 james and whomever :)

post #6644 of 19490
Quote:
Originally Posted by JamesFiiO View Post
 

 

1, The EQ is not valid when the sample rate is higher than 48K ( not includes 48K)

 

2, We are testing the 1.23beta right now.

 

3, For beta version, I saw someone complained about some bugs to the public, in case other people may misunderstanding the situation, it is best not to report any bugs to public cause it is beta version, otherwise we have will not release beta version again.

 

Thanks for the info about the EQ. In that case it works fine. Sorry about reporting bugs, wont do it again. Keep up the great work! 

post #6645 of 19490
Quote:
Originally Posted by alwass89 View Post
 

 

Thanks for the info about the EQ. In that case it works fine. Sorry about reporting bugs, wont do it again. Keep up the great work!

 

thanks, sorry it will cause some trouble and we have not explain again and again, and too many unneccessary work to us.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X5 Thread