or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X5 Thread
New Posts  All Forums:Forum Nav:

The Fiio X5 Thread - Page 677

post #10141 of 19481

X5 has pretty natural sound.  Something I've not experienced with previous Fiio products.  My experience with Fiio DACs has been more cold sounding players, not natural sounding.  

post #10142 of 19481

Just a small bug on mine. When I power it on, it gets stuck at the welcome screen. After repeatedly pressing the power button and holding it then only it entered into the menu, but it says no tf card detected. Removed the microsd and the display says "tf card removed". Replaced it in and then it works again.

post #10143 of 19481

So I just sat down to write an e-mail to FIIO about my X5 that died on me earlier today, and before writing them I tried one more time and Voila, it turned on fine. I'm glad it's working again, but I am a bit concerned about it just completely powering off like that. I had only been using it for about 5 minutes when it died on me, so I doubt it overheated. Either way, I will be post if it happens again, but things are going good for now again.

post #10144 of 19481
Quote:
Originally Posted by Duncan View Post

Even though I've been here for nearly exactly 13 years (holy moly, where has that time gone!) - I still find this place toxic, poisonous to my wallet...

Having accidently left my E12 powered up, the battery went flat - in a state of panic, I used the X5 'nude', and actually have now found the E12 to sound quite thick, and syrupy...

As a consequence, i'm going to be demoing in the next couple of days a TTVJ Slim, Vorzuge Duo and a Sony PHA2 (okay, I know the DAC section will be redundant with this!) - No idea if I'll buy any, or maybe even all of them, but - seems the E12's days may be numbered...

Damned Head-Fi, and its wallet draining possibilities!!

Yo, tell me why I have the same feeling ?!
I decided to plug my Mad Dogs into the Lineout input and for some reason I like it so much more then w/ the E12.
post #10145 of 19481
Quote:
Originally Posted by nick67 View Post

Just a small bug on mine. When I power it on, it gets stuck at the welcome screen. After repeatedly pressing the power button and holding it then only it entered into the menu, but it says no tf card detected. Removed the microsd and the display says "tf card removed". Replaced it in and then it works again.

That will more than likely cause errors on your card if you are removing it while the device is powered on. Once again................ Was the card formatted with the X5?
post #10146 of 19481
Quote:
Originally Posted by KLJ1992 View Post

Yo, tell me why I have the same feeling ?!
I decided to plug my Mad Dogs into the Lineout input and for some reason I like it so much more then w/ the E12.

Did you really plug it in to the lineout? Are you deaf now?

Edit: Did you have the e12 on high gain? That would sound better for the Mad Dogs.
Edited by x RELIC x - 6/4/14 at 9:02pm
post #10147 of 19481

Man, this is interesting.  X5 is PCM1792?  I wonder why they went with this DAC?  As others went with either ESS or Wolfson or Cirus.  I'm liking the sound, it seems to sound detailed without being forward about it.  It's like it's not offending me in anyway. lol.  Very polite little(maybe big) guy.  I don't like punchy sound, and at low gain setting, there is none of that punchyness that DX90 has.  DX90 to me has a U shaped signature to me with a bit of exaggerated bass IMO.

post #10148 of 19481
Quote:
Originally Posted by SilverEars View Post

Man, this is interesting.  X5 is PCM1792?  I wonder why they went with this DAC?  As others went with either ESS or Wolfson or Cirus.  I'm liking the sound, it seems to sound detailed without being forward about it.  It's like it's not offending me in anyway. lol.  Very polite little(maybe big) guy.  I don't like punchy sound, and at low gain setting, there is none of that punchyness that DX90 has.  DX90 to me has a U shaped signature to me with a bit of exaggerated bass IMO.

You're describing what I (and many others) would agree is the unique signature of the X5. Not too warm or too bright. Very natural sound. Definitely a departure from the Fiio house sound. smily_headphones1.gif
post #10149 of 19481

I'm sorry if this question was asked here 100 times, but how good is X5's digital output (vs PC's USB, for example)?

post #10150 of 19481

sigh..currently my x5 has been resting at home for few days since my x3 has been upgraded with FW3.0... i dont know why..but the SQ of new x3 (fw3.0) pair very well with my um mentor. 

 

just wondering when x5 will have another round of fw update? :P

post #10151 of 19481
Quote:
Originally Posted by remilio View Post

I'm sorry if this question was asked here 100 times, but how good is X5's digital output (vs PC's USB, for example)?

The digital out is excellent and on par with USB from my MacBook Pro, tested going to the Oppo HA-1 which is a very, very revealing DAC/amp. Digital should just work or it doesn't so this isn't unexpected, but to reassure you there is no coloration or veil to the output. Unless you want to use the EQ which actually does work using the coaxial digital out.
post #10152 of 19481
Quote:
Originally Posted by x RELIC x View Post


That will more than likely cause errors on your card if you are removing it while the device is powered on. Once again................ Was the card formatted with the X5?

 

Yes, it is formatted using the X5. It just happened again. This time I didn't remove the card directly but powered off and on but still no dice. Such a weird problem.

 

Edit: Turned it off an on 2 more times and all is well again.


Edited by nick67 - 6/5/14 at 12:46am
post #10153 of 19481
Quote:
Originally Posted by nick67 View Post

Yes, it is formatted using the X5. It just happened again. This time I didn't remove the card directly but powered off and on but still no dice. Such a weird problem.

Edit: Turned it off an on 2 more times and all is well again.

Have you tried clearing the X5 database?
post #10154 of 19481
Quote:
Originally Posted by x RELIC x View Post


The digital out is excellent and on par with USB from my MacBook Pro, tested going to the Oppo HA-1 which is a very, very revealing DAC/amp. Digital should just work or it doesn't so this isn't unexpected, but to reassure you there is no coloration or veil to the output. Unless you want to use the EQ which actually does work using the coaxial digital out.

Wow, pretty good. Thanks! I'm gonna buy some coaxial cable then to connect my Anedio and test it with Fiio.

post #10155 of 19481
For the ones interested, just got my JH Audio Roxanne and used it for a couple of hours with my X5. I feel that this is a really nice combination as the warm sound of the Roxanne goes well with the neutral sound from the X5!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X5 Thread