Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Fiio X5 Thread - info updated on Jan 17th 2014
New Posts  All Forums:Forum Nav:

Fiio X5 Thread - info updated on Jan 17th 2014 - Page 572

post #8566 of 14626

For those with Macs having problems with those extraneous hidden files: CleanMyDrive.  Available free on the App Store for the time-being, and actively supported.  "Eject for Windows" hasn't been updated since 2011.

HTH.

post #8567 of 14626
I know what you mean about "new toy syndrome", I think anybody on head-fi does really, but new toy syndrome wouldn't be enough for me to sell of my Burson Conductor. The fact is this is this combo (X5/E12) is, for me, almost as good of sound quality for a mere fraction of the cost, with the added benefit of portability which I would even pay extra for. I would be happy with this combo at $1000, but for $450 combined, I'm blown away.
post #8568 of 14626
The only gripe I have with the X5 is the track skipping issue, which I seem to only get on 24/96 material, but it is quite annoying. If that gets patched in a future firmware update I will be completely happy with this device.
post #8569 of 14626
Quote:
Originally Posted by goldendarko View Post

The only gripe I have with the X5 is the track skipping issue, which I seem to only get on 24/96 material, but it is quite annoying. If that gets patched in a future firmware update I will be completely happy with this device.

I had a little trouble with that in FW version 1.2, but have not had the skipping with 24/192 FLAK since installing FW 2.0.
post #8570 of 14626
Yeah no problems with 24/192 for me, only 24/96 files it seems. Doesn't always do it, but when it does it will skip like 3 or 4 songs on the album, very annoying especially when I'm locked in the groove smily_headphones1.gif
post #8571 of 14626
Quote:
Originally Posted by goldendarko View Post

Yeah no problems with 24/192 for me, only 24/96 files it seems. Doesn't always do it, but when it does it will skip like 3 or 4 songs on the album, very annoying especially when I'm locked in the groove smily_headphones1.gif

 

Are you getting an error message or does it just skip?

 

For example, when I try to play very low kb, mono podcasts I see an error message about the format not being compatible and the X5 skips to the next track.

post #8572 of 14626
Quote:
Originally Posted by Loquah View Post

 

Are you getting an error message or does it just skip?

 

For example, when I try to play very low kb, mono podcasts I see an error message about the format not being compatible and the X5 skips to the next track.

 



No error messages, just starts skipping in the middle of the track, then the next 2 or 3 songs will play for a second and then skip also. Restarting it will usually fix the problem but it's still annoying as heck, would like to see it go away. Also, I am not accidentally hitting any buttons or anything as I usually just have it laying flat on a table.
post #8573 of 14626

is there a way to check what firmware my X5 has...?   Its only just been delivered (last week) from a back order here in Australia.  Should I naively expect it has the latest firmware..?

 

I must say - out of the box I am impressed with the unit - sound wise at least.  No issues what so ever in playing.   My only gripe is no PlayList.....   coming from an iPod I mostly listened to playlists and rarely album at once....

 

Anyone got a workaround for the X5 and playlists...?

post #8574 of 14626
Quote:
Originally Posted by Scuzzii View Post
 

is there a way to check what firmware my X5 has...?   Its only just been delivered (last week) from a back order here in Australia.  Should I naively expect it has the latest firmware..?

 

I must say - out of the box I am impressed with the unit - sound wise at least.  No issues what so ever in playing.   My only gripe is no PlayList.....   coming from an iPod I mostly listened to playlists and rarely album at once....

 

Anyone got a workaround for the X5 and playlists...?

For checking the firmware - go to System setting =>About X5 and it should be listed there...

 

I have a somewhat limiting workaround for the playlists. It works if you are not using the "Genre" in any way for the use of the X5, because it uses the genre field to denote a playlist name the file is associated with. What you do is:

1. Connect your X5 to your computer. Load all your X5 files in foobar2000 or similar music player/library.

2. Select the songs you want in a specific playlist and edit their genre tag field to "playlist 1"(or whatever name playlist you want). You can do as many playlists as you wish. The problem is each song can be associated with maximum of 1 playlist.

3. Disconnect your X5 from the computer. Update your X5 media library.

4. Go to "Play by category" and select "Genre". Your playlists should be listed there, along with any unchanged genre categories...

 

Again it is kind of limiting because you can only put each song in one playlist and also it makes the genre unusable when it comes to X5 use.


Edited by pe3ucTop - 5/4/14 at 6:50pm
post #8575 of 14626
Quote:
Originally Posted by reihead View Post
 

 

The link to the DAC USB Driver goes to http://www.fiio.net/firmware_download/X3_USB_AUDIO20_Windows_Driver.zip

The filename states X3, is that right?

 

 

And last but not least, great job on the firmware!

I, too, suspect that the linked USB DAC driver on that page is wrong. It won't install for me. However, the other driver package that you can get on http://fiio.com.cn/support/download.aspx does install.

post #8576 of 14626

Just got my X5 yesterday and went through this routine - Definitely not a simple as iTines/iPod but worth the SQ improvement -

Upgrade to FW2.0

 

On a Mac..

- Open up iTunes..

- Open up the card in finder..

- Create Folder as playlist name on the card - navigate to folder

- Click on your iTunes playlist - select all - drag files to card folder

- repeat for all playlists

Not sure if this works on Windows

 

Clean up filenames and extra Mac hidden files if required

No that if you ripped your files in iTunes, they may have the track number in front of each filename - 

- use something like Better Rename 9 to strip off the first three character & repeat for each folder - clean up file names as necessary

- use Eject for Windows (know this works) or Clean My Drive (haven't tested yet) to remove hidden files

 

Hope this helps, M

 

Quote:

Originally Posted by Scuzzii View Post

 

Anyone got a workaround for the X5 and playlists...?

post #8577 of 14626
Quote:
Originally Posted by Duncan View Post

reihead...

Quite hard to say with volume matching issues (and that you cannot use the headphone and line out jacks at the same time it appears), however - with those caveats aside, the X5 headphone output has surprisingly nice extension at both ends of the spectrum, but sounds quite hollow in the mids compared to the line out / E12, losing a lot of 'emotion', seems to lack a little definition...

Must be said that that doesn't mean that the X5 headphone out is junk, not at all - infact, if your 'phones are very mid-centric, then you might actually be better off with the headphone out, however - if you crave lush[er], warm[er], comforting vocals / midrange from your X5, then the E12 definitely adds that for you...

That difference gets noticeably wider when going up the volume, the X5 itself not having as much control as the amp, which - to be fair is understandable (and on the most part, I wouldn't recommend being up as loud as I do on occasion - just recently, was listening to a jazz recording at maximum volume on the E12, the IE800s really open up the harder you push them!)

These though, should be said are still preliminary opinions, considering I've only had the player for four days...

Duncan, your observations exactly mirror mine. I have no problem with harshness on the top and, as several people have discussed, or the bass. The bass is reasonably full and satisfying. If anything, using several different headphones and IEMs, I think the top end maybe a little rolled off and could use a tad bit more clean sparkle. But I have noticed a hollowness in the meds. They still sound good, but you have to look for them a little bit. I just received an E12 DIY, and I'm looking forward to playing with that. Just wanted to affirm your observations from my point of view.
post #8578 of 14626
So where can we get the X5 accessories shown on the FIIO web site, here in the US? Do we have to order on eBay? When will US suppliers have them in stock, if they don't already?
post #8579 of 14626
Quote:
Originally Posted by Peter_S View Post

What about this PNY 256 GB turbo flash drive. Seems like just what OTG was meant to work with. But it's really big storage, right. See tiger direct link below. Any sense on whether this should work. I'm really thinking of buying it for $99 shipped. That is a lot of extra storage and is small. Should work with x5 cabling.

http://m.tigerdirect.com/products/8967119?cm_mmc=EML-_-Main-_-MBWBBP1899-_-tigeremail1899&SRCCODE=MBWBBP1899&utm_source=EML&utm_medium=main&utm_campaign=MBWBBP1899

Okay, so I ordered this… And will let people know how it works out. It will take about a week to get and a little bit more time to set up. Does anyone know whether I will need to reformat it to fat 32? So, recommendations on how to do this? I assume I cannot rely on the X5 to format something external like this? I'm also assuming that if this can be done, it would be a wise thing to do? Any thoughts or comments?
post #8580 of 14626
Hi there! I'm a happy owner of a brand new Fiio X5, bought on B&H 3 days ago.

I have a few questions for the experts on this thread:

1) Is the maximum volume still a bit low? I've tried all my headphones with the X5, and I just can't use any volume level south of 65, even with the high gain on. And that happens even with low impedance IEMs. I expected a very powerful amp, but with some headphones such as the Beyers 990 250 Ohms, I have to use the full volume (I'm not deaf, my hearing is fine). Is this normal or I got a lemon?

2) Weird equalizer behaviour. If I use any other eq than normal (flat, no eq), the volume level gets down very noticeably. This is really weird. If I customize the eq, upping all 10 bands, I get a much quieter sound. This doesn't make any sense to me. Is this a bug?

3) Balance levels. I use the balance to achieve an almost perfectly centric sound, as I hear a bit more on one ear than on the other. The total balance change achievable for either channel appears to be quite low. On my Cowon Z2/J3 or iPhone 5S, the balance levels are much, much more powerful. A lot of people with more serious balance needs would not be able to get them with the small balance control of this 2.0 firmware. Is the balance control really that slight?

I thank you all for any insights and comments on these 3 issues that worry me about this otherwise great player!

Cheers!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Fiio X5 Thread - info updated on Jan 17th 2014