Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Fiio X5 Thread - info updated on Jan 17th 2014
New Posts  All Forums:Forum Nav:

Fiio X5 Thread - info updated on Jan 17th 2014 - Page 797

post #11941 of 12477
Well, that's it. Going back to 2.02b again.

Anyone else see this on the startup (every time) with 2.2?



Not that a glitch in the startup screen is a deal breaker, I just needed an excuse to go back to 2.02b. biggrin.gif
post #11942 of 12477
Quote:
Originally Posted by Muenchener View Post
 

Sad to read that yet another customer is returning the X5 for a firmware/UI issue. Last time I said that FiiO was losing money because the firmware was not mature, I was basically called a troll.

Perhaps, someone at FiiO has already realized how increasingly important a good, mature, well thought out UI/firmware is. Sadly, the X5 still hasn't achieved the level of firmware that such a terrific piece of hardware deserve.
 

 

I think it had more to do with a questionable story about a friend who said the X5 gets returned in droves, which didn't jibe with any evidence. That, and the fact that you only seem to come out of the woodwork every fifty pages or so when someone decides to return one.

 

Everyone knows the firmware needs work, including FiiO themselves. Our differences stem from how patient we're willing to be while they work it out.

post #11943 of 12477
Quote:
Originally Posted by CH23 View Post


It's okay, i can understand the emotion. Most of us are just throwing in ideas here to see what sticks.
i'm not sure if you knew this, but the 2 bottom buttons on the X5 also work for navigation on the "home" screen, and with normal accuracy, instead of the problematic scrollwheel.
This might help you a bit already. I hope you'll manage to remember most of the stuff and where it is.

No hard feelings smily_headphones1.gif

-CH23


Thanks.  I should be able to choose bettween albums as long as I remember what I have in what order.

Thanks  again.

Kevin

post #11944 of 12477
Quote:
Originally Posted by x RELIC x View Post

Well, that's it. Going back to 2.02b again.

Anyone else see this on the startup (every time) with 2.2?



Not that a glitch in the startup screen is a deal breaker, I just needed an excuse to go back to 2.02b. biggrin.gif


No glitch on my X5 2.20

post #11945 of 12477
@x RELIC x: No glitch for me, either. Tried reloading firmware?
post #11946 of 12477
Quote:
Originally Posted by nmatheis View Post

@x RELIC x: No glitch for me, either. Tried reloading firmware?

Yeah, it's weird. I've had the screen randomly glitch when waking from sleep before so I thought this was the issue. Turns out that every time I power it on (with 2.2) this is what I see instead of the welcome screen and then it clears up and goes to my last played song (my setting preference) and displays as normal.

I rolled back to 2.02b and this doesn't happen. Weird. I guess mine is getting tired as I use it A LOT.

One thing is, I thought there was a startup animation but now all I see is 'Welcome'. Is my memory failing or is there a FiiO startup animation? It doesn't really matter to me, just curious.
post #11947 of 12477
@x RELIC x: Yes, there's an animated startup sequence - some silver arcs appear as the Welcome message is displayed.
post #11948 of 12477
Received my new X5 today loaded up 5400 songs and enjoying every minute of it. What a great player, I'm so glad I got rid of my DX50 and got this
post #11949 of 12477
Quote:
Originally Posted by nmatheis View Post

@x RELIC x: Yes, there's an animated startup sequence - some silver arcs appear as the Welcome message is displayed.

That's what I thought. All I see is the word "Welcome" then in to the interface. Time to clear the database I guess.
post #11950 of 12477
Quote:
Originally Posted by Muenchener View Post

Sad to read that yet another customer is returning the X5 for a firmware/UI issue. Last time I said that FiiO was losing money because the firmware was not mature, I was basically called a troll.


Perhaps, someone at FiiO has already realized how increasingly important a good, mature, well thought out UI/firmware is. Sadly, the X5 still hasn't achieved the level of firmware that such a terrific piece of hardware deserve.


In any case, I prefer the X5 to the DX90. Can't you wait for a firmware revision instead of returning the X5?

 

Well I received my additional 64gb micro sd evo and 16gb (specifically for firmware upgrades) formatted both cards and then downloaded the new firmware 2.2 to the 16gb and subsequently upgraded. Rescanned the database and voila all of my album art is there for my ogg's. I left the cover.jpg and the embedded art so who knows which it is seeing and I don't really care. The X5 is staying.
post #11951 of 12477
Quote:
Originally Posted by x RELIC x View Post

Well, that's it. Going back to 2.02b again.

Anyone else see this on the startup (every time) with 2.2?



Not that a glitch in the startup screen is a deal breaker, I just needed an excuse to go back to 2.02b. biggrin.gif

Have you tried reflashing 2.2? I have no animation issues on startup.
post #11952 of 12477
Quote:
Originally Posted by x RELIC x View Post

Well, that's it. Going back to 2.02b again.

Anyone else see this on the startup (every time) with 2.2?



Not that a glitch in the startup screen is a deal breaker, I just needed an excuse to go back to 2.02b. biggrin.gif

 

I've had this issue since upgrading from 2.07b to 2.2. Just reflashed 2.2 over the top of 2.2 and the glitch remains... I'll try downgrading to 2.0 and then back to 2.2...

post #11953 of 12477

pretty every dap beside the a&k and sony walkmans have absoluetly $hit UI.

 

 

Its just something we have to deal with sadly.

post #11954 of 12477

^^ Now back on 2.0 and the same glitch remains!?

post #11955 of 12477
Have you tried a factory reset, upgrade the firmware and try another factory reset?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Fiio X5 Thread - info updated on Jan 17th 2014