or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 635

post #9511 of 17129
Quote:
Originally Posted by marty63 View Post

I'd one note. When I want change some value (e.g. bass, treble), window will display too to short time.

That's true! It's like a game of planning and coordination, to change the values. It usually takes me 3 tries to get the value that I want.
post #9512 of 17129

I downloaded and installed the modified beta firmware, but I'm having issues updating the media library. It seems make it through all my songs, but than keeps spinning even after 5-10 minutes. If I press any button it looks like it freezes (spinner stops, moving text stops). It's the first thing I did after I installed the firmware. I also thought I could revert back to 2.1, update the DB, re-install, and not update library. That didn't work; it gives the error "Playback failed. No music found!" I'm guessing the DB format changed and cannot be reused. I can browse files to play files, but I was looking forward to albums grouped by artists and gapless playback features. It does sound great though.

 

Anyone else experience this problem? My library's a mix of Flac/MP3 and some cover pictures. I admit I need to clean up my library, but it did work in the previous firmware.


Edited by RevisionD - 4/26/14 at 6:58pm
post #9513 of 17129

The OGG noise problem is fixed!  Thanks so much, FiiO.

post #9514 of 17129

Impressive for a Beta, well done FiiO peeps.

post #9515 of 17129

Way to go Fiio! This new update is great and moved the X3 back into the top of my lineup.  Thanks!

post #9516 of 17129

sorry, please don't upgrade to the beta version cause it is not so stable. we are working hard and try to release it after 2 weeks but it is really a big work to us.

 

anyway, good things is that you guys can see what we are working in.  :beerchug:

post #9517 of 17129
Quote:
Originally Posted by Stuff Jones View Post
 

OK I'm trying the volume modded version with FLAC only. It seems a little more treble-y with a tighter low end and better separation. I'd like confirmation though that this isn't just expectation bias.

 

Navigation is snappier. Menu appearance change is neutral to me, but the font thickness and color when playing songs should be adjusted to look less amatuer. I've got the black theme but I've got gold thin letters telling me track info.

 

Anyway, nice to see Fiio not abandon us X3 owners.

 

:beerchug:

post #9518 of 17129
Quote:
Originally Posted by JamesFiiO View Post
 

sorry, please don't upgrade to the beta version cause it is not so stable. we are working hard and try to release it after 2 weeks but it is really a big work to us.

 

anyway, good things is that you guys can see what we are working in.  :beerchug:

 

James, do you plan on retaining lyric support in the new firmware?  If so, it would be nice to have the lyrics scroll on the entire screen (remove the image shown on the lyrics screen in 2.10).

post #9519 of 17129

Decided that 60 max volume wasn't cutting it. The 120 mod seemed overkill. I did a quick remod to 80 max and it seems just perfect for my use. 

 

Enjoying the X3 even more. I'm not a huge fan of the tile-style menus but it doesn't matter enough to me to change my impression of the X3.

 

Looking forward to a finished release. Although, I'm holding onto this beta version just in case. :ph34r:

post #9520 of 17129

Great update so far.  Impressive.

I have noticed on my TF card that the number maxes at 5800, all MP3.  I have over 11000 on a 128gb card.  Has anyone else experienced this?

I'm sure it's going to be fixed, but get spooked as my old Cowon was so limited in this regard.  

 

Thanks Joe & Fiio!

post #9521 of 17129
Quote:
Originally Posted by ryankesler View Post
 

Great update so far.  Impressive.

I have noticed on my TF card that the number maxes at 5800, all MP3.  I have over 11000 on a 128gb card.  Has anyone else experienced this?

I'm sure it's going to be fixed, but get spooked as my old Cowon was so limited in this regard.  

 

Thanks Joe & Fiio!

5,800 is a very familiar number if you've been following the X5 threads. This is probably an X5 limitation rather than an X3 one so, like the volume, has probably been carried over accidentally from the X5. Regardless of that, though, there is a plan to fix it on the X5 so I'm pretty sure that it will be fixed on the X3.

 

On another subject, back when DAC functionality was first introduced to the X3, a lot of people thought that the SQ of the X3 as a DAC was better than when in DAP mode. Maybe the decoding has caught up with the hardware capabilities in this beta firmware?

post #9522 of 17129

Here's a UI-modded firmware based on Razorblader's Volume-modded 2.14b firmware: LINK.

 

I modded the boot and shutdown UIs to be charcoal gray.  I also modded the black theme to remove the micro-grid pattern, replacing it with charcoal gray and dropped in a font I preferred with the modded UI I've been using with 2.13.  Finally, I made the charcoal gray theme Theme 1, so it would be the default theme.  Give it a try and let me know what you think.

 

I have to say that Fiio did an amazing job with this firmware update SQ-wise!  I regularly cranked the hardware bass up to +4 or +5 with 2.13, but I haven't felt the need to touch it at all with 2.14b.  The sound is so much cleaner now.  Need to find time to A/B with my new DX90.

post #9523 of 17129
Quote:
Originally Posted by tjw321 View Post
 

5,800 is a very familiar number if you've been following the X5 threads. This is probably an X5 limitation rather than an X3 one so, like the volume, has probably been carried over accidentally from the X5. Regardless of that, though, there is a plan to fix it on the X5 so I'm pretty sure that it will be fixed on the X3.

 

On another subject, back when DAC functionality was first introduced to the X3, a lot of people thought that the SQ of the X3 as a DAC was better than when in DAP mode. Maybe the decoding has caught up with the hardware capabilities in this beta firmware?

 Cheers for that info.  I don't follow the X5 thread at all.  I could only afford an X3.

post #9524 of 17129
Quote:
Originally Posted by uzi2 View Post
 


Yes - credits to Razorblader and Skalkman

 

Use firmware tools and edit x3/system_attribute/default.ini

 

The standard beta sets a max_vol of 60 (Razorblader increased this to 120)

The standard beta sets a default_vol of 20 (unchanged by Razorblader)

 

The standard beta does not allow the setting of a fixed startup_vol as it defaults to the last used.

 

In order to do this you should set default_vol to double your previous number and change default_vol_type from 0 to 1

The latest version of my modded 2.14beta that has been up since yesterday has a default volume setting of 40 and will revert to that value (which can be changed in the X3 settings) upon reboot.

My initial post with the download link has been updated accordingly when the new FW went up.

 

http://www.head-fi.org/t/651769/the-fiio-x3-thread/9405#post_10489378


Edited by razorblader - 4/26/14 at 10:46pm
post #9525 of 17129
Quote:
Originally Posted by JamesFiiO View Post
 

sorry, please don't upgrade to the beta version cause it is not so stable. we are working hard and try to release it after 2 weeks but it is really a big work to us.

 

anyway, good things is that you guys can see what we are working in.  :beerchug:

oh mine!!! the album the UI...everything is so good now!!!! i LOVE it!!! thank you Fiio!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.