or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 631

post #9451 of 17129
Quote:
Originally Posted by Mr Trev View Post

Just a reminder for anyone experiencing mysterious shut downs. Joe mentioned earlier that idle & sleep were swapped. I forgot and had mine shut down in the middle of a song.
Sounds like I need to change my settings!

But then again, I had it on shuffle all songs so I wouldn't expect it to be idle and sleep or shut down.
Edited by nmatheis - 4/25/14 at 10:58pm
post #9452 of 17129
Quote:
Originally Posted by LasVegas View Post
 

I have to listen at vol 60 - High Gain. With FW 2.1 I was at vol 28 Low Gain :P


What are you driving...what cans or IEM's?

post #9453 of 17129

I'm using the 128 GB card which works fine except on shuffle. Shuffle plays one album (out of about 400) about 50% of the time and plays 5 albums about 80% of the time. Anyone have this problem? It may not be related to the new 128 card but I didn't have it before.

post #9454 of 17129
Quote:
Originally Posted by tjw321 View Post
 

I didn't have long to play with the new beta firmware, but in my brief time with it, I couldn't get the coax out to work. Has anyone else tried?

This was a false alarm. On my second attempt, when I had more time, it worked perfectly.

 

Other than the well-documented "low volume bug" the only issue I have is it isn't possible to do shuffle play on an artist, AFAICT, only an individual album. OTOH, before the huge improvements in the db handling in this beta, it wasn't possible for me to shuffle anything except a folder using "Browse Files". At least now I can shuffle by genre (which was the thing I wanted most). The only problem now is, I can see how bad my genre tags are!

 

This is a huge step forward. Well done to Fiio! Even the "cartoonish interface" (not my words) isn't as annoying as I thought it would be (not annoying at all, really). I think I still prefer a text-based one, but I can definitely live with this one.

post #9455 of 17129
Quote:
Originally Posted by Stuff Jones View Post
 

I'm using the 128 GB card which works fine except on shuffle. Shuffle plays one album (out of about 400) about 50% of the time and plays 5 albums about 80% of the time. Anyone have this problem? It may not be related to the new 128 card but I didn't have it before.


huh

post #9456 of 17129

Nice and great working for a beta firmware, GUI looks nice, slightly faster, gapless works for me now, EQ added. :etysmile:

 

But I miss only one thing, please tell how I can disable the cover view, with 2.10 I disabled this stuff, I don't want to see covers, the text with artist title is more than enough. Thanks

post #9457 of 17129
Quote:
Originally Posted by subguy812 View Post
 


huh

I think he is saying that the shuffle isn't as random as it should be. I haven't played with shuffle much yet, but I found something similar. The first three tracks all came from the same album, then I got one from a second album, then one from the first again, then one from the second again.

post #9458 of 17129

I'm not sure how to compare before and after, since I cant even match the previous volume i used and the volume now. There is definitely a change in sound though. but gapless is still not really gapless.

post #9459 of 17129

Is the sound quality change just for MP3s?

post #9460 of 17129

OK I'm trying the volume modded version with FLAC only. It seems a little more treble-y with a tighter low end and better separation. I'd like confirmation though that this isn't just expectation bias. 

 

Navigation is snappier. Menu appearance change is neutral to me, but the font thickness and color when playing songs should be adjusted to look less amatuer. I've got the black theme but I've got gold thin letters telling me track info. 

 

Anyway, nice to see Fiio not abandon us X3 owners.


Edited by Stuff Jones - 4/26/14 at 1:49am
post #9461 of 17129
Quote:
Originally Posted by Stuff Jones View Post
 

I'm using the 128 GB card which works fine except on shuffle. Shuffle plays one album (out of about 400) about 50% of the time and plays 5 albums about 80% of the time. Anyone have this problem? It may not be related to the new 128 card but I didn't have it before.

I'm not having this problem with either on my 128 GB cards. I use shuffle all when I use my X3 and it does appear random enough to me.

post #9462 of 17129

Is there a way to export the favorites from x3?
Is it saved as a playlist/textfile somewhere?
(would be nice to sort it out on the fiio, not on pc)

post #9463 of 17129
Quote:
Originally Posted by LasVegas View Post

It is not just about micro-detail, the bass and treble were noticeably improved too. Highs are airier, with more definition and bass is more detailed and controled. I think that just now it is taking full advantage of the amplification section, since I no longer need the JDS Labs C5 to give that detailed/textured bass.

Ain't that typical. I got the E12 yesterday to help me out and now the player is better by itself. Poor me wink.gif
post #9464 of 17129
Quote:
Originally Posted by Nec3 View Post
 

I'm going to say I love everything about the new U.I. Well. Almost everything.

-Low volume (looks like I'm downloading that 120 volume mod!)
-During playback, browsing or performing any other function is very tedious due to I think maybe hardware limitations?

-Playback text is in an odd placement...

 

You could just use the normal firmware tools provided for unpacking the old firmware and just change the "max_vol" parameter in default.ini to something like 120 instead of the normal 60. Though 120 might be a bit over the top since for what i have gathered is that the "volume drop" is is something like 20 units so since the old max volume was 60 you could just bump it up to 80 and have everything like it was before. 

post #9465 of 17129
Quote:
Originally Posted by Joe Bloggs View Post

I have my hands on an alpha firmware for the X3. Alas it really is an alpha feature-wise: no EQ, no high gain setting, some other menu items missing, system settings that are in Chinese no matter what language you select (and the language selection is also missing from the menu so the only way to select language is the language selection screen that comes up on the first boot-up after flashing). But it is using the new UI, and seems to be using the new mp3 decoding engine. And gapless really is gapless (tested with Pink Floyd's DSOTM, FLAC) Who knows, it might even play DSD rolleyes.gif If anyone wants to try it, they can pm me for a download link. Please, no redistributing the alpha and only report bugs to me via pm.

Edit: just received an updated beta of the firmware with EQ (both software 5-band and hardware 2-band), complete menu in English (although I note that the tag for "idle power off" and "sleep" have been mixed up), language selection in menu... all in all I'd rate this as a solid "beta" worth trying out and I anticipate to be inundated by pm requests so here's a public link biggrin.gif :
https://www.dropbox.com/s/wp5bs1j5gc06q0r/x3%20FW2.14beta.zip

Extract x3.fw into root folder of mSD card in X3 (that's formatted in FAT32), turn off X3, make sure X3 is adequately charged, hold down upper left menu button while pressing power key to start the update.

If things don't work out for you with the alpha here's the version 2.1 firmware to revert to
https://www.dropbox.com/s/d49q7vmdkhfeqjc/X3_FW2.1_EN.zip

I'm opening a new version of firmware for this in the bugzilla
https://app.devzing.com/FiiO/bugzilla/

although I anticipate this version to remain current for only a week or two at most biggrin.gif

 

The beta does play DSD64!


Edited by skalkman - 4/26/14 at 2:23am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.