or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 626

post #9376 of 17125

Updating...

post #9377 of 17125
That's nice to hear smily_headphones1.gif
post #9378 of 17125

Is there anyway to get it to show the song title on the play screen - at the moment I have album artwork with the filename shown rather than the title from ID3 tag?

post #9379 of 17125
Quote:
Originally Posted by BigAund View Post
 

Is there anyway to get it to show the song title on the play screen - at the moment I have album artwork with the filename shown rather than the title from ID3 tag?

It shows up for 5 seconds then disappears right?  Close enough!

post #9380 of 17125
Quote:
Originally Posted by BigAund View Post

Is there anyway to get it to show the song title on the play screen - at the moment I have album artwork with the filename shown rather than the title from ID3 tag?

I guess that's up to the next fw revision redface.gif
post #9381 of 17125
Quote:
Originally Posted by TsukiNick View Post
 

It shows up for 5 seconds then disappears right?  Close enough!

Yeah just noticed that! 

post #9382 of 17125
You are going to post that revision within the hour right? :P
post #9383 of 17125

Gapless works perfectly (also just tried DSotM) - then again, I never really had a problem on 2.1

post #9384 of 17125
Quote:
Originally Posted by Joe Bloggs View Post

I have my hands on an alpha firmware for the X3. Alas it really is an alpha feature-wise: no EQ, no high gain setting, some other menu items missing, system settings that are in Chinese no matter what language you select (and the language selection is also missing from the menu so the only way to select language is the language selection screen that comes up on the first boot-up after flashing). But it is using the new UI, and seems to be using the new mp3 decoding engine. And gapless really is gapless (tested with Pink Floyd's DSOTM, FLAC) Who knows, it might even play DSD rolleyes.gif If anyone wants to try it, they can pm me for a download link. Please, no redistributing the alpha and only report bugs to me via pm.

Edit: just received an updated beta of the firmware with EQ (both software 5-band and hardware 2-band), complete menu in English (although I note that the tag for "idle power off" and "sleep" have been mixed up), language selection in menu... all in all I'd rate this as a solid "beta" worth trying out and I anticipate to be inundated by pm requests so here's a public link biggrin.gif :
https://www.dropbox.com/s/wp5bs1j5gc06q0r/x3%20FW2.14beta.zip

Extract x3.fw into root folder of mSD card in X3 (that's formatted in FAT32), turn off X3, make sure X3 is adequately charged, hold down upper left menu button while pressing power key to start the update.

If things don't work out for you with the alpha here's the version 2.1 firmware to revert to
https://www.dropbox.com/s/d49q7vmdkhfeqjc/X3_FW2.1_EN.zip

I'm opening a new version of firmware for this in the bugzilla
https://app.devzing.com/FiiO/bugzilla/

although I anticipate this version to remain current for only a week or two at most biggrin.gif

Thanks for posting the link to the beta FW for the X3 Joe. Everything seems to work so far except the maximum volume (60) on L and H gain is much lower than with previous FW versions.

Just wondering if anybody else experiences the same problem.

post #9385 of 17125
Quote:
Originally Posted by razorblader View Post
 

Thanks for posting the link to the beta FW for the X3 Joe. Everything seems to work so far except the maximum volume (60) on L and H gain is much lower than with previous FW versions.

Just wondering if anybody else experiences the same problem.

Yea, me to. I'd say that max volume is about 1/3 -1/2 of 2.1

post #9386 of 17125

I've also noticed the same with Volume - I was listening on 22, High gain this morning and it was loud enough for me. Since the update, I'm on high gain and 42! 

post #9387 of 17125
Quote:
Originally Posted by BigAund View Post

I've also noticed the same with Volume - I was listening on 22, High gain this morning and it was loud enough for me. Since the update, I'm on high gain and 42! 

Are all of you with the volume problem listening to FLAC files by any chance? This may be related to the volume bug in X5 FW1.21-1.22 where FLAC and DSD files were decoded 18dB below full scale. Mp3s were unaffected.
post #9388 of 17125
Quote:
Originally Posted by Joe Bloggs View Post


Are all of you with the volume problem listening to FLAC files by any chance? This may be related to the volume bug in X5 FW1.21-1.22 where FLAC and DSD files were decoded 18dB below full scale. Mp3s were unaffected.

I wasn't aware of that, but the lower volume seems consistant across Flac and MP3 anyway

post #9389 of 17125
Quote:
Originally Posted by Joe Bloggs View Post


Are all of you with the volume problem listening to FLAC files by any chance? This may be related to the volume bug in X5 FW1.21-1.22 where FLAC and DSD files were decoded 18dB below full scale. Mp3s were unaffected. 

I've tried both and the max. volume output is much lower with both. Got a feeling it's connected to the new software EQ.

post #9390 of 17125
@Joe Bloggs: Should we be submitting bugs and feature requests to the bugzilla for the unreleased beta firmware, or wait until you release a stable version until we use the new bugzilla?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.