Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 614

post #9196 of 12912
The new firmware should add like two stars to the performance. Nice how we get updates.
post #9197 of 12912
Quote:
Originally Posted by Trunks159 View Post

The new firmware should add like two stars to the performance. Nice how we get updates.


Yes, but when? When is the new firmware due to be released?

post #9198 of 12912
Latest I would guess is in June. May might be possible.
post #9199 of 12912
Quote:
Originally Posted by Mr Trev View Post
 

since the x3 screen has a resolution of 240x320 I don't think it makes sense to go any larger than 240x240. It seems that the smaller the artwork the quicker the UI works (doesn't have to spend time scaling).

Late reply, but thanks for the tip.  Over the weekend I re-did the artwork on my X3 so max file size is 240x240.  Then I re-enabled gapless playback.  I haven't noticed any issues so far (in 30 minutes of playback time).  I have noticed snappier playback response, presumably thanks to the 1:1 image size.  I will report back on gapless playback errors, if there are any.

post #9200 of 12912
After seeing the screenshots it would be a little cruel to have us wait until june for it. Mostly I'd appreciate better ogg vorbis playback in the new firmware, software eq being a nice bonus.
post #9201 of 12912
Quote:
Originally Posted by pennylane View Post

Late reply, but thanks for the tip.  Over the weekend I re-did the artwork on my X3 so max file size is 240x240.  Then I re-enabled gapless playback.  I haven't noticed any issues so far (in 30 minutes of playback time).  I have noticed snappier playback response, presumably thanks to the 1:1 image size.  I will report back on gapless playback errors, if there are any.
Well, that's interesting. Can you report back in a week or so and let us know if your X3 is still stable with Gapless on. If so, I might try that trick myself smily_headphones1.gif.
post #9202 of 12912
Quote:
Originally Posted by nmatheis View Post


Well, that's interesting. Can you report back in a week or so and let us know if your X3 is still stable with Gapless on. If so, I might try that trick myself smily_headphones1.gif.

Been keeping my artwork @ 240x since the start, and I do still have the odd freeze using gapless. Seems like there was something broke in the 2.1 update. Gapless worked ok pre 2.1 so I don't imagine the artwork size makes any diff in this case. But the UI response does seem a bit quicker to me, and smaller artwork = smaller files = more music:D.

post #9203 of 12912
Quote:
Originally Posted by pennylane View Post
 

Late reply, but thanks for the tip.  Over the weekend I re-did the artwork on my X3 so max file size is 240x240.  Then I re-enabled gapless playback.  I haven't noticed any issues so far (in 30 minutes of playback time).  I have noticed snappier playback response, presumably thanks to the 1:1 image size.  I will report back on gapless playback errors, if there are any.

 

I don´t want to crush any hopes... but I´ve been doing this since October and it didn´t change anything. At first it seemed as it would but it was a placebo on my part. However, the interface will in fact be snappier so it´s still a good idea to do it.

post #9204 of 12912

I have been using my X3 a lot recently - and I have noticed that there are certain groups of music where the player simply will NOT remember the last place I was at.

 

When I was listening to one gigantic hour long FLAC mix - every time I turned on the player it went back to that track - right where I left off. That was awesome.

 

The last few days I have been listening to a different group of songs - and EVERY time I turn the player back on it forgets where I was and I end up at the main menu - and then have to go all the way through the browse files annoyance.

 

So it seems particular about which group of music it is playing.

 

Three solutions for this:

 

1. The obvious one - fix this glitch in the firmware

 

2. Put an option on the main menu for: LAST KNOWN POSITION - so even if the player goes to main menu accidentally, I can still force it to go back where I was.

 

3. Update firmware to allow me to setup options so that the player NEVER auto shuts down. At least this would help me during a single days use while driving around. Every morning I may be stuck with having to re-find my last position - but that is better than 7 times a day!

post #9205 of 12912
As this is my final day of using the X3(my X5 arrived today!!), i'd like to give my last bit of advise:

If you're going to install the drivers on windows, and you don't want "bloatware" instead of using the .exe files in the driver file, you can install the following way:


Needed:
tusbaudio.cat
tusbaudio.inf
tusbaudio.sys
tusbaudio_x64.sys (for 64 bit OS)

tusbaudioks.cat
tusbaudioks.inf
tusbaudioks.sys
tusbaudioks_x64.sys (for 64 bit OS)

I'll even tell you how exactly:

Connect the X3 in DAC mode, it will tell you drivers couldn't be installed or a similar message.
Press windows key+r and type "compmgmt.msc"
The window that opens, computer management, has a column in which you can select "device manager".
Now on the right of this column you should see a list.
In this list there should be a group called "universal serial bus controllers", and in this group there should be one device with a little yellow triangle /!\ called "USB Composite Device"
Right click it, click "update driver software"
In the new window click "browse my computer for software"
Click "let me pick from a list of device drivers on my computer"
Now click "have disk" and select the location of the drivers (which have been unzipped)
Select "tusbaudio.inf" and click open, then ok, now you should see "FiiO X3" as the selected driver.
Click next, a windows security popup can appear, select "install this driver software anyway"
This first driver should now be successfully installed.

Now for the 2nd driver.
Go to the "computer management" screen again, and find "other devices"
Here should be a device called "FiiO X3 WDM audio"
Right click it, click "update driver software"
In the new window click "browse my computer for software"
Now browse to the location of the other driver, and click "next".
Another windows security popup can appear, select "install this driver software anyway"
This second driver should now be successfully installed.

You can close the Computer Manager window.

All you need to do now, is open audio devices, doubleclick the FiiO X3 audio device, go to advanced tab, and select a default format (i use 24bit, 192000 Hz) click apply.
Quote:
Originally Posted by Marlene View Post

I don´t want to crush any hopes... but I´ve been doing this since October and it didn´t change anything. At first it seemed as it would but it was a placebo on my part. However, the interface will in fact be snappier so it´s still a good idea to do it.

I have no album art, and my X3 freezes at times, i think it's to do with the RAM usage.
post #9206 of 12912
What bloatware?
post #9207 of 12912
Quote:
Originally Posted by TrollDragon View Post

What bloatware?

The thesycon program. In my experience you don't need it, yet it gets installed.
post #9208 of 12912
Quote:
Originally Posted by CH23 View Post

The thesycon program. In my experience you don't need it, yet it gets installed.
Good to know, I might just uninstall and update drivers only.
post #9209 of 12912
A small input from my side for the upcoming firmware update: Everytime I experienced that the player could not play a track, I shortened the filename and the problem was solved. There seems to be a limitation in the lenght of the filename beside that of the filesystem (talking only about the internal storage because now I use an external card but I don't make very long filenames anymore).
... and please change 'Unknow Album' to 'Unknown Album' (- Genre, Artist).

Happy testing biggrin.gif
post #9210 of 12912

I just ordered my fiio x3 ...i bought a DX50 last week and i had to return it, for some reason i just did not like the sound it was a bit sterile sounding or flat with an anaemic bass i hope the x3 is better!!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.