or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 581

post #8701 of 17129

Hello,

 

I have had an X3 since December. It has been excellent. I updated the firmware no problems. Everything was perfect...until today.

 

The machine clicked off when in use...I assumed the battery was out. It was running via lineout into a portable speaker.

 

Since then, I cannot get the thing to turn on. I have tried recharging it. The charge light comes on but the computer no longer recognises it as an external drive. It doesn't put up in the 'my computer' (I have Windows 8).

 

Can anyone help? Is there a way to reboot it?

 

Incidentally, the machine has never been dropped, had water on it, or anything like that. Handled with kid gloves since I had it.

post #8702 of 17129
Quote:
Originally Posted by Thropplenoggin View Post

Hello,


 


I have had an X3 since December. It has been excellent. I updated the firmware no problems. Everything was perfect...until today.


 


The machine clicked off when in use...I assumed the battery was out. It was running via lineout into a portable speaker.


 


Since then, I cannot get the thing to turn on. I have tried recharging it. The charge light comes on but the computer no longer recognises it as an external drive. It doesn't put up in the 'my computer' (I have Windows 8).


 


Can anyone help? Is there a way to reboot it?


 


Incidentally, the machine has never been dropped, had water on it, or anything like that. Handled with kid gloves since I had it.


 



Reset your X3. There's reset hole near the heaphone out jack. If your computer doesn't recognize it, just recharge it using a normal wall outlet. Transfer your files using a microSD reader (this is what I do nowadays because file transfer speed is faster).
Edited by Za Warudo - 2/27/14 at 12:21pm
post #8703 of 17129
Quote:
Originally Posted by Thropplenoggin View Post
 

Hello,

 

I have had an X3 since December. It has been excellent. I updated the firmware no problems. Everything was perfect...until today.

 

The machine clicked off when in use...I assumed the battery was out. It was running via lineout into a portable speaker.

 

Since then, I cannot get the thing to turn on. I have tried recharging it. The charge light comes on but the computer no longer recognises it as an external drive. It doesn't put up in the 'my computer' (I have Windows 8).

 

Can anyone help? Is there a way to reboot it?

 

Incidentally, the machine has never been dropped, had water on it, or anything like that. Handled with kid gloves since I had it.

 

Like said above.

 

Take a pin, and poke the reset at the top of the X3. 

 

If it doesn't work still. Use an Apple or authorized Android USB wall adapter (usb charger that plugs into wall) and plug it into X3. Leave for 20m and then try the reset again with it connected.

 

Remove the mSD card and try those steps above.

 

All else fails, contact FiiO.

post #8704 of 17129
Quote:
Originally Posted by Thropplenoggin View Post

Hello,

I have had an X3 since December. It has been excellent. I updated the firmware no problems. Everything was perfect...until today.

The machine clicked off when in use...I assumed the battery was out. It was running via lineout into a portable speaker.

Since then, I cannot get the thing to turn on. I have tried recharging it. The charge light comes on but the computer no longer recognises it as an external drive. It doesn't put up in the 'my computer' (I have Windows 8).

Can anyone help? Is there a way to reboot it?

Incidentally, the machine has never been dropped, had water on it, or anything like that. Handled with kid gloves since I had it.

Hold the power button for 10 seconds, wait 5 second, and power it on again. (Or use the technique as the other two posts tell)
post #8705 of 17129
Quote:
Originally Posted by CH23 View Post

Hold the power button for 10 seconds, wait 5 second, and power it on again. (Or use the technique as the other two posts tell)[/quote
You can use a pin or paper clip on the top reset button.
post #8706 of 17129
Quote:
Originally Posted by JamesFiiO View Post
 

we are woking in the new firmware and new UI for X3, something share with you .

 

 

 

Very nice .....thanks a lot ^_^

post #8707 of 17129
Quote:
Originally Posted by JamesFiiO View Post
 

hope it will be a story about " The clown duck into a swan " . and we will add some new features in X3 in the coming soon.


New firmware looks incredible. Good work Team Fiio! :beerchug: Is there anyway you can make the X3 sound more neutral like the X5?

post #8708 of 17129
Quote:
Originally Posted by Thropplenoggin View Post

Hello,

I have had an X3 since December. It has been excellent. I updated the firmware no problems. Everything was perfect...until today.

The machine clicked off when in use...I assumed the battery was out. It was running via lineout into a portable speaker.

Since then, I cannot get the thing to turn on. I have tried recharging it. The charge light comes on but the computer no longer recognises it as an external drive. It doesn't put up in the 'my computer' (I have Windows 8).

Can anyone help? Is there a way to reboot it?

Incidentally, the machine has never been dropped, had water on it, or anything like that. Handled with kid gloves since I had it.
I would hate to ask and I've seen it before, do you have the "hold button" on.
post #8709 of 17129
Quote:
Originally Posted by M-13 View Post

Quote:
Originally Posted by JamesFiiO View Post
 

hope it will be a story about " The clown duck into a swan " . and we will add some new features in X3 in the coming soon.


New firmware looks incredible. Good work Team Fiio! :beerchug: Is there anyway you can make the X3 sound more neutral like the X5?


No one mess with the X3's signature. If you want it like the X5, get the X5. smily_headphones1.gif

Sent from my SCH-I545 using Tapatalk
post #8710 of 17129
Quote:
Originally Posted by TrollDragon View Post
 

I don't know about that isolator as there are limitations to it...

 

You will not have any 24/192 support and it will take a month to charge the X3 with that unit.

Just sayin...

Quote:
Originally Posted by ClieOS View Post
 

 

It will crash X5 (and highly likely X3 as well) and requires a restart to get back to normal when you have an USB isolator in between the player and the PC (*Yes, I have tried it). Both X3 and X5 will need high speed (480Mbps) USB 2.0 to work, but most USB isolator only works up to full speed (12Mbps). USB Isolator that actually supports high speed will cost about 10~20 units of X3, last I checked. The only thing that is workable is actually the iFi iUSB Power that has been mentioned, but it is still more expensive than X3 itself.

Thank you very much.

 

Keep using 3-to-2 prong adapter should be the most economic solution for me.

post #8711 of 17129

IEM's that gel with the X3??

 I just got a used X3, its on its way, I have some DT1350's I'll try and a bunch of IEM's but what is the best one, think $100-150 range......I'm curious how the RE-400's do with it and they are solidly in the budget!!

Thanks

 Ed

post #8712 of 17129
Quote:
Originally Posted by eclein View Post
 

IEM's that gel with the X3??

 I just got a used X3, its on its way, I have some DT1350's I'll try and a bunch of IEM's but what is the best one, think $100-150 range......I'm curious how the RE-400's do with it and they are solidly in the budget!!

Thanks

 Ed

Depends if you want complimenting sound sig, or on using the warm and bassy FiiO sound to counteract some analytical units. Those are the two typical 'way's people synergize units. 

 

Nuforce NE 700M goes well with the X3 in terms of it complimenting the Nuforce in everything it does.

post #8713 of 17129
Quote:
Originally Posted by bowei006 View Post
 

Depends if you want complimenting sound sig, or on using the warm and bassy FiiO sound to counteract some analytical units. Those are the two typical 'way's people synergize units. 

 

Nuforce NE 700M goes well with the X3 in terms of it complimenting the Nuforce in everything it does.


How about the Nuforce NE-600s? Just got a dirt cheap pair on Mass**** :biggrin:

post #8714 of 17129
Quote:
Originally Posted by batteraziiz View Post
 


How about the Nuforce NE-600s? Just got a dirt cheap pair on Mass**** :biggrin:

Since you have them, you tell me :D

 

I only have Ne700M

post #8715 of 17129
Quote:
Originally Posted by JamesFiiO View Post
 

we are woking in the new firmware and new UI for X3, something share with you .

 

 

 

 

I hope the icon with the gear and the musical note has the equalizer behind it.  ;)

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.