Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 467

post #6991 of 12310
Quote:
Originally Posted by Ziemas View Post

Can someone please tell me the latest X3 firmware is capable of reading id3 tags and supports id3 tag browsing? I'm looking to upgrade my Sansa Clip Zip, but as don't have everything organized in folders, only via tags, so I need proper tagged browsing for my music.

Thanks for the help.

Z.

The X3 has always supported id3 tags. There has always been the limitation that it can show your songs ordered by albums, OR it can show all songs under a particular artist or genre. It doesn't let you, say, select an artist, then let you browse the albums by that artist. We hope to make this feature available in a future firmware update but can't promise a time.
post #6992 of 12310
Quote:
Originally Posted by Joe Bloggs View Post


It doesn't let you, say, select an artist, then let you browse the albums by that artist. We hope to make this feature available in a future firmware update but can't promise a time.

^^^^^ This.

 

Once this point is solved, I can finally enjoy 100% the X3. Soundwise it's an amazing player, but if you have 100+albums on it, you really feel the pain when you search for a song (if you know the artist but not the album) :-(

post #6993 of 12310
Quote:
Originally Posted by sygyzy View Post
 

Hi,

 

I just received my X3. Is it possible to hide all the tracks that are in the memory (from the factory), short of deleting them?

Sorry that our X3 do not have this kind of funtion....If you don't listen to the Dummy head recording album that frequently, you can back up in your PC and take out when you have the feeling to listen!

post #6994 of 12310

I have owned the x3 for almost a month now and thought i would share my thoughts on some of the "freezing issues" that people have been experiencing. 

 

my x3 came with the 1.31 firmware, i experienced some freezing with this firmware, initially thought it was random but later on i was able to narrow it down to a few things, read below. 

After upgrading to 2.05 the freezing issue still happens, after upgrading to 2.1 there was no improvement, still getting system freeze. 

 

I listen to a mix of flac/mp3 files running on a 32GB sandisk class 10 micro sd card. Gapless play back on, Album covers display on.

 

initial troubleshooting was just trying to re-produce the freezing to prove that it is not random was quite difficult as it would just freeze up at random songs. 

 

But what i did notice was, the freezing always happens if i am browsing through my music collection, if i just let it play and not touch the player. It will play for hours with no issues. 

 

So this narrows it down to the player freezing due to browsing a song/album rather than from it playing a particular badly encoded file. 

 

After more days of troubleshooting i have come to the conclusion that one of the following or a combination of the things below has fixed my problem:

 

disable gapless playback

disable album covers - changed to display lyrics

deleted the .db and .journal file and re-scanned the sd card. 

 

it has been a week now and the player has been rock solid. Hope this helps the people that's been having issues!

post #6995 of 12310

I also just noticed that the x3 seems to struggle with long file names, i downloaded the hdtracks sampler pack and it was the first album that i could not get it to play in library mode, it was able to scan the id3 tags but when trying to play back the album the files fails to play. 

 

renaming all the files to less than 50 characters and running another library update fixed the issue. 

 

Note: i was able to playback the files with the long file name from browse files but not from the library categories. 


Edited by r33tom - 12/8/13 at 8:18pm
post #6996 of 12310
Quote:
Originally Posted by Joe Bloggs View Post


The X3 has always supported id3 tags. There has always been the limitation that it can show your songs ordered by albums, OR it can show all songs under a particular artist or genre. It doesn't let you, say, select an artist, then let you browse the albums by that artist. We hope to make this feature available in a future firmware update but can't promise a time.

That's exactly what I wanted to know. Thanks for the help. Sadly it's a deal breaker for me as I like to browse by Artist>Album. Hopefully it'll be sorted soon and I can get an X3.

post #6997 of 12310

So I noticed the line out sounds like garbage. I even used the special line out cable that came with it. Is it my unit or is this normal? I connected it to my car and made sure to keep the volume really low so that it wouldn't explode. I could only bump the car volume to like 5 at most. With how loud it is and the static, I just used the regular headphone out.

 

Audio quality is still sounding great, though! I wish we had a parametric EQ. My initial assumptions about the bass not being low enough seem to be actually correct. If you turn the bass to 10, of course, it's too much, but it still feels like something is missing. I don't have that problem when I crank up the bass on my Cowon J3 so I know it's not an issue with the IEM.

post #6998 of 12310
Quote:
Originally Posted by Unfie View Post
 

So I noticed the line out sounds like garbage. I even used the special line out cable that came with it. Is it my unit or is this normal? I connected it to my car and made sure to keep the volume really low so that it wouldn't explode. I could only bump the car volume to like 5 at most. With how loud it is and the static, I just used the regular headphone out.

Line out on mine is same quality as HP out, very good. There is no special line out cable that comes with it ? it comes with a digital out cable & a 1/8th to 1/8th mini cable. The line out is NOT next to the HP out, it is at the bottom next to USB.

post #6999 of 12310
Quote:
Originally Posted by punit View Post
 

Line out on mine is same quality as HP out, very good. There is no special line out cable that comes with it ? it comes with a digital out cable & a 1/8th to 1/8th mini cable. The line out is NOT next to the HP out, it is at the bottom next to USB.

 

Yes, I am very much aware of that. I am wondering if it has anything to do with me accidentally plugging in my IEMs to it when I first got it. That mini cable you said is what I was talking about by "special line out cable" because that's what it was for. 

post #7000 of 12310

It can be 3 things :

 

1. The cable, you will have to test with a diff cable.

2. Your car stereo line in may be faulty, you will have to test whether it has same problem on a friends car stereo.

3. If not both of above then you got a defective unit & line out is faulty.

post #7001 of 12310

It was mentioned before that the X3 line out at 1.7v maybe too powerful for some amps and hence resulting in distortion.

post #7002 of 12310
Quote:
Originally Posted by CosmicHolyGhost View Post
 

It was mentioned before that the X3 line out at 1.7v maybe too powerful for some amps and hence resulting in distortion.

 

This is very often the case. As line in on car audio is more often than not, not an actual line in. Usually they are designed to be used with the headphone out of mobile devices.

 

 

Nice example of this: In my previous car I had an one-model-below-top-of-the-line Pioneer headunit (DEH-8600MP, if I'm not mistaking). It was absolutely brilliant in all but one aspects: The so called "line in" was meant to be used with Headphone out as input. Quite odd actually, as the 3 line out pairs on this unit were 5V high volt outputs, which meant you couldn't just hook up any amp to it. 

 

No matter what line level signal I put on it, it would distort exactly the way you describe it. It was worst with my S:Flo2, but the X3 and even a CD homedeck (with a very long extension cord and some weird looks from my neighbours) would cause this distortion too. When I used the headphone out, toning the volume down a little, it would sound ok. That was the first time I saw the value of Rockbox' adjustable line out volume on my Fuze & iPod Classic.

As these players both use proprietary dock connectors for their line outs and the length and/or stiffness of the LODs I had available never came close to matching the distance to the storage compartment I wanted to put my player in, I just started using my Clip+ through headphone out with a regular 3.5mm to 3.5mm cable and it worked even better. Not ideal either, as I nearly blew my eardrums out a couple of times switching from car setup to gym setup with IEMs. But hey, the bright side was that I had an excuse to buy a Fiio E6 :)

 

My current car, a 2013 Renault Clio Estate, has a proprietary built in sound system, with a line in jack on the dash. This handles the line out of the X3 just fine, no distortion, but it is significantly louder than other sources. The S:Flo2 is still a no go, the line out on that thing is just crazy powerful.

post #7003 of 12310
So it seems that I'm going to buy the X3.

What am I looking for when I'm going to buy an external battery? Any suggestions on good value ones from ebay? What are the rest of you guys using, are you able to manage well without one?

(Probably worth adding is that I live in Sweden and thus options for international shipping is a must)
Edited by Simcon - 12/9/13 at 9:09am
post #7004 of 12310
Quote:
Originally Posted by Simcon View Post

So it seems that I'm going to buy the X3.

What am I looking for when I'm going to buy an external battery? Any suggestions on good value ones from ebay? What are the rest of you guys using, are you able to manage well without one?

My choice of battery pack is the AL-350 from A-solar. 7000mAh, can charge 2 devices at once.
The X3 lasts around 10 hours.
cable used for charging and DAC is a nokia CA-101D. Short, high quality USB to microUSB
post #7005 of 12310
Quote:
Originally Posted by Simcon View Post

So it seems that I'm going to buy the X3.

What am I looking for when I'm going to buy an external battery? Any suggestions on good value ones from ebay? What are the rest of you guys using, are you able to manage well without one?

I picked up a Chinese made battery pack in Thailand for some 30 USD.  8400mAh it has both a 2 and 1 amp (5v each) USB port.  Charges via a microUSB cable so I can just pack one cable and use it for my phone, X3 and charge the battery pack.  When at home, it will charge off the powered USB hub and provide juice to both ports at the same time.

 

Only real problem is that it is not UL/CE rated....and since my daughter was there I had to get the pink one so a bit embarrassing to use it in public.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.