or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 462

post #6916 of 17125
Quote:
Originally Posted by JosephKim View Post

My X3 is incoming!! After being underwhelmed with the DX50 I hope the X3 hits a sweet spot.
Hopefully you will like that one better. How about the VSD1s, are you liking those? The UI is really good on the X3 and it has a solid build and fell to it. I only have one issue with mine shortly after buying it as one of the pixels died.
post #6917 of 17125
Quote:
Originally Posted by tjw321 View Post
 

So far, cross fingers, I've only had a couple or so freezes, but they have all been when the gapless setting is on. It may be coincidence, but it may be worth turning gapless off if you don't need it?

undersys, vic2vic, and tjw321,

 

I've experienced the same issues with gapless set to on.  What format was the music in?  Were you playing using "browse files" mode or "category" mode?

 

My settings were: gapless ON, AAC (M4A, TVBR encoded with  QAAC), and playing under "browse files" mode.

post #6918 of 17125

guys... need a little help from x3 owners...

 

i ordered these on adorama.com for $139

 

looking for headphones that match with these

 

i short listed grado 125i or 225i

 

any suggestions guys...

post #6919 of 17125
225i without a doubt. Much better than the lower end Grados.
post #6920 of 17125
Quote:
Originally Posted by howdy View Post


Hopefully you will like that one better. How about the VSD1s, are you liking those? The UI is really good on the X3 and it has a solid build and fell to it. I only have one issue with mine shortly after buying it as one of the pixels died.

Well I have only used the VSD1S with the DX50 and I didn't like them. Maybe they will be better with the X3

post #6921 of 17125
Quote:
Originally Posted by pennylane View Post
 

undersys, vic2vic, and tjw321,

 

I've experienced the same issues with gapless set to on.  What format was the music in?  Were you playing using "browse files" mode or "category" mode?

 

My settings were: gapless ON, AAC (M4A, TVBR encoded with  QAAC), and playing under "browse files" mode.

My settings are : gapless ON, FLAC and using the "browse files" mode.

post #6922 of 17125
Quote:
Originally Posted by pennylane View Post

undersys, vic2vic, and tjw321,

I've experienced the same issues with gapless set to on.  What format was the music in?  Were you playing using "browse files" mode or "category" mode?

My settings were: gapless ON, AAC (M4A, TVBR encoded with  QAAC), and playing under "browse files" mode.
Exactly the same as you except I used XLD to encode my files - gapless on, AAC TVBR and browse files.
post #6923 of 17125
Quote:
Originally Posted by Andrew_WOT View Post
 

So DX50 UI is better, so is the build I'd assume.

What about the sound, tried to read through the posts comparing both but opinions are all over the board.

Thanks in advance

 

The UI of the DX50 was pretty infuriating to me. It's the main reason for me selling it. The build of the X3 is very good however and definitely seems more sturdy than the DX50 in terms of it being able to handle an accidental drop.

post #6924 of 17125
Quote:
Originally Posted by rawrster View Post
 
Quote:
Originally Posted by Andrew_WOT View Post
 

So DX50 UI is better, so is the build I'd assume.

What about the sound, tried to read through the posts comparing both but opinions are all over the board.

Thanks in advance

 

The UI of the DX50 was pretty infuriating to me. It's the main reason for me selling it. The build of the X3 is very good however and definitely seems more sturdy than the DX50 in terms of it being able to handle an accidental drop.


Interesting, like I said opinions are all over the map.

Comparison: FiiO X3 vs. iBasso DX50 - Head-Fi

Quote:
 

 

Build quality
The DX50 has the edge here.  Upon first receiving the X3, I have to admit that I was disappointed that the build quality isn’t even close to the quality of my E17.  I realize James told us in advance that the X3 design is several years old (it was put on hiatus for over a year due to subcontractor supply problems) and that we should not expect more up-to-date E17-like build quality, but I still felt the disappointment.  The E17’s beautiful brushed aluminum case is sublime.  The quality of the case is first-rate and it feels like it was milled from a solid aluminum block.  Not so with the X3.  From a distance, the X3 appears to be built like the E17, but that is only in appearance.  The case is actually plastic, and not particularly sturdy feeling plastic either.  There are thin sheets of brushed aluminum bonded to the top and bottom to give the appearance of an aluminum case, but once you hold it in your hand, the illusion ends there.  I don’t think it would survive even a short fall onto a concrete floor very well.  I keep my X3 is in the silicone sleeve at all times.  It is a bit weird looking, but I feel much more comfortable with some protection. 
 

In comparison, the DX50 is more than a bit better.  While still nowhere near the quality of the E17’s construction, the DX50 just feels more solid.  The plastic body is much thicker, better finished, and feels more durable.  There is also more (and thicker) aluminum used in the outer shell.  The DX50 feels more solid in the hand, and it would probably survive an accidental drop better than the X3.

 

As you owned both, any comments on sound quality on two?

post #6925 of 17125

My X3 just arrived yesterday. So far I have to say the device has good value for the money. The AMP is powerful enough, I listen to my Beyer DT880 250 Ohm at 50% volume, low gain. The sound quality doesn't wow me, but it does a much better job than my laptop/smartphone. It is very clean, I can hear guitar strings vibrate, singers' breath better. I have to tone down the treble -2 to suit the bright DT880. My current favorite combo is paring the X3 with the Vsonic GR07be IEM. The X3 just makes the clear sound of GR07be ultraclear and its bass & treble better well-extended, without EQ.  :dt880smile:

post #6926 of 17125
Quote:
Originally Posted by z7nz View Post
 

I have seen these the sound doesn't wow me after first listen many times, then someone goes back to your old device and the story changes. Hearing guitar strings vibrate and singers breathe hmmm.

post #6927 of 17125
Quote:
Originally Posted by subguy812 View Post

I have seen these the sound doesn't wow me after first listen many times, then someone goes back to your old device and the story changes. Hearing guitar strings vibrate and singers breathe hmmm.

About the strings vibrate and singers breath, I can hear them using my laptop/smartphone, I just happen to hear them clearer with the X3. I wonder if it's the AMP that make my can/iem perform better, or the X3 itself. Maybe both smily_headphones1.gif
post #6928 of 17125

Just purchased the X3 last week and received it in the mail the other day.

 

I wish I would have read this thread detailing the issues with OGG before making the purchase.

 

The SD card that I've been using in my Clip+ has 300+ albums in it all ripped to OGG format, and all tagged correctly (using MP3 tag) so that they show up in the Clip+'s Library/Database.  They play splendidly in the Clip+.

 

The X3 will not read any of these files.  It's bad enough that they do not show up in the Library.  But what's much worse is that even when I go into "Browse Files > Micro SD Card," it will not actually play the files, just skipping over them one by one.

 

I updated to the newest firmware (2.1) on the X3, and that didn't resolve the issue.

 

I loaded some FLAC and MP3 files onto the X3, and they play fine and show up in the Library.

 

Also, the problem is not with the SD card because the X3 will play the 10 or so albums that I have in MP3 format on the card.  It's specifically the OGG files that will not playback.

 

But since I can't playback 80% of the files that I want to on the player, I guess I have no choice but to return it.

 

Very disappointing.

 

I assume this issue is something that has not yet been fixed nor will be fixed soon?  I don't want to wait around hoping that they'll fix it and then that never happen and miss the return date.


Edited by steelglam - 12/5/13 at 10:26am
post #6929 of 17125
Is it true? X3 won't play ogg files? On fiio website i see it should play them. Maybe your encoding is different somehow.
post #6930 of 17125
Quote:
Originally Posted by LightBlue77 View Post

Is it true? X3 won't play ogg files? On fiio website i see it should play them. Maybe your encoding is different somehow.


My encoding has worked on two Clip+'s and a Fuze for years, so I don't think it's an encoding problem.

 

Also, all have been tagged with MP3tag, and they can be read in my Sansa players, so I don't think it's a tagging issue.


Edited by steelglam - 12/5/13 at 11:21am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.