or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 325

post #4861 of 17125
Quote:
Originally Posted by JamesFiiO View Post
 

to all users, I can see almost every advice about the UI, and I am working in a list about the firmware issues. and in the past couple months, we have released at least 4 version. behind it , there are a team includes 7 software engineers and 10 QA to test the firmware.

 

to be honest, I don't see any other company improve the firmware as we did . and here is the situation:

 

1, we have to spent time in the development of X5. 

 

2, the most bugs and the advice already finished or fixed.

 

3, some advice is hard to be done in the coming soon, but we may redesign the whole UI/UE in 2014 depended on the UI of X5 which will be far more better than X3. hope you can understand, something need to solve from the beginning . the firmware updated is not magic.

 

so, we will take care every suggestion or bugs report and don't worry I am here listening and watching to you. and I promise we will try our best to make X3 perfect . but if we can't , it must be out of our ability, but I hope you can still support us . caz man are man caz we are not 

 

God!  

 

Thanks for the update and the continued support. The majority is very happy with the X3 if I may say so, at least I am. Personally I have no problems with the current UI but that could be me as I foremost shuffle all my songs when listening.

If we get a revamped UI later on that would be awesome support :D

Best regards from The Netherlands to you and the crew!

 

Edit:

@ James: is the leather case already Internationally available and what would be the suggested retail price? 


Edited by maniac2003 - 9/6/13 at 11:52pm
post #4862 of 17125

Thank you James for all your hard work,it's appreciated.

I have a small problem. I updated to 1.31 no problem and put in my 64gb card, everything indexed with no problem. I then removed some files and added some to the card and updated the library.this time the new files did not appear. I then removed the card and updated the library. I now get the message "updating file please wait". This is now constant. I have tried resetting the player but all the SD card files can still be seen in category but not in the file browser. Is there any way that I can delete the database as as the player will not do it for me. I have also reinstalled the 1.31 firmware but no change. Can anyone help me get rid of the constant updating file ?

Thank you

post #4863 of 17125
Quote:
Originally Posted by maniac2003 View Post
 

 

Thanks for the update and the continued support. The majority is very happy with the X3 if I may say so, at least I am. Personally I have no problems with the current UI but that could be me as I foremost shuffle all my songs when listening.

If we get a revamped UI later on that would be awesome support :D

Best regards from The Netherlands to you and the crew!

 

Edit:

@ James: is the leather case already Internationally available and what would be the suggested retail price?

 

should be but it depend on our local dealer, plz contact our sales agents in Netherlands. and I can't remember the MSRP righ now.

post #4864 of 17125
Quote:
Originally Posted by gikigill View Post

I am on the line for a DX50 but their previous efforts are expensive.

 

you don't need to pay another usd30 in the shipment and don't forget you can get local warranty service. of course, not everyone will have problem in quality.

 

anyway, it is the only way to provide decent products and service to the customer, and the local government also benefit in our products, VAT, local employee. we don't like to compare with others but

 

of course we can sell cheaper by ourself directly to the end customer, it is cost effecience but not good for everyone.

post #4865 of 17125
Quote:
Originally Posted by graemei101 View Post
 

Thank you James for all your hard work,it's appreciated.

I have a small problem. I updated to 1.31 no problem and put in my 64gb card, everything indexed with no problem. I then removed some files and added some to the card and updated the library.this time the new files did not appear. I then removed the card and updated the library. I now get the message "updating file please wait". This is now constant. I have tried resetting the player but all the SD card files can still be seen in category but not in the file browser. Is there any way that I can delete the database as as the player will not do it for me. I have also reinstalled the 1.31 firmware but no change. Can anyone help me get rid of the constant updating file ?

Thank you

 

 

yes, this can be solved by delete the database file in PC, please email to support@fiio.net and get help about how to do that. and we will add this to the FAQ in the coming soon.

post #4866 of 17125

Thank you for your prompt assistance

Graeme

 

Update - I have been in contact with support. All sorted now.

Thanks again


Edited by graemei101 - 9/7/13 at 3:09am
post #4867 of 17125

James would support be able to assist me with the issue I am having? How do i contact support personell?

post #4868 of 17125

That right,i hope the x3 has this and that blablabla crap" in this thread! i doubt though.thanks

21.gif

post #4869 of 17125
Quote:
Originally Posted by oldpiglas View Post

That right,i hope the x3 has this and that blablabla crap" in this thread! i doubt though.thanks
21.gif
Way to welcome yourself to the community. Just a killer post.rolleyes.gif
post #4870 of 17125
Quote:
Originally Posted by graemei101 View Post
 

Thank you for your prompt assistance

Graeme

 

Update - I have been in contact with support. All sorted now.

Thanks again

Graeme

 

Possible to share the tip on how to delete database file... Did the firmware upgrade but still not getting the files in the library, guessing could be corrupted already.... thanks!

 

cheers

post #4871 of 17125

I've sent you a pm

Graeme

post #4872 of 17125
Quote:
Originally Posted by graemei101 View Post
 

I've sent you a pm

Graeme

 

yay! worked like a champ. Million thanks!! Happy to see my library appeared in the X3.

post #4873 of 17125
Quote:
Originally Posted by graemei101 View Post

I've sent you a pm
Graeme
pm

Graeme

[/quote] Can you send me that PM, too, please? I'm having the same library issues.
post #4874 of 17125

Done

post #4875 of 17125

Because it helps every other person with database issues to send a pm rather than posting in this thread. 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.