or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 305

post #4561 of 17129
Quote:
Originally Posted by good sound View Post

It would appear that the files accessable from the categories folder are files that are on the internal memory only and not from the external(micro SD card) source. Is this correct?

I just ripped Abbey Road from the Beatles and if played back through Categories/Album it plays back gapless, but if I play it back from the Browse Files folder it does not. Partial success I guess but i don't understand why Nirvana MTV Unplugged-Live in New York, which was ripped the exact same way will not play gaplesss either way. It plays gapless on all of my PC media playback software. Very puzzling.

Yes in the current firmware (1.25) gapless playback only works wen you play albums through categories>albums

If the nirvana album was somehow mistagged, that might stop it from being played gaplessly.

if i understood it right, in a future update, gapless playback will be possible everywhere.
post #4562 of 17129
Quote:
Originally Posted by CH23 View Post


Yes in the current firmware (1.25) gapless playback only works wen you play albums through categories>albums

If the nirvana album was somehow mistagged, that might stop it from being played gaplessly.

if i understood it right, in a future update, gapless playback will be possible everywhere.

I have checked and the Nirvana album is tagged properly.

 

Yes I know that gapless playback is only possible through  Categories/Album. I was asking if Categories/Album only displays files that are loaded on the internal memory and not on an external source such as a micro SD card. It certainly appears to be that way. So in essence not only can you get gapless playback from only the one path, but that one path is restricted to the 8GB internal memory of the player. Until the firmware fix I'd better make sure any files that require gapless playback are loaded onto the internal memory.

 

Also, another peculiar thing. Some  full albums are accessable on their own from Categories/Album but most are just listed by song in a very long list under the heading unknown album, although they were loaded onto the player in the exact same way, and are titled and fully separate under browse files. I wonder why this is?

 

Also, and this is even more peculiar, with the DVD-Audio album Love form the Beatles, ripped from DVD-Audio Extractor and transferred to the X3 via JRiver Media center 18, if I access the album from Browse Files the tracks are in their proper order, or sequence, and will not play gapless as already established, but if I access this album through Categories/Album the tracks are placed in alphabetical order instead of numerical order, but in the few instances where there are two or more tracks in numerical order, simply by the luck of the alphabetical draw, they will play gapless, which they did not previously on the initial transfer of this album. This is very strange. I deleted and transferred this album again as it was originally on the micro SD card and not the internal memory, thus ultimately the reason why it was not playing gapless. Now if i can only get the track progression correct I should be all set for this file.

 

I have ripped and transferred both Abbey Road, and The Dark Side Of The Moon, ripped via EAC and transferred via MC18, onto the internal memory and they will both play gapless flawlessly from the Categories/Album header, so it would seem that the issue may indeed be with the Nirvana file, but i can't for the life of me figure out what that issue could be. Like I said i have checked the tags and they are correct and this file plays gapless on MC18, Foobar, and through Windows Media Player, the latter in WAV as flac is not supported in Windows Media Player. The Nirvana file has always been located on the internal memory of my X3.


Edited by good sound - 9/1/13 at 5:13am
post #4563 of 17129
Quote:
Originally Posted by good sound View Post

I have checked and the Nirvana album is tagged properly.

Yes I know that gapless playback is only possible through  Categories/Album. I was asking if Categories/Album only displays files that are loaded on the internal memory and not on an external source such as a micro SD card. It certainly appears to be that way. So in essence not only can you get gapless playback from only the one path, but that one path is restricted to the 8GB internal memory of the player. Until the firmware fix I'd better make sure any files that require gapless playback are loaded onto the internal memory.

Also, another peculiar thing. Some  full albums are accessable on their own from Categories/Album but most are just listed by song in a very long list under the heading unknown album, although they were loaded onto the player in the exact same way, and are titled and fully separate under browse files. I wonder why this is?

Also, and this is even more peculiar, with the DVD-Audio album Love form the Beatles, ripped from DVD-Audio Extractor and transferred to the X3 via JRiver Media center 18, if I access the album from Browse Files the tracks are in their proper order, or sequence, and will not play gapless as already established, but if I access this album through Categories/Album the tracks are placed in alphabetical order instead of numerical order, but in the few instances where there are two or more tracks in numerical order, simply by the luck of the alphabetical draw, they will play gapless, which they did not previously on the initial transfer of this album. This is very strange. I deleted and transferred this album again as it was originally on the micro SD card and not the internal memory, thus ultimately the reason why it was not playing gapless. Now if i can only get the track progression correct I should be all set for this file.

I have ripped and transferred both Abbey Road, and The Dark Side Of The Moon, ripped via EAC and transferred via MC18, onto the internal memory and they will both play gapless flawlessly from the Categories/Album header, so it would seem that the issue may indeed be with the Nirvana file, but i can't for the life of me figure out what that issue could be. Like I said i have checked the tags and they are correct and this file plays gapless on MC18, Foobar, and through Windows Media Player, the latter in WAV as flac is not supported in Windows Media Player. The Nirvana file has always been located on the internal memory of my X3.

Sorry, i meant to answer that question as well, however i forgot to add it to my initial response.
Yes, categories/album should work for external memory as well. It does work for me.
Gapless playback wirks for some of my albums, both on the internal and external memory.

I think that the problem with the DVD audio the problem is with the tagging. If the ID3 tags aren't correct, it won't work. Same for the abbey road & DSOTM rip. of clurse, the chances are it's a bug on the X3. (EAC is sadly not all knowing)
post #4564 of 17129
Quote:
Originally Posted by CH23 View Post



Yes, categories/album should work for external memory as well. It does work for me.
 

Well, that's strange. When I go into Categories/Album the only files i have access to are ones that are on the internal memory. None of the files I have loaded on my micro SD card can be accessed via Categories/Album, plus like I mentioned in my previous post several of the albums I have loaded into my internal memory are only listed by track, alphabetically, in a long list in a folder titled unknown album in Categories/Album, but when I go through Browse Files these same albums are in individual folders with the album title listed as they should be. I am beginning to wonder if maybe I should try and uninstall the v1.25 firmware and then re-install it to see if that straightens things out. Then again the newest firmware update should be out in about a week so maybe i will just wait until then.

post #4565 of 17129

When you use the 'Browse Files' function you are browsing through the actual folder structure you see on the microSD while browsing from the PC. I have a few tracks under the "Unknown Artist" tag, too (actually some of my older MP3s), probably due to corrupted/incomplete tags. I'm not interested in rectifying these files, it's just about 5-6 tracks.

post #4566 of 17129
Quote:
Originally Posted by MrScratch View Post

When you use the 'Browse Files' function you are browsing through the actual folder structure you see on the microSD while browsing from the PC. I have a few tracks under the "Unknown Artist" tag, too (actually some of my older MP3s), probably due to corrupted/incomplete tags. I'm not interested in rectifying these files, it's just about 5-6 tracks.
You see both internal and external memory through "browse files" function.
Browse files - internal ->
-external->


My OCD always kicks in when i see unnamed tracks.
Same for missing albumart (which is now a huge issue, having ripped about all music with iTunes)
Quote:
Originally Posted by good sound View Post

Well, that's strange. When I go into Categories/Album the only files i have access to are ones that are on the internal memory. None of the files I have loaded on my micro SD card can be accessed via Categories/Album, plus like I mentioned in my previous post several of the albums I have loaded into my internal memory are only listed by track, alphabetically, in a long list in a folder titled unknown album in Categories/Album, but when I go through Browse Files these same albums are in individual folders with the album title listed as they should be. I am beginning to wonder if maybe I should try and uninstall the v1.25 firmware and then re-install it to see if that straightens things out. Then again the newest firmware update should be out in about a week so maybe i will just wait until then.

I still think it could have to do with the ID3 tags.
You could try reinstalling the firmware, if it works, please let us know smily_headphones1.gif
post #4567 of 17129

now most problem is about the album/artist playback, gapless playback, and the format of TF card, thanks for all your support. we should release a new firmware in next week , but hope all can understand we really need time to fix all the bugs. what I can say is that all will be fixed , and the reason why it is not fixed before we release X3 to outside China, is because there are few people in China use gapless, album/artist playback, and none put over 256 sub folders in one folder. 

 

also from the feedback, now we realized that a good products is win in the detail, but we believe we can do that caz we are working hard in the new firmware and already fix quite some bugs. 

post #4568 of 17129
Quote:
Originally Posted by CH23 View Post


You see both internal and external memory through "browse files" function.
Browse files - internal ->
-external->


My OCD always kicks in when i see unnamed tracks.
Same for missing albumart (which is now a huge issue, having ripped about all music with iTunes)
I still think it could have to do with the ID3 tags.
You could try reinstalling the firmware, if it works, please let us know smily_headphones1.gif

I have checked all of my ID3 tags and they look complete unless you know of a different and better way other than checking the properties of a file through windows or dbPoweramp. I still can't see any of the files on my SD card when going in through categories/Album and I don't see where that would have anything to do with incomplete ID3 tags.

post #4569 of 17129
Quote:
Originally Posted by good sound View Post

I have checked all of my ID3 tags and they look complete unless you know of a different and better way other than checking the properties of a file through windows or dbPoweramp. I still can't see any of the files on my SD card when going in through categories/Album and I don't see where that would have anything to do with incomplete ID3 tags.

dbPoweramp is one of the best ways, as far as i know. you could also try IDTE, the developer is really helpful.
i think the 2 important tags are ALBUM and TRACKNO. are you sure there are no spelling errors, or capital letters for some files, where others don't have them?
And about the categories/album thing, did you update the library after adding the SD? And is the SD in fat32 format?

Quote:
Originally Posted by JamesFiiO View Post

now most problem is about the album/artist playback, gapless playback, and the format of TF card, thanks for all your support. we should release a new firmware in next week , but hope all can understand we really need time to fix all the bugs. what I can say is that all will be fixed , and the reason why it is not fixed before we release X3 to outside China, is because there are few people in China use gapless, album/artist playback, and none put over 256 sub folders in one folder. 

also from the feedback, now we realized that a good products is win in the detail, but we believe we can do that caz we are working hard in the new firmware and already fix quite some bugs. 

You're doing a great job, James (and team)!
Really happy with the service you guys deliver.
post #4570 of 17129
Quote:
Originally Posted by CH23 View Post


dbPoweramp is one of the best ways, as far as i know. you could also try IDTE, the developer is really helpful.
i think the 2 important tags are ALBUM and TRACKNO. are you sure there are no spelling errors, or capital letters for some files, where others don't have them?
And about the categories/album thing, did you update the library after adding the SD? And is the SD in fat32 format?
 

Yes, I have updated the library after inserting the SD card. I have it set to auto update, and yes the card was formatted to fat32

 

As far as i can see all the album and track info is correct, spelled properly and consistent in character.

post #4571 of 17129

Well I decided to completely delete and re-rip the Nirvana-Unplugged album and now it plays without gaps,YAY!

 

Now I just have to figure out why in Categories/Album i can't access the files on my SD card and why also in Categories/Album the Beatles-Love track listing is alphabetical instead of numerical but in Browse Files it is numerical starting at track one as it should be. 

 

I'm chipping away at it. It's taking up the bulk of my weekend but hey I really didn't have anything better to do anyway.

post #4572 of 17129
I don't think the X3 can index more than a couple of directories deep (might have been fixed in the last firmware). Maybe that is your problem on the SD card?
post #4573 of 17129
Quote:
Originally Posted by tjw321 View Post

I don't think the X3 can index more than a couple of directories deep (might have been fixed in the last firmware). Maybe that is your problem on the SD card?

Yes this could also be the problem.
post #4574 of 17129
Quote:
Originally Posted by CH23 View Post


Yes this could also be the problem.

 

 

Quote:
Originally Posted by tjw321 View Post

I don't think the X3 can index more than a couple of directories deep (might have been fixed in the last firmware). Maybe that is your problem on the SD card?

If these responses are directed at me i am not sure what you are talking about. Could you please explain this a little more clearly and in more detail? I have the latest firmware correctly installed.

post #4575 of 17129
Quote:
Originally Posted by good sound View Post


If these responses are directed at me i am not sure what you are talking about. Could you please explain this a little more clearly and in more detail? I have the latest firmware correctly installed.

you can't have a folder in a folder in a folder in a folder.
SD root-> folder -> folder in folder -> folder in folder -> audio.flac
that can't be read because the file is too many levels(folders) deep.

root -> folder -> folder in folder -> audio.flac
This could and should work.

on my X3 i have the following structure:
Root-> ARTIST -> ALBUM -> TRACKS.flac
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.