or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 287

post #4291 of 17125
I updated to 1.25EN, then i manually updated the library. No luck, the indexing is still broken. It goes artist>tracks and album>tracks, and all ofthose are 01 01 01 01 02 02 02 02 03 03 03 03 etc.\

Am i supposed to completely remove every single album, update lib, re-add them, and update lib again?
post #4292 of 17125
Quote:
Originally Posted by shrimants View Post

I updated to 1.25EN, then i manually updated the library. No luck, the indexing is still broken. It goes artist>tracks and album>tracks, and all ofthose are 01 01 01 01 02 02 02 02 03 03 03 03 etc.\

Am i supposed to completely remove every single album, update lib, re-add them, and update lib again?

http://www.head-fi.org/t/651769/fiio-x3-thread-full-review-http-www-head-fi-org-t-663600-impression-fiio-x3-high-fi-low-price/3540#post_9684111

 

Not a fix but a work around. If you aren't good with computers, don't understand what is going on, and don't care. Then don't attempt it. There are plenty of warnings in the page. Not everyone has intermediate computer skills to do this or want to. 

post #4293 of 17125
yeah, i saw this. I just figured i'd stick to the "browse" thing instead of using the tags. So far it hasnt really gotten in the way since i hardly ever search through for a specific song, but when i do have to do that, its very annoying and can be easily found using browse instead of category. Everything is maticulously named and sorted in my player anyways. I just wanted to point out that they stated that 1.25 fixed this issue and im still having it.
post #4294 of 17125
Quote:
Originally Posted by shrimants View Post

yeah, i saw this. I just figured i'd stick to the "browse" thing instead of using the tags. So far it hasnt really gotten in the way since i hardly ever search through for a specific song, but when i do have to do that, its very annoying and can be easily found using browse instead of category. Everything is maticulously named and sorted in my player anyways. I just wanted to point out that they stated that 1.25 fixed this issue and im still having it.

They fixed an issue, not the one you want

 

Before it would go 

 

01

01

11

11

12

12

13

13

 

(if you had two albums that both go up to 13 tracks etc etc)

Now it goes

01

01

02

02

03

03

04

04

etc etc sequentially

1

post #4295 of 17125
Quote:
Originally Posted by shrimants View Post

I updated to 1.25EN, then i manually updated the library. No luck, the indexing is still broken. It goes artist>tracks and album>tracks, and all ofthose are 01 01 01 01 02 02 02 02 03 03 03 03 etc.\

Am i supposed to completely remove every single album, update lib, re-add them, and update lib again?

I noticed that the FiiO rep posted 4 or 5 posts after I asked if the indexing problem was ever going to be fixed.  Still no response.  The question is being ignored.

 

Can we get an official answer?  

Then again we could go vote on whether a parametric equalizer should be added before the unit is able to index the library.

post #4296 of 17125

I think James is not ignoring it as much as he does not want to give an answer he can't deliver.

 

The X3 being delayed for 2+ years probably deals with him not making set promises or announcements he isn't sure of probably.

 

And he is not just the represenative of FiiO. He's the CEO so he spends his time with other stuff as well.

post #4297 of 17125

this is why I always use folders. not 2 daps deal with tags (artist album genre etc) the exact same way. and even when it's well done, it's such a bother to learn a new way on each dap. on the other hand a folder is a folder everywhere.

post #4298 of 17125
Quote:
Originally Posted by bowei006 View Post
 He's the CEO so he spends his time with other stuff as well.

like trying not to end up naked in the street with the x5 ^_^

post #4299 of 17125
Hi James! Great product. Quick Q: is there a size limit to the cover art for the X3: the reason I ask is that even with the new FW, some of my ALAC albums covers show up but not others. Thanks!
post #4300 of 17125
Quote:
Originally Posted by Kiats View Post

Hi James! Great product. Quick Q: is there a size limit to the cover art for the X3: the reason I ask is that even with the new FW, some of my ALAC albums covers show up but not others. Thanks!

 

YES, the cover files must meet the below requirement includes

 

1, size less than 1M.

 

2, resolution less than 1024*1024

 

3, must be in jpg, bmp , png format

post #4301 of 17125
Quote:
Originally Posted by JamesFiiO View Post

YES, the cover files must meet the below requirement includes

1, size less than 1M.

2, resolution less than 1024*1024

3, must be in jpg, bmp , png format

Thanks for the quick reply James. Will try to work it out. I assume the same applies for album art embedded in ALAC? ie. the file name of the graphic file? Thanks for your patience.
post #4302 of 17125
Quote:
Originally Posted by msromike View Post

I noticed that the FiiO rep posted 4 or 5 posts after I asked if the indexing problem was ever going to be fixed.  Still no response.  The question is being ignored.

 

Can we get an official answer?  

Then again we could go vote on whether a parametric equalizer should be added before the unit is able to index the library.

 

1, We will not add parametric equalizer in X3 till we can make a decent software EQ. noted it is not we don't want it is we can't. we always like to support our user if we can.

 

2, please understand that there have more than 100 requirements about the firmware , but remember we just go into this market not more than 1 years, so we need time to improve the UI/GUI step by step and it cost us a lots of resource to do this.

 

so far, I am response for any questions about FiiO and our staff just help me post some official news and such etc. there are some reasons for this

 

1, hard to find staff have enough skill in English, Technical and how to talk with end customers.

 

2, they don't need to work when they leave office. :) 

post #4303 of 17125
Quote:
Originally Posted by JamesFiiO View Post

1, hard to find staff have enough skill in English, Technical and how to talk with end customers.

 

2, they don't need to work when they leave office. :) 

I'm sure with FiiO getting larger, maybe opening an office in HK with lots of people skilled in English and Chinese will rectify this issue right up! wink.gif

post #4304 of 17125
Quote:
Originally Posted by bowei006 View Post

I'm sure with FiiO getting larger, maybe opening an office in HK with lots of people skilled in English and Chinese will rectify this issue right up! wink.gif

Then you will no longer see FiiO as competitive as it is now.

 

I'm sure that are english literates around in china. But such people usually have bright futures and won't sit in a desk just replying people.

post #4305 of 17125

Hey James, I have a bug to report, not sure if this is the right thread but here goes.

For my multi-disc albums, I usually name my files as 1.01 [song title], 1.02 [song title], ... , 2.01 [song title] and so on. It goes %discnumber% then %tracknumber% with a dot in between. All files will be put into a single folder for the whole album.

These files are not sorted correctly on the X3 (using firmware 1.25EN). For example, Dream Theater's Live Scenes from New York, on the X3 it goes: 1.10, 1.03, 1.01, 1.04 to 1.09, 1.02, 2.03, 2.01, 2.02, ...

The sorting appears to be random, varying from album to album. On another album of mine, it goes 1.02, 1.04 to 1.15, 1.01, 1.16 to 1.24, 1.03, 2.25, 2.15, 2.01, ....

Hope that this could be fixed, thanks!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.