or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 240

post #3586 of 17125

about the TAGs support in X3, we sitll need more time to fix it . in China, X3 launched marekt in 3 months ago, but most user in China tend to use the folder to play music, but it is different in Western regions,

 

just like Android VS IOS, it make us a little difficult to support both very good at the same time, but all should be fixed in the new firmware.

 

Anyway, if X3 can't meet your requirement about the Tags / music format, there probably not any DAPs can do that. We have purchased all the DAP for audiophiles . but I can say this is the true. and we will try to become the only one who can take care everyone.

 

for example , do you need a CUE support? I think most people never heard it before, but it is very important for Chinese user, but at the other hand, almost 99% Chinese people download MP3 or other music from internet or just copy from the seller. and manage

 

their music by folder, they never try to manage the music by Tags. and that is why we display the files name but not Tags because it will display nothing if we do that.

post #3587 of 17125
Quote:
Originally Posted by dimmockg View Post

 

how about compared to a rockboxed ipod video 80gb??

 

For me, the iPod video I have (Rockboxed, 60Gb 5th Gen) is the least competent of my DAP's in terms of sound quality. YMMV though, as some people prefer the warmer sound from the Wolfson DAC in the iPod video to the somewhat more neutral sounding (comparatively speaking) Clip Zip.

 

If you are a fan of the Wolfson DAC sound from the iPod video, the X3 is a bit warmer again imo, and in terms of sound quality, a good bit better than the iPod.

post #3588 of 17125
Quote:
Originally Posted by phlashbios View Post

 

I have 53.5Gb in a mixture of MP3's and FLAC. MP3's are all 256k or 320k. There are approx 7000 tracks in 400 folders. It indexes all artists from A-R, but does not index any artists from S-Z.

The indexing completes in 5-10 seconds and says "MediaLib Updated", but it is still the same, with half my music library missing. All tracks, both MP3 and FLAC are fully tagged, and my 3 other DAP's (Cowon C2, Clip Zip (Rockboxed) and Colorfly C3) can all index the card just fine.

 

lol, you are the first user who storage so many music , anyway, need to confirm it with our engineer but I believe it is a bugs so we will find out the reason and fix it in the future.

post #3589 of 17125
Quote:
Originally Posted by JamesFiiO View Post

about the TAGs support in X3, we sitll need more time to fix it . in China, X3 launched marekt in 3 months ago, but most user in China tend to use the folder to play music, but it is different in Western regions,

 

just like Android VS IOS, it make us a little difficult to support both very good at the same time, but all should be fixed in the new firmware.

 

Anyway, if X3 can't meet your requirement about the Tags / music format, there probably not any DAPs can do that. We have purchased all the DAP for audiophiles . but I can say this is the true. and we will try to become the only one who can take care everyone.

 

for example , do you need a CUE support? I think most people never heard it before, but it is very important for Chinese user, but at the other hand, almost 99% Chinese people download MP3 or other music from internet or just copy from the seller. and manage

 

their music by folder, they never try to manage the music by Tags. and that is why we display the files name but not Tags because it will display nothing if we do that.

 

I can't browse half my music archive is the problem. I can only browse by folder the artists A-R. Artists S-Z just don't appear at all to be browsed by folder. I'm not trying to manage the music by tags, I am trying to browse by folder and half of my music archive is missing. I can see all the folders when I am browsing by folder on my other DAP's.

post #3590 of 17125
Quote:
Originally Posted by phlashbios View Post

 

For me, the iPod video I have (Rockboxed, 60Gb 5th Gen) is the least competent of my DAP's in terms of sound quality. YMMV though, as some people prefer the warmer sound from the Wolfson DAC in the iPod video to the somewhat more neutral sounding (comparatively speaking) Clip Zip.

 

If you are a fan of the Wolfson DAC sound from the iPod video, the X3 is a bit warmer again imo, and in terms of sound quality, a good bit better than the iPod.

 

the warm sound 80% comes from the amp section ( AD8397) , and you can get a more clear sound from E12 if you connect E12 to the line out of X3. lots of people in China bough E12 to pair with X3, and the price is still

 

very good for the value if you compare with other DAPs.

post #3591 of 17125
Quote:
Originally Posted by JamesFiiO View Post

 

lol, you are the first user who storage so many music , anyway, need to confirm it with our engineer but I believe it is a bugs so we will find out the reason and fix it in the future.

 

Thank you for your response, I appreciate it. I suspect you are going to come across this again with other users who have large music archives and are using 64Gb cards biggrin.gif

Hopefully it will not be a difficult fix for your engineer cool.gif

post #3592 of 17125
Quote:
Originally Posted by JamesFiiO View Post

 

the warm sound 80% comes from the amp section ( AD8397) , and you can get a more clear sound from E12 if you connect E12 to the line out of X3. lots of people in China bough E12 to pair with X3, and the price is still

 

very good for the value if you compare with other DAPs.

 

I agree. It is excellent. You've produced a really good quality product for the money.

post #3593 of 17125
Quote:
Originally Posted by phlashbios View Post

 

I can't browse half my music archive is the problem. I can only browse by folder the artists A-R. Artists S-Z just don't appear at all to be browsed by folder. I'm not trying to manage the music by tags, I am trying to browse by folder and half of my music archive is missing. I can see all the folders when I am browsing by folder on my other DAP's.

 

Try to reset by press the play key more than 12 seconds to see if the reset can fix the bugs first, otherwise we will see if we can check out what happen and fix it in the new firmware.

post #3594 of 17125
Quote:
Originally Posted by JamesFiiO View Post

 

Try to reset by press the play key more than 12 seconds to see if the reset can fix the bugs first, otherwise we will see if we can check out what happen and fix it in the new firmware.

 

At the moment I have reformatted the card again, removed all the artists from the parent 'Music' folder and am transferring the artists folders back to the root of the sd-card on the X3 using the USB cable you supplied. This will mean they will be on the sd-card in folders by artist/album/tracks

 

I will try indexing the library again when I have done that, and see what happens, and then I will try your reset using the play key.

 

I will report the results back to this thread.

post #3595 of 17125
Quote:
Originally Posted by phlashbios View Post

 

I have 53.5Gb in a mixture of MP3's and FLAC. MP3's are all 256k or 320k. There are approx 7000 tracks in 400 folders. It indexes all artists from A-R, but does not index any artists from S-Z.

The indexing completes in 5-10 seconds and says "MediaLib Updated", but it is still the same, with half my music library missing. All tracks, both MP3 and FLAC are fully tagged, and my 3 other DAP's (Cowon C2, Clip Zip (Rockboxed) and Colorfly C3) can all index the card just fine.

 

OK. I just did an experiment.

 

I made one single folder in my 64GB MicroSD (Sandisk Ultra) and put in 60GB worth of music (around 1200 songs in FLAC, mix of 44.1 to 192K).

It took about 2 minutes to do "Update Lib", but it eventually completed (with a finished message), and now all the songs seem to be properly indexed.

Albums and Artists are all complete A-Z.

 

I had the "Update Lib" hanging and freezing when I had my songs in many separate album folders, but now it is OK under one single folder, so it must depend on how the songs are stored on the MicroSD.

 

Also, while "Update Lib" is going on, sometimes the screen goes black due to the power saving mode, and if I press some random buttons to wake it up (to see the progress) then it often aborted the "Update Lib" half way, causing it to lock up. I used the Hold switch to wake it up, because this didn't seem to freeze the "Update Lib" (The progress bar is still spinning and eventually completed).

 

Hope it helps

post #3596 of 17125
Quote:
Originally Posted by JamesFiiO View Post

about the TAGs support in X3, we sitll need more time to fix it . in China, X3 launched marekt in 3 months ago, but most user in China tend to use the folder to play music, but it is different in Western regions,

 

just like Android VS IOS, it make us a little difficult to support both very good at the same time, but all should be fixed in the new firmware.

 

Anyway, if X3 can't meet your requirement about the Tags / music format, there probably not any DAPs can do that. We have purchased all the DAP for audiophiles . but I can say this is the true. and we will try to become the only one who can take care everyone.

 

for example , do you need a CUE support? I think most people never heard it before, but it is very important for Chinese user, but at the other hand, almost 99% Chinese people download MP3 or other music from internet or just copy from the seller. and manage

 

their music by folder, they never try to manage the music by Tags. and that is why we display the files name but not Tags because it will display nothing if we do that.

 

I can confirm this is true of most Chinese.

Quote:
Originally Posted by sandalaudio View Post

 

 

Also, while "Update Lib" is going on, sometimes the screen goes black due to the power saving mode, and if I press some random buttons to wake it up (to see the progress) then it often aborted the "Update Lib" half way, causing it to lock up. I used the Hold switch to wake it up, because this didn't seem to freeze the "Update Lib" (The progress bar is still spinning and eventually completed).

 

Hope it helps

Yeah , it may be good to have the user above set the X3 to not turn off after inactivity when doing media update after his new refresh

post #3597 of 17125
James,

Will be the new firmware allow us to create playlist in the favourite section for example work out folder or fav rock folder ...at the moment if added to favourite ..it is just a long list of songs ?

Well ...just wanna say to Fiio ...well done ...love how the X3 turns out ...excellent product

Also special mention to Panda for all the insightful and help ...many a times wanted to ask questions but most of the time ...other headfier came ahead and he has been there all the way.

Kudos again to Fiio .
Edited by Wokei - 8/7/13 at 9:45am
post #3598 of 17125
Quote:
Originally Posted by sandalaudio View Post

 

OK. I just did an experiment.

 

I made one single folder in my 64GB MicroSD (Sandisk Ultra) and put in 60GB worth of music (around 1200 songs in FLAC, mix of 44.1 to 192K).

It took about 2 minutes to do "Update Lib", but it eventually completed (with a finished message), and now all the songs seem to be properly indexed.

Albums and Artists are all complete A-Z.

 

I had the "Update Lib" hanging and freezing when I had my songs in many separate album folders, but now it is OK under one single folder, so it must depend on how the songs are stored on the MicroSD.

 

Also, while "Update Lib" is going on, sometimes the screen goes black due to the power saving mode, and if I press some random buttons to wake it up (to see the progress) then it often aborted the "Update Lib" half way, causing it to lock up. I used the Hold switch to wake it up, because this didn't seem to freeze the "Update Lib" (The progress bar is still spinning and eventually completed).

 

Hope it helps

 

Still no luck. I have tried it as Music/Artist/Album/Tracks and now just as Artist/Album/Tracks and it makes no difference. I do however have substantially more files than you, even if it is in a smaller archive:

 

400 Artist folders

1047 Album folders

7904 tracks in total

 

As I say, the same card works in my other DAP's and indexes fine. Reformatting the card and trying the reset function has made no difference, also tried holding the Play button as suggested by James from Fiio and that has made no difference, and neither has manual or auto re-indexing. I really do not want to have to store all my tracks by all artists in one big folder, just to get them to index properly. I don't have to do that with any other DAP I have, and indeed even the X3 is fine with Music/Artist/Album/Tracks or Artist/Album/Tracks as long as I only want to browse the folders of artists A-R, and not any artists S-Z  blink.gif

 

Not sure whether to return the X3 for a refund or wait for a firmware fix at this point.

post #3599 of 17125
Quote:
Originally Posted by JamesFiiO View Post

Anyway, if X3 can't meet your requirement about the Tags / music format, there probably not any DAPs can do that. We have purchased all the DAP for audiophiles . but I can say this is the true. and we will try to become the only one who can take care everyone.

 

I think the X3 is already very good sound wise, and the GUI is much better than most other audiophile DAPs I tried. Some of them are totally horrible to use.

 

Most audiophile DAPs nowadays sound as good as any high-end Hi-Fi gear, but they are still in the domain of fiddly toy for young computer geeks, rather than something that can be advertised to mature (rich) audiophiles who read Gramophone, Downbeat, etc. If the X3's GUI is perfected and ironed out then I think Fiio would be one step ahead of the competitors. Also the know-how gained on GUI development can carry over to the future models too.

 

Personally I am 99% happy with the X3. Only minor things like the support for ALAC tag/cover art and the lack of multi-level tag search (e.g. choose artist, then choose album by that artist) annoys me at the moment. I and a few other Western audiophiles still buy and rip CDs into iTunes etc, rather than share and acquire MP3 from the web, so in this case tags are very handy. I remember in the old days ID3 tags used to get corrupted easily for Asian fonts, so it never became popular over there.

post #3600 of 17125
Quote:
Originally Posted by phlashbios View Post

 

Still no luck. I have tried it as Music/Artist/Album/Tracks and now just as Artist/Album/Tracks and it makes no difference. I do however have substantially more files than you, even if it is in a smaller archive:

 

400 Artist folders

1047 Album folders

7904 tracks in total

 

As I say, the same card works in my other DAP's and indexes fine. Reformatting the card and trying the reset function has made no difference, also tried holding the Play button as suggested by James from Fiio and that has made no difference, and neither has manual or auto re-indexing. I really do not want to have to store all my tracks by all artists in one big folder, just to get them to index properly. I don't have to do that with any other DAP I have, and indeed even the X3 is fine with Music/Artist/Album/Tracks or Artist/Album/Tracks as long as I only want to browse the folders of artists A-R, and not any artists S-Z  blink.gif

 

Not sure whether to return the X3 for a refund or wait for a firmware fix at this point.

 

Yes, I only have around 1000 or so songs in 60GB (because many are 192kHz FLAC), and that indexed fine, so it almost seems like the X3 simply can't index all 7904 tracks and store the info, so it gives up? Then again, that doesn't explain why mine couldn't index 1000 songs when they were put into separate folders before. It only worked for me once I moved every single song into one single folder. Very strange.

 

It's a pain to diagnose the problem because microSD are so slow to work on (you might want to get a fast USB card reader).

 

If you get rid of all the files for artists A-G or something, then would that allow the X3 to index all the way up to Z? (It doesn't fix the problem but it might tell you something).

 

X3 is a good sounding player so I hope the problem gets fixed and you don't have to return it.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.