Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 887

post #13291 of 13302
Quote:
Originally Posted by Nec3 View Post
 


Welp... seems like the firmware doesn't work for Windows 8.1.
Worked well when I had Windows 7 though.

Error "C:\Users\User\Appdata\Local\Temp\nsi88A2.tmp\nss8932.tmp" cnep
"'C:\Program Files\FiiO X3 Driver\TUSBAudioCpl.exe' -hide" did not return within 30000ms.

Looks like I'll have to send in this error to FiiO >.>


I can confirm that it does work with Windows 8.1 64-bit. You have do boot with 'PC Settings, Update & Recovery, Advanced Setup, Restart Now' and disable driver signature check or something like that while booting to install the driver.

post #13292 of 13302
Quote:
Originally Posted by maeschba View Post
 


I can confirm that it does work with Windows 8.1 64-bit. You have do boot with 'PC Settings, Update & Recovery, Advanced Setup, Restart Now' and disable driver signature check or something like that while booting to install the driver.



Editted my post in regards to the troubleshoot, but in a nutshell my DAC's are picky with their ports.
i.e. one dac likes a certain usb 3.0 port, odac prefers the back of my pc, e07k likes a certain 2.0 port... yeah. Windows 8.1 is so great.

post #13293 of 13302

quick question guys i have not been on this thread for a while ....i had the x3 about 6 months ago is sold it because of the bugs then...have the bugs totally disappeared now?

post #13294 of 13302

Yes it still has some bugs, according to this thread.

Anyway I'm using it with fw 3.2 beta and zero complains,  I do not use any additional  feature or stuble setting, just a very basic functionality, I'm using it for playing FLAC files (as stand alone player and as a DAC with Mac), and it does very well, flawless, and rock solid, according to my use.


Edited by Pituky - Today at 12:12 pm
post #13295 of 13302
Quote:
Originally Posted by Pituky View Post
 

Yes it still has some bugs, according to this thread.

Anyway I'm using it with fw 3.2 beta and zero complains,  I do not use any additional  feature or stuble setting, just a very basic functionality, I'm using it for playing FLAC files (as stand alone player and as a DAC with Mac), and it does very well, flawless, and rock solid, according to my use.

Same.  I haven't run into any issues with fw 3.2 beta.  I'm still waiting for the album art un-cropping fix and playlist support, though.  And replaygain would be nice.

post #13296 of 13302

well i will have to wait till the bugs are completely gone...it just did my head in with the constant crashes and bugs 

post #13297 of 13302

I just purchased the X3 and love the sound quality but can't seem to figure out a few things, despite reading here and other posts I've found online.

 

Gapless Playback

Even with gapless on I still have gaps. Trying to play 16bit FLAC files, which are live concerts. I seelect the folder/file and play and the gaps pop up between tracks.  It sounds exactly the same when gapless is off, or on.

 

Album view

All of the FLAC files I'm trying to play are tagged with song/album info.  The song/album info appears on the screen when playing, but none of the shows are listed in the Albums section.  Only in the folder view. Why?

 

It looks like my X3 came with firmware version 3.02 according to the info within Settings.

 

Any help would be appreciated, thanks.

post #13298 of 13302
Quote:
Originally Posted by rockymtnryan View Post

I just purchased the X3 and love the sound quality but can't seem to figure out a few things, despite reading here and other posts I've found online.

Gapless Playback
Even with gapless on I still have gaps. Trying to play 16bit FLAC files, which are live concerts. I seelect the folder/file and play and the gaps pop up between tracks.  It sounds exactly the same when gapless is off, or on.

Album view
All of the FLAC files I'm trying to play are tagged with song/album info.  The song/album info appears on the screen when playing, but none of the shows are listed in the Albums section.  Only in the folder view. Why?

It looks like my X3 came with firmware version 3.02 according to the info within Settings.

Any help would be appreciated, thanks.

Perhaps you can update the library to see the album category view. This may also fix the gapless issue.
post #13299 of 13302

What bugs are still there?

post #13300 of 13302
Quote:
Originally Posted by h1f1add1cted View Post

Try to install USB Audio Player Pro trial on Android phone to use the X3 as a USB DAC. Maybe it works, this app can handle a ton of USB DACs on Android phones.

Not all album arts showing properly and gapeless still having a small gap on flac files as mentioned above are the only ones I can think of.

The album art issue is most certainly due to them having to big size but I'm to lazy to do anything about it wink.gif
post #13301 of 13302
Quote:
Originally Posted by x RELIC x View Post


Perhaps you can update the library to see the album category view. This may also fix the gapless issue.

 

How would I update the library? Once I select gapless to "On" do I have to apply that setting to the library somehow?  Again, I'm very new to this device, just feeling frustrated that I can't figure this out quicker.

post #13302 of 13302

Think I got it, thanks!  Didn't realize I had to update the library after making the change to gapless and it seems to work now.  Songs transition as they should.

 

The only flaw I see is track names not being displayed in Album view.

 

Example:

I can go onto Artist view

Select "Greensky Bluegrass" and see the 3 albums (concerts) under that Artist

The one I'm looking at displays the proper tag "2014-09-26 Orange Peel, Asheville, NC  ak40"

When I select that Album it still shows me the actual file names (ex greenskybluegrass2014.09.26.s01.t01.flac") instead of track name "Just To Lie"

When I select that track to play the player screen does show

 

Just To Lie

Greesnky Bluegrass

FLAC 44.1KHz/16Bits

 

Why can't it just show the track titles, instead of file name, especially in Album view.  I would expect file names when in Folder/File view.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.