Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 825

post #12361 of 12912
@dcfac73   firmware V3.2???? when it was released, i've checked fiio page and only see the current 3.0
 
post #12362 of 12912

 

 

 

post #12363 of 12912
Quote:
Originally Posted by gerelmx1986 View Post
"firmware V3.2???? when it was released, i've checked fiio page and only see the current 3.0"


Well, I got this no. from the About X3 Menu in the System Settings. "Firmware Version: FW 3.2". Tell me if I'm mistaken :o 


Edited by dcfac73 - 8/27/14 at 5:50pm
post #12364 of 12912
Quote:
Originally Posted by TrollDragon View Post
 

I sent a pair of AD8620's to a Head-Fi'er in the Philippines for his X3 and he seems to like the sound, I find the AD8620 a little too bright sounding. 

and i recommend too AD8066 .... it is bright sounding indeed .... but with REALLY nice bass better than the stock one  ... not thin sounding at all ..... and more powerful than AD8620 ( i am not sure ) but it is rail to rail while AD8620 is not.

   modding specially opening and assembling the case again is hard and tricky thing because of the hold switch and reset button

for me it was very dangerous move and enjoyable at the same time  and i am thinking know to push it further :veryevil: :veryevil:

Burson audio SS opamp 

post #12365 of 12912
Quote:
Originally Posted by nmatheis View Post


I *think* they bypass the amp circuitry so you just get a permanent line out from the headphone jack. Cleans up the internal audio chain. Not something I have the skill to do. If I did, I'd much rather try swapping opamps in my X3 like ClieOS did.

Hey, maybe someone would like to mod my X3 for me. Any takers?

 

I know someone who does that, let's hope he is still ok with that ;)

post #12366 of 12912

Does the new firmware support gapless playback?

 

And what are the improvements that the new firmware has over the previous one?

post #12367 of 12912

hi guys,

 

just got my shure 425 with fiio x3. theres a post in this thread stating fiio e11 kilimanjaro is pretty redundant to use as the built in bass booster is sufficient to boost bass in any bass as the built in x3 is better than e11. but fiio jus release new fiio e11k 2. will there be any difference ?

 

@sewoo55 yerp it support gapless playback. UI pretty much changes. read up here  http://www.fiio.net/news/index.aspx?ID=100000163834271

post #12368 of 12912
Quote:
Originally Posted by romanov89 View Post
 

hi guys,

 

just got my shure 425 with fiio x3. theres a post in this thread stating fiio e11 kilimanjaro is pretty redundant to use as the built in bass booster is sufficient to boost bass in any bass as the built in x3 is better than e11. but fiio jus release new fiio e11k 2. will there be any difference ?

 

@sewoo55 yerp it support gapless playback. UI pretty much changes. read up here  http://www.fiio.net/news/index.aspx?ID=100000163834271

I don't believe that there will be much difference between E11 and E11k , if you want an amp with x3 & shure 425 i think the JDS labs C5 is the first amp you can get 

post #12369 of 12912
Quote:
Originally Posted by dcfac73 View Post
 


Well, I got this no. from the About X3 Menu in the System Settings. "Firmware Version: FW 3.2". Tell me if I'm mistaken :o 


Mine says Firmware Versión: FW 3.0

post #12370 of 12912
Quote:
Originally Posted by dcfac73 View Post


Well, I got this no. from the About X3 Menu in the System Settings. "Firmware Version: FW 3.2". Tell me if I'm mistaken  

 

Well, I would say that you are since 3.2 hasn't been released yet.
Edited by skalkman - 8/28/14 at 12:01pm
post #12371 of 12912
Quote:
Originally Posted by skalkman View Post
 
Quote:
Originally Posted by dcfac73 View Post
 


Well, I got this no. from the About X3 Menu in the System Settings. "Firmware Version: FW 3.2". Tell me if I'm mistaken  

 

Well, I would say that you are since 3.2 hasn't been released yet.


Yep, mine says 3.2. Don't know why that would be.

post #12372 of 12912
Quote:
Originally Posted by skalkman View Post
 
Quote:
Originally Posted by dcfac73 View Post
 


Well, I got this no. from the About X3 Menu in the System Settings. "Firmware Version: FW 3.2". Tell me if I'm mistaken  

 

Well, I would say that you are since 3.2 hasn't been released yet.


edit

post #12373 of 12912

There is one other option.  You didn't notice firmware 2.2 was for the X5, not the X3.

post #12374 of 12912

Had a weird/bad glitch today. Was listening to some music, all was fine. All of a sudden heard a burst of staticy noise (the sort of thing you hear if a file is corrupted), and my x3 lost access to all the music on my sd card. Library only showed the files on the internal memory, update didn't help. Even the browser wouldn't show any files on the sd card. Thought maybe my card died, but that seemed to check out ok in windows. I'm hoping that rolling back to 3.0 will be the only fix needed (was using 3.0ex and so far it's reading the sd card properly again - fat32 btw, always has been).

 

re: previous posts....are you using modded fw? As far as I know 3.0ex is the most recent version released.

post #12375 of 12912
Quote:
Originally Posted by Mr Trev View Post

 

re: previous posts....are you using modded fw? As far as I know 3.0ex is the most recent version released.

No. I'm using the X3 straight out of the box. I shot them an email.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.