Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 811

post #12151 of 12912
Quote:
Originally Posted by akbar625416 View Post

sorry for posting as a reply. i am new to headfi.
hi friendzz,
I was lookin forward to buy the fiio x3 player and audio Technica athm50 headphones. i dont have a very big budget and i am not an audiophile . But i loved to hear the best music in its best quality. I am from india so its hard for me to purchase both things from here. But luckly one of ma friend is coming from USA. It would be great if you people suggest me anything to get the best music quality but with a limited budget. say 350$ for both the headphones and player.

Also please reply on my preferred combo like the ATH M50 and Fiio x3. will they satisfy my needs . i am not a bass lover. am more into acoustics and soft rock songs.

kindly reply me.

I have the shure srh 840 I was thinking initially on the m50 or the shure similar performance and price.
It sounds really great, details coming from x3 are a pleasure.
I've used some tracks from bandcamp recommended by h20fidelity (havi b3 thread) to compare the shure against the superluxhd 668b, oohhh man that very big sq diferences are evident with a good track on the x3.
Sure you are going to enjoy the m50 on the x3
Edited by Pituky - 8/13/14 at 1:17pm
post #12152 of 12912

I've had the X3 since Christmas 2013. I have enthused and put up with the eccentric operating system on the basis that the sound quality was great and I could play whatever hi def files I had. I can stick it through my HiFi system comprising VTL tubes and KEF Reference Speakers and it can sound spectacular with the right material. It can do Hi End.

 

HOWEVER IT IS A DAP PLAYER AND WHEN THE F@@KING THING CUTS OUT ALL THE TIME IT FAILS TO MEET IT'S PURPOSE.It has died mid song twice today and has been mardy for a while.

 

 I can buy an ipod or anything else and it works. The X3 doesn't. I don't want to tweak I want it to WORK. THe PRS guy was right this is not acceptable and Trolldragon YOU ARE SO WRONG.

 

The software is still not up to speed and it pains me to say if you are a Newbie reading this thread buy something else unless you are a computer programmer or Bill Gates.

 

Sorry to upset the Love In but this is akin to a Morris Marina. Fix it and I will retract.

 

Steve

post #12153 of 12912

Wrong.... moi???

Please do tell, I have NOT had my X3 cut out or pause on any song since FW 3.0, so let me know where I have failed.

 

Had to look up the Morris...

I kind of relate it to a Yugo with a Naim sound system...


Edited by TrollDragon - 8/13/14 at 1:41pm
post #12154 of 12912
Hi Steve,
Are you on fw 3.0? If so it's highly likely that you have a faulty unit since I can't even remember one comment from people having repeatedly freezes on that fw.

Pleas correct my if I remember wrong.
post #12155 of 12912
Quote:
Originally Posted by slawts View Post

 

HOWEVER IT IS A DAP PLAYER AND WHEN THE F@@KING THING CUTS OUT ALL THE TIME IT FAILS TO MEET IT'S PURPOSE.It has died mid song twice today and has been mardy for a while.

 

 I can buy an ipod or anything else and it works. The X3 doesn't. I don't want to tweak I want it to WORK. THe PRS guy was right this is not acceptable and Trolldragon YOU ARE SO WRONG.

 

The software is still not up to speed and it pains me to say if you are a Newbie reading this thread buy something else unless you are a computer programmer or Bill Gates.

 

Sorry to upset the Love In but this is akin to a Morris Marina. Fix it and I will retract.

 

Steve

 

 

Sorry you're troubled....valium works at the right dosage.

 

I DON'T think Bill Gates would buy an X3 even if it worked....

 

 

Keep chilled.

post #12156 of 12912
Mine works like a dream. I'll admit the button layout is convoluted, but it's certainly no deal breaker. Also, please don't call people out like that.
post #12157 of 12912

Mine has stopped mid song twice today. Yesterday it stopped as well. I went in to my SD card and tried to mend bits two days ago but at the end of the day why isn't it possible to download and play like everything else.

 

My wife has an iphone, my daughters have iphone and you download and they play. My Fiio sometimes plays and sometimes doesn't.

 

All the music plays happily on the PC but has **** fits on the X3. PRS was complaining and you were dismissive but if the thing worked NOBODY would complain. I'm on FW 3.0 as well. I don't know if you have heard of British Leyland but they made cars in the 1970's that broke down all the time and they went bust.

 

Cheers

post #12158 of 12912
Quote:
Originally Posted by slawts View Post
 

I've had the X3 since Christmas 2013. I have enthused and put up with the eccentric operating system on the basis that the sound quality was great and I could play whatever hi def files I had. I can stick it through my HiFi system comprising VTL tubes and KEF Reference Speakers and it can sound spectacular with the right material. It can do Hi End.

 

HOWEVER IT IS A DAP PLAYER AND WHEN THE F@@KING THING CUTS OUT ALL THE TIME IT FAILS TO MEET IT'S PURPOSE.It has died mid song twice today and has been mardy for a while.

 

 I can buy an ipod or anything else and it works. The X3 doesn't. I don't want to tweak I want it to WORK. THe PRS guy was right this is not acceptable and Trolldragon YOU ARE SO WRONG.

 

The software is still not up to speed and it pains me to say if you are a Newbie reading this thread buy something else unless you are a computer programmer or Bill Gates.

 

Sorry to upset the Love In but this is akin to a Morris Marina. Fix it and I will retract.

 

Steve

Calm down there tiger. 

 

Now, from being an administrator for the X3 beta project I can tell you that the X3 has been stable since 2.19Beta. I have not had v3.0 cut out on me with a unmodified firmware. If you are having issues with the firmware after version 3.0, it's your fault.

 

And calling out people like that is really not going to help you here.


Edited by skalkman - 8/13/14 at 2:03pm
post #12159 of 12912
Quote:
Originally Posted by slawts View Post

 

My wife has an iphone, my daughters have iphone and you download and they play. My Fiio sometimes plays and sometimes doesn't.

 

 

+1 +1

 

It's wise to follow the example set by family members....a happy troupe is one that bands together.

 

post #12160 of 12912
Quote:
Originally Posted by Saoshyant View Post

Mine works like a dream. I'll admit the button layout is convoluted, but it's certainly no deal breaker. Also, please don't call people out like that.


I'm not trying to call anyone out and I apologise to Trolldragon if it was too aggressive. I am not keen on slagging off the X3 but every time I think it is working perfectly it craps out. This is a Forum. The X3 should work on a basic level of switching on and playing not switching off mid way through a song.

 

I know you all love the Fiio but I want something reliable and this ain't! Before you accuse me I have played, downloaded, deleted and amended for 9 months. I've enjoyed/not enjoyed 2.05, 2.1, 2.14Beta and 3.0. I download stuff and it all works and then suddenly it doesn't. It's a bit like having the perfect girlfriend and you wake up and she has an axe and she's going to use it on you.

 

Cheers,

Steve

post #12161 of 12912
@slawts-Its an electronic device... things happen. If you have the correct firmware and it is not working properly, it must be a defective unit. Things happen unfortunately. Just get a new one. I have no doubts you are being honest, but most of us are as well. I have no stake in Fiio, nothing to gain if you or anyone else buys any of their products. I can only tell you the X3 for me, has worked as promised and sounds quite good. I also own a Sony ZX1, which costs over 3 times the price. I prefer the sound of the X3. I also have an Ipod, my girl has a new itouch and an iPad. Throw in my Note 3...thats a number of devices... I prefer to listen to X3. It's a great little device when given the chance.
post #12162 of 12912

I am beginning to think that there IS some kind of compromised situation with the uSD cards.

Take for instance this odd phenomenon of having the file play fine on the PC, and not on X3. How can this be?

Well, let's take a look at how that SD card operates. For one thing it reads 'nibbles', that is 4 bits at a time. Which is one uncommon thing. And of course inside each little SD card is a little controller chip that handles data transfer and storage. Then consider that in flac files the data is arranged in blocks that contain important information for decoding and error checking.

So let's say the file is fragmented in a way in which the controller has to boogey around to get all that critical data and try to transfer it all so that it hangs together. Consider that the file structure inside the SD card has no relationship at all to the flac block size, and the file structure in which the file may have become fragmented is not the same as that inside the card.

If X3 does not have a sufficiently large area in memory to buffer say several blocks of flac code there could well be moments of extreme anguish, and outright breakdown in the flow of samples to the DAC.

No wav file has ever even burped on X3. But, as I noted in an earlier post I have had my first flac freak-out.

Not being a highly volatile sort, this doesn't trouble me much. But some may loose patience.

And maybe these chemical solutions aren't such a good idea. After all, it could be chemical dependency that is making some folks more volatile than they should be.

Hmmmm?

Be kind to your phrends..

post #12163 of 12912
Quote:
Originally Posted by slawts View Post
 


 I am not keen on slagging off the X3 but every time I think it is working perfectly it craps out. This is a Forum. The X3 should work on a basic level of switching on and playing not switching off mid way through a song.

 

Just to say, I have now got 5 devices from FiiO now and they are all reliable and still working as they were intended too. I have had the X3 and it doesn't have any technical issues at all. If it has this cutting out or turning off problem they I think it will just be that it is a faulty one. FiiO's customer service is very good from what I have experienced. Try contacting them and describe your issue to them.

post #12164 of 12912
Quote:
Originally Posted by TheGiantHogweed View Post

Just to say, I have now got 5 devices from FiiO now and they are all reliable and still working as they were intended too. I have had the X3 and it doesn't have any technical issues at all. If it has this cutting out or turning off problem they I think it will just be that it is a faulty one. FiiO's customer service is very good from what I have experienced. Try contacting them and describe your issue to them.
+1.
I've had my X3 since the release and it froze only 1 time, it has worked flawlessly this whole time. I as well have many FiiO products and work really well all the time. I will be buying the X5 tomorrow as I sold my I basso DX50, if you want to talk about buggy than get a DX50!
post #12165 of 12912
All is cool...

I'd still like to know what I did, you can PM if you want to, I am one of the first to declare "My Bad" when it is.

I had a serious hate on for the X3 after that first firmware update, music locking up, that foolish spin wheel interface and the sound change. So I switched over to Mr. Trev's list theme which got rid of the Metro Style boxes. Still had the music lockups and they were so bad that I was either going to bift it at the wall or sell it. Well they were selling for $150 in the FS forum with free shipping so instead of taking a severe beating on it, I just threw it in the drawer and went back to my C3.

Firmware 3.0 was released so I installed that with Mr. Trev's theme again and no lockups... The X3 played without issue, the sound was better, UI is still the Schiit's but you can't expect much from a device that doesn't have enough buttons. Compared to a Sansa Clip+ with the Rockbox Interface, the proper amount of buttons and stuff just works as it should.

The SQ on the X3 is excellent, so back out it came and has been my primary player ever since.

You mentioned PRS getting dismissed, his main problem was the sound from the X3 and no equalizer. Well many tried to assist him with the sound issue to no avail, he claims the X3 just sounds bad to him. I was probably a bit curt with my suggestion of possibly the A&K to go with his $1K+ customs, but that was met with a, not paying that kind of money and it probably doesn't sound any better. Someone else suggested that he ask in the Miracles thread for player recommendations and he did.

The first reply, the very first reply was the AK240... So he just doesn't like the sound of the X3 and has possibly moved onto a DX90.

I know the angst you feel for a player that just doesn't work like it should, basic functions do not work like they should... Unfortunately it is a proprietary firmware as Rockbox in my opinion would fix this player. I can see once the X7 gets released and the X1 sales start to take off, the X3 will take a back seat to any fixes or improvements, possibly even abandoned... Back in the day I had my share of ATI video cards and Soundblaster card drivers getting abandoned... Hopefully not but I feel the X3 is FiiO's red headed step child.

So like it was mentioned earlier I see an iDevice in your future, or get a hold of FiiO and have them fix it, tracked shipping back to China would possibly not be feasible and a nice 160GB Classic might just be the better choice.

This was cranked out on my phone so ignore and formatting errors etc... smily_headphones1.gif
beerchug.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.