Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 761

post #11401 of 12952
Quote:
Originally Posted by tjw321 View Post
 

You shouldn't ever get an error message. The only time I ever got an error message was when the cable fell out during a file transfer and I ending up having to reformat the card *and* the X3 to get rid of the resulting problems. What error do you get?

 

When you say that you can't see the files on the X3, do you mean that you can't see them in categories, or that you can't see them using the file browser, or both?

 

If you can't see them in categories, have you tagged them? 

Yes, I'm pretty obsessive about my music library - ID tags, album cover art, etc.  The error message I'm getting is that when eject the SD card and then the X3 (or vice versa), it reads "the device has not been ejected properly" or something to that effect, when in all actuality, it has been.  Still, that shouldn't affect the ability for the card to be read by the x3 when I'm in the artist or album category.  But it's happening nonetheless.

 

I placed an email to Fiio tech and awaiting their response.  In the meantime, Agent XXl was also kind enough to post something regarding formatting which I'll take a look at. Thanks, all.  I'll keep you posted...

post #11402 of 12952
Quote:
Originally Posted by MicroEuphoneum View Post
 

Very strange! Of course most of it IS nonsense. Hopefully readers realize I'm just NUTS!. But, X3 would not even read the 64G microSDHC card I got, pre-formatted. I mean not even recognize it. So I just did a search for posts regarding this and found that formatting NTFS was the magic key. Well, now, some posters say format the card in the X3, but with the X3 refusing to recognize the card no such thing is possible. What do they call that, a 'catch 22' ? Chicken or the egg, whatever. No, seriously, the first thing I did was install fw3.0. Unit came with a pre-formatted 64G card and would not recognize the card. So I took the advice, did the NTFS thing and it works. Is this X3 in some kind of alternate reality? Like me. Other than the 64G card hang up (and I don't even like using it) X3 has given me absolutely no other problems. I get along with it fine and I think mostly because of what I've learned here.

AHA! There are some multiple variables here that make these ethereal events more clear. Are you, in fact, loading songs onto cards installed in the X3, via USB with a Mac computer. I've read the links provided by AgentXXL and think that if I was having problems of that nature I would probably take a sledge hammer to the Mac AND the X3. MAYBE the trick is to load the files onto the microSD card directly on the computer. But what if you don't have a card slot on your computer? I suppose one might try the USB / X3 / microSD detour. Don't even go there.

Soniccircle; do you not have a SD card slot? Most of the micro's come with an adapter because the PC's usually have the regular SD slot. This detour approach must be where the hang up lies. But why my unit with fw3.0, and some other unit with the same fw would react differently to card formatted the same way is still a head banger. WTF????

I don't have a dedicated SD card slot on my computer but I'll try both reformatting one card onboard the x3 and the other via my computer in NTFS as you suggested and see what happens.  The saga continues...

post #11403 of 12952
Quote:
Originally Posted by soniccircle View Post

Yes, I'm pretty obsessive about my music library - ID tags, album cover art, etc.  The error message I'm getting is that when eject the SD card and then the X3 (or vice versa), it reads "the device has not been ejected properly" or something to that effect, when in all actuality, it has been.  Still, that shouldn't affect the ability for the card to be read by the x3 when I'm in the artist or album category.  But it's happening nonetheless.

I placed an email to Fiio tech and awaiting their response.  In the meantime, Agent XXl was also kind enough to post something regarding formatting which I'll take a look at. Thanks, all.  I'll keep you posted...

Unfortunately, if you see that message, it hasn't been ejected properly. It can take a fair while for all the buffers to flush to the SD card after you select eject, and every time you see that message it's more likely that the file system on the card has become corrupted. Sometimes, a program has a file open on the card and you can't eject it at all until you close the prrogram. When this happened to me, I tried fixing it by scanning the card on my Mac but it was too far gone. I had to totally reformat the card, in the end.
post #11404 of 12952
Quote:
Originally Posted by soniccircle View Post
 

I don't have a dedicated SD card slot on my computer but I'll try both reformatting one card onboard the x3 and the other via my computer in NTFS as you suggested and see what happens.  The saga continues...

How do you access a micro SD card from your computer without a card slot? Is this happening still via the USB cable and the X3? Seems there could be some problem with that, such as the computer doesn't really know what the X3 is doing with the card. Too many variables IMO. Maybe a card adapter that plugs into the computer USB port could help. Hope it's OK to provide links. There's a good unit here ...http://www.amazon.com/Transcend-Information-Card-Reader-TS-RDF5K/dp/B009D79VH4/ref=sr_1_3?s=electronics&ie=UTF8&qid=1405201545&sr=1-3&keywords=usb+micro+sd+adapter

Just over $6 and would provide a simple and robust way to use the micro SD cards.

post #11405 of 12952
It will also be 10X faster moving files through a card reader than on the X3.

I picked up a 64GB that came with a little USB adapter, works like a charm.

Similar to this one here, but half the price since it was just Class 10.

http://www.lexar.com/products/lexar-high-performance-microsdhc-microsdxc-uhs-i-cards-633x
post #11406 of 12952
Quote:
Originally Posted by HeatFan12 View Post
 

Who nails the solo better, Juliette or Emily?

And I'm pretty sure you are a Rush fan..lol...Bass lines YYZ by Anna Sentina:

 

Wow HF some serious finds there!

 

Emily does the better version, but Tina S also does a version that is incredible, the girl has some amazing talent!!

Anna Sentina is seriously talented with piano, bass and guitar! YYZ is bang on and she does a great cover of The Unforgiven.

 

Now just add Meytal Cohen on drums... :D

:beerchug: \m/ A7X \m/ :beerchug:

post #11407 of 12952
So i got a reply from facebook in regards to the leather case. She's not taking orders at this time.
post #11408 of 12952
Quote:
Originally Posted by lostwind View Post

So i got a reply from facebook in regards to the leather case. She's not taking orders at this time.
That's too bad, she probably will in the future though. Ask her again in a month or so.
post #11409 of 12952
Quote:
Originally Posted by MicroEuphoneum View Post
 

How do you access a micro SD card from your computer without a card slot? Is this happening still via the USB cable and the X3? Seems there could be some problem with that, such as the computer doesn't really know what the X3 is doing with the card. Too many variables IMO. Maybe a card adapter that plugs into the computer USB port could help. Hope it's OK to provide links. There's a good unit here ...http://www.amazon.com/Transcend-Information-Card-Reader-TS-RDF5K/dp/B009D79VH4/ref=sr_1_3?s=electronics&ie=UTF8&qid=1405201545&sr=1-3&keywords=usb+micro+sd+adapter

Just over $6 and would provide a simple and robust way to use the micro SD cards.

Thanks again.  Appreciated. Just ordered one.  Yes, I was transferring files with the USB 2.0 cable directly from Mac to x3 w/card.  Slow, too.  Looking forward to a better experience with the card reader.

post #11410 of 12952

New member here and a new owner of an X3 which I picked up for $179 last week with a 64 gb sd card from the sale at Adorama.I picked up the unit and immediately updated to the 3.0 firmware. I've been reading through the forums to see if my issue is a tagging issue or a firmware issue. I was hoping someone might be able to help me out.

 

I have used the same file structure on the external sd card that I have used for years for my music: /artist/album/ track #-song name. I am using Free File Sync to move the music from my hard drive to the external SD card using the same file / folder structure.When I "browse files" on the TF card all of my music is there as expected. If I go to categories, albums or artist, a bunch of my music is missing. Any group that has a "the" in front of their name is not there (either in the artist list or their albums) except for one group from my SD card the four groups that came on the internal drive. In the about screen it does not show all of my music in the total number of songs.

 

I have tried updating my library several times using manual and auto settings with the card in. I then removed the card, updated my library, put the sd card in and updated again. I reset the unit back to factory settings then updated. Nothing seems to work.

 

I am trying to figure out if this is a firmware issue or a tagging issue. I have not yet converted my library to a lossless format yet so these are just mp3s. I've used mp3 tag and mediamonkey to try to determine if there are any anomalies in my tagging. I can't find any evidence of that. The sd card is formatted to FAT32.

 

Any advice?

 

Thanks.

post #11411 of 12952

Have you got more than 5,800 files? The current firmware can't index more than 5,800 tracks.

post #11412 of 12952
Quote:
Originally Posted by tjw321 View Post
 

Have you got more than 5,800 files? The current firmware can't index more than 5,800 tracks.


Yup that's it.  Thanks. I'm not sure how I missed that limitation.

post #11413 of 12952
Quote:
Originally Posted by lostwind View Post

So i got a reply from facebook in regards to the leather case. She's not taking orders at this time.

X3 came with this leather case...

 

Did you not get this? Or don't like? I don't want to keep X3 in this sheath because it might get too hot. I was kinda sorry I put it in there for this picture because it was real hard to get it back out.

post #11414 of 12952
Quote:
Originally Posted by tjw321 View Post
 

Have you got more than 5,800 files? The current firmware can't index more than 5,800 tracks.

soniccircle: I sure hope this is not what is causing your problem. Sure sounds similar. Otherwise, don't forget that now you have to manually update your media library when you change microSD cards. Auto-update only gets activated when you access X3 via USB. It's easy to do. 3 clicks after power up.

I was thinking also that it takes a while for the media library to get updated if you put thousands of tracks on the card. If you ejected the card before that was finished then of course all your ID3 data wouldn't be there. OMG! Premature Ejection. Sounds like some sexual dysfunction. Why eject the card? Seems like you would want the card to stay after putting your songs on. Probably you should only eject X3.

post #11415 of 12952

does anyone know how to put multiple playlists on this player as so far I have to go into each artists individual folder on the player to play the music is there anyway to have a playlists, for example I have a playlist on the pc is there anyway to copy it over without it going into individual folders. thanks for the help

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.