Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 742

post #11116 of 14237
Using mostly Shure SE 420's or Senheiser over ear Momentums. Occasionally ATH-M50.
post #11117 of 14237
Quote:
Originally Posted by x RELIC x View Post


First off what headphones are you driving?

The X3 is basically an e17 that can decode and playback music. It even has a slightly more powerful amp section than the e17 so for efficient headphones/earphones it should be more than adequate. If you prefer bass boost from a portable amp you should know that the X3 treble/bass controls are hardware based and analogue, and are very good.

 

Yep, I totally agree that this is the important question when wondering if the X3 needs additional amping.  Of the amps listed in the original question, I own the E11 & E12.  If you're using something that is easy to drive, the difference you might hear in sound quality, assuming you hear a difference at all, might not be worth the cost of an additional amp at all.  If you're using something harder to drive, I personally find that the E12 for example produces a nicer sound than the stock amp in the X3, but only on headphones that can actually take advantage of the extra power.  I'm not sure I really hear a difference for example on my Momentum On Ear, but I certainly notice an improvement on the HE-400 and HD700, especially in the quality of the bass.  Even setting aside how easy something is to drive for a moment, each headphone and IEM has varying levels of improvement from increased amping once it is being sufficiently driven.  Some still show noticable improvement far beyond what is necessary for adequate amping, I'm learning that the HE-400 seems to fall in this group, while others don't seem to show much if any improvement beyond a certain point.

post #11118 of 14237
Quote:
Originally Posted by x RELIC x View Post

First off what headphones are you driving?

The X3 is basically an e17 that can decode and playback music. It even has a slightly more powerful amp section than the e17 so for efficient headphones/earphones it should be more than adequate. If you prefer bass boost from a portable amp you should know that the X3 treble/bass controls are hardware based and analogue, and are very good.

Prior to this firmware I was using an e11 to get the line out "sound" and boost bass a little
I find this unnecessary with the 3.0 firmware

Keep in mind there are no rules for this stuff IMHO
If you like the sound of a certain amp combo or
If it makes you happy go for it
post #11119 of 14237
Quote:
Originally Posted by FritzL View Post

Using mostly Shure SE 420's or Senheiser over ear Momentums. Occasionally ATH-M50.

With those headphones you wouldn't require any additional amping unless you like the sound of the amp itself. Then again, like I said earlier, the bass/treble controls on the X3 are excellent so you can make it sound any way you want.
Edited by x RELIC x - 6/25/14 at 10:40pm
post #11120 of 14237
Quote:
Originally Posted by TrollDragon View Post

I use the E12 / X3 combo for the DT880 Pro's, the E12 adds the extra headroom without having to switch the X3 into High Gain.

+1 for this combo. I use it to be able to listen to some of my hard to drive cans at different places at home.

If you like to add an amp for the purpose of more power you need to move up to E12 and others in that range, if you just want a different soundsignature you can pair it with whatever you enjoy.
post #11121 of 14237
Quote:
Originally Posted by Arty McGhee View Post

Prior to this firmware I was using an e11 to get the line out "sound" and boost bass a little
I find this unnecessary with the 3.0 firmware

Keep in mind there are no rules for this stuff IMHO
If you like the sound of a certain amp combo or
If it makes you happy go for it
+1
post #11122 of 14237

Yesterday I figured out there is a new firmware. Does anybody know, DSD is being supported by coding it to PCM or is it native DSD? I thought, WM8740 didn't support native DSD...
 

post #11123 of 14237

Yes, WM8740 didn't support native DSD. X3 coding it to PCM 24/88,2 (answer from FiiO Support).

post #11124 of 14237

OK, thx.
 

post #11125 of 14237
I received my X3 yesterday and am trying to update the v1.31 firmware with the new v3.0. I continually get the error "File not found".
I have downloaded the FW3.0 file to a 2gb FT card formatted as FAT32.

I've searched the thread and can't find any help but suspect that may be because of my search criteria.
Any help resolving this problem will be appreciated.
post #11126 of 14237
Quote:
Originally Posted by fatcat28037 View Post

I received my X3 yesterday and am trying to update the v1.31 firmware with the new v3.0. I continually get the error "File not found".
I have downloaded the FW3.0 file to a 2gb FT card formatted as FAT32.

I've searched the thread and can't find any help but suspect that may be because of my search criteria.
Any help resolving this problem will be appreciated.

 

Try this:

 

- format the card in the X3

- make sure the file you copy onto the card (top level directory, unzip before copying) is not the ZIP file but the x3.fw file

- try updating again

 

Cheers,

K

post #11127 of 14237
Quote:
Originally Posted by fatcat28037 View Post

I received my X3 yesterday and am trying to update the v1.31 firmware with the new v3.0. I continually get the error "File not found".
I have downloaded the FW3.0 file to a 2gb FT card formatted as FAT32.

I've searched the thread and can't find any help but suspect that may be because of my search criteria.
Any help resolving this problem will be appreciated.


Did you put just the file x3.fw from the 3.0 download in the root of the TF card ?

 

Edit:20 seconds too slow :D


Edited by jimmers - 6/26/14 at 3:06am
post #11128 of 14237
Quote:
Originally Posted by jimmers View Post
 


Did you put just the file x3.fw from the 3.0 download in the root of the TF card ?

 

Edit:20 seconds too slow :D

 

We are a helpful bunch here in this thread ;-)

post #11129 of 14237
Quote:
Originally Posted by Koolpep View Post

We are a helpful bunch here in this thread ;-)

Yes you are! Thanks, I reformatted the card in the X3, unzipped, ran and wallah! I'm now up-and-running with v3.0

Thank you all for your help. I hope that in the not to distance future I'll be X3 savy enough to contribute to the thread.

This is the kind of experience that makes Head-Fi such a great forum.
post #11130 of 14237
Quote:
Originally Posted by fatcat28037 View Post


Yes you are! Thanks, I reformatted the card in the X3, unzipped, ran and wallah! I'm now up-and-running with v3.0

Thank you all for your help. I hope that in the not to distance future I'll be X3 savy enough to contribute to the thread.

This is the kind of experience that makes Head-Fi such a great forum.

 

Ah, mabrouk habibi, my pleasure. 

 

Enjoy the great FW 3.0 - it's a huge step.

 

Cheers,

K


Edited by Koolpep - 6/26/14 at 5:24am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.