or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 699

post #10471 of 17162
Quote:
Originally Posted by FW214b View Post
 

 

+1 please.

 

+2

post #10472 of 17162

Fairly sure the 2.19 beta is not available for public use, and would most likely violate some kind of contract signed by those in the beta testing group.

post #10473 of 17162
Quote:
Originally Posted by Mr Trev View Post

Yes, I was referring to mulit-band eq. I never did try it in 2.14b (heck, I don't even use bass/treble), but some people claim it din't work all that well so maybe that's why it got dumped. Either way i'm not going to lose sleep over it.

I tend to rotate my earphones quite a bit, so I really can't say anything about whether the sound has changed for the better or worse, but I think I remember James/Joe mentioning that nothing has been done since the beginning to alter the sound - other than fixing decoding bugs (mp3, ogg, etc).

Been really stable so far, and really the only negatives I can say are minor quibbles. Album art which is over scaled and getting cut off on the sides, and looking through the firmware files there is a shade graphic that should darken the background when displaying info/lyrics (kinda like volume) that doesn't seem to be active. Makes reading the tag info over top of the artwork really hard (I might add this to bugzilla).

All in all however, a great job by the Fiio engineers, and I'm looking forward to good things to come.

Cheers.

ps. I should have my theme updated by the weekend.

Lyric display improvement bug is #143
Album art resizing bug #119

Please add comments and vote for these bugs.
post #10474 of 17162
Yes a
Quote:
Originally Posted by Saoshyant View Post

Fairly sure the 2.19 beta is not available for public use, and would most likely violate some kind of contract signed by those in the beta testing group.

Yes, that is correct.
post #10475 of 17162
Quote:
Originally Posted by marty63 View Post
 

I would like to share several objections to the new firmware.

1) Lack of the Custom Volume option – upon start-up the player remembers the last volume setting. This can be a real issue, since there are records (especially albums with old mastering or most LP rips) that have an overall lower volume than contemporary records. It is clear what happens when you’re playing a “silent” record with the volume cranked up high and then turn the player off – next day you decide to play a contemporary “loud” album and the volume blows your head off.
I think this is very inconvenient, the possible solution being to go back to the Custom and Memory options from the 2.1 version.

2) It would be nice to make the treble/bass settings part of the Quick Menu.

3) The Play Now screen. If there is no album cover or lyrics, this screen should be displayed without the standard background image. Or a theme should be added which has a blank Play Now screen, without a picture.
Why do song and artist data disappear from the screen after some time? Why is the song name displayed twice, while the album name is not displayed at all?
I would logically expect the Artist, Album and Song Title items to be permanently displayed on the Play Now screen. This is a complete nonsense and should be fixed.

I'm idiot. Trouble with loudness don't pay attention.

But time for setting some values too be short.

post #10476 of 17162

I personally liked the sound of 2.1 better and so i tried to change back the firmware but it seems to be stuck in 3.0 even if I put the 2.1 fw file on the tf card and updatearrow-10x10.png.

 

Could someone help me here? Am i doing something wrong? I really do want the old sound back

 

Nvm i ****ed up is all


Edited by Caival - 5/28/14 at 1:52pm
post #10477 of 17162
Quote:
Originally Posted by ngs428 View Post

Yes a
Yes, that is correct.


That sucks.

 

Particularly since 2.14b, which sounds different than 2.1 and 3.0, is publicly available.  (From what I gather from folks here, 2.19b sounds the same as but is a less buggy version of 2.14.)

 

I really don't understand why the sound is changing so much between firmwares.  I mean, I guess it was a good thing the first time because to my ears, it improved between 2.1 and 2.14b.  But I thought the basic tone of the player had more to do with its hardware than its software.  Wouldn't one want theoretically want to use software that provides no coloration to the sound, and to have the player tuned with the hardware components? 


Edited by steelglam - 5/28/14 at 1:42pm
post #10478 of 17162

I was hoping for larger than 5800 track library and playlist capability. Maybe version 7.9.

Same want list for my X5.....................Jim

 

PS.........What is a cue sheet?

post #10479 of 17162

I've just downloaded and played 2 tracks so it's too early for an opinion. It's the same face and operation as 2.14b. Is that right? I was thinking it may be different.

 

There is more bass. I liked 2.14b better than 2.1 so I need to get used to this first.

 

Cheers for the effort put in James and Joe! :)

post #10480 of 17162

Gapless playback with MP3's at 320kbps now works flawlessly in 3.0. Well done Fiio :wink_face:

The Floyd is now back on the menu :normal_smile :

post #10481 of 17162
Quote:
Originally Posted by slawts View Post
 

I've just downloaded and played 2 tracks so it's too early for an opinion. It's the same face and operation as 2.14b. Is that right? I was thinking it may be different.

 

There is more bass. I liked 2.14b better than 2.1 so I need to get used to this first.

 

Cheers for the effort put in James and Joe! :)


Definitely more bass.  Like 2.1.

 

Mids seem recessed or less detailed like in 2.1 as well, though.  What I liked about 2.14b was that the mids were clearer and more detailed.  I also think 2.14b was more dynamic and faster-sounding than 2.1 and 3.0.

post #10482 of 17162
Quote:
Originally Posted by ngs428 View Post


Lyric display improvement bug is #143
Album art resizing bug #119

Please add comments and vote for these bugs.

Seems I can't find those particular reports. Were they for the beta trials? I'll give Fiio some time to update the bugzilla progress and check back.

post #10483 of 17162
Man, I haven't updated my X-3 in months. I guess I've been missing out on all the new good updates.
post #10484 of 17162

I know this has been covered before so please bear with me.

 

In the new firmware (and the beta version I had before), MP3s sometimes display album art but mostly don't.  Those same files don't allow me to fast-forward within a track.  I know tagging is an ongoing issue.  However, some of those files gave me no problem on 2.1 and earlier.  (Flac has never been a problem.)  I assumed I would wait for 3.0 and all would be resolved.  Nope. 

 

Any one else have this problem?  Retagging the files with different pics changes nothing, and even if it did, attaching a couple thousand pics is a bit time-consuming!  Is there a simple fix?  BTW, all conversions and tags were done with Foobar.

 

Thanks for any help!

post #10485 of 17162
Quote:
Originally Posted by kh600rr View Post

Man, I haven't updated my X-3 in months. I guess I've been missing out on all the new good updates.

 

You've missed 2.14b :basshead:

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.