Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 681

post #10201 of 12978
Quote:
Originally Posted by paruchuribros View Post
 

Firmware upgrade to X3 to 2.14Beta did the trick.

Please try it.I highly recommend it now after 3 hrs of testing.

I am on the internal beta testing team, so I have the latest beta installed.

post #10202 of 12978

any link to the 2.14B firmware

post #10203 of 12978
Quote:
Originally Posted by ngs428 View Post
 

His username is Joe Bloggs.  Send him a PM and ask to be in the Beta Group.  

Submitted my request. Fingers crossed.

post #10204 of 12978

Aaaaaaand I converted all of the 192/24 vinyl rips down to 96/24.  I'm still convinced that there's a difference to my ear, that 192/24 is superior to 96/24.
But in the truck… 192/24 sounded just wrong somehow, like I needed to fiddle with bass/treble, and I did, and it just never sounded right.  But it sounded great in headphones!  So sometimes I would listen to my Android in the truck (and there's another entry)(I actually do like my phone best for lossy stuff or 44.1/16).  Anyway, X3 + truck was disappointing.  I really wanted the X3 to be my all-around music player for my LP stuff.
And now it is!  96/24 sounds great in the truck, truck's bass set at -5 and treble set at +5, X3's bass set at 0 or 2 and treble set at 10.  Perfect.  Dare I say it, better than cassettes.  
I wish I'd been doing that on my long drive to and from Berkeley this last weekend.  I listened to my MP3s on my phone.
But anyway, yay.
In the truck, 96/24 all the way.
In headphones, 96/24 is super great, but not super super great.
If I ever get to a point where I won't ever be listening to stuff in a vehicle again, well then, I'll just re-record everything to 192/24!

God, I love music.

post #10205 of 12978
Quote:
Originally Posted by ekelund View Post

any link to the 2.14B firmware

I suggest that we stop talking about the beta's at all, because this attracts people who don't understand the concept of beta firmware, as the one quoted above.
post #10206 of 12978

http://www.youtube.com/watch?v=9JWP5h1FbxI&feature=youtu.be

 

The problem that I'm having is in the video. I've tried contacting MP4Nation but the only thing they said is "Discharge it and recharge it." When I said that I can't even start it... I'll try making another ticket.

post #10207 of 12978
Quote:
Originally Posted by KorkiPoo View Post

http://www.youtube.com/watch?v=9JWP5h1FbxI&feature=youtu.be

The problem that I'm having is in the video. I've tried contacting MP4Nation but the only thing they said is "Discharge it and recharge it." When I said that I can't even start it... I'll try making another ticket.

I think your screen or it's backlight might be dead.

Tell them the screen's broken and you want your unit replaced.
post #10208 of 12978
Quote:
Originally Posted by CH23 View Post


I think your screen or it's backlight might be dead.

Tell them the screen's broken and you want your unit replaced.


I'm sure it's the battery or the charging circuit, when I received it I only charged it for 2-3 hours and then I listened to some music with it for an hour. That's when it stopped working.

post #10209 of 12978
Quote:
Originally Posted by KorkiPoo View Post


I'm sure it's the battery or the charging circuit, when I received it I only charged it for 2-3 hours and then I listened to some music with it for an hour. That's when it stopped working.

But even on the charger it won't turn on.

fiiO designed this device to make sure overcharging couldn't happen, so it should feed the circuitry and not the battery when the light is green.
post #10210 of 12978

One last thing you could try is to press and hold both the power and menu  buttons at the same time for a few seconds. That is how you would put it into update mode. If nothing happens then I'd say it's a hardware failure. Return or exchange would be in order.

post #10211 of 12978

Wow, something amazing just happened! It finally worked! When I (I was scared to tell him that) just told my dad that what he bought for me broke within the first day it suddenly started to work. I'm charging it now and the light is finally red. I hope I'm not cursed or something cause it's so strange. Oh well, thanks for trying to help guys. Really appreciate it. :D

post #10212 of 12978
Quote:
Originally Posted by KorkiPoo View Post

Wow, something amazing just happened! It finally worked! When I (I was scared to tell him that) just told my dad that what he bought for me broke within the first day it suddenly started to work. I'm charging it now and the light is finally red. I hope I'm not cursed or something cause it's so strange. Oh well, thanks for trying to help guys. Really appreciate it. biggrin.gif

Any idea what caused it to work? What did you do?
post #10213 of 12978
Quote:
Originally Posted by CH23 View Post


Any idea what caused it to work? What did you do?


No idea, I just held the power button and it worked again. After 20 hours being unresponsive. Strange, hope it doesn't happen again.


Edited by KorkiPoo - 5/15/14 at 9:15am
post #10214 of 12978

double post pls remove

post #10215 of 12978
I'm opting to wait for the official FW release, and I would like that day to come quickly. That is all.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.