Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.
New Posts  All Forums:Forum Nav:

The Fiio X3 Thread. - Page 678

post #10156 of 12952
Quote:
Originally Posted by chengsta View Post
 

Open it up and use a dryer on it and let it sit for a day.  If that doesn't work, then there is no fixing it, something got shorted out.

Please :

 

Never use an hot air dryer on elecrtonic chips.

 

The silicium die is encapsulated in a ceramic matrix polymer (the black part of the chip), when flooded, the water penetrate into the matrix polymer.

 

If you apply hot dry air on it, the water evaporate immediately and generate a very high pressure into the chip (particulary at the junctions)

 

In most cases this very high and irregular pressure destroy the silicum die and its connections.

 

An electronic chip will never get out unscathed from this treatment.

post #10157 of 12952
Quote:
Originally Posted by Stuff Jones View Post
 

**** my X3 was in my pocket in a rainstorm and now one channel doesn't work. Both for headphone and line out jacks. 

 

Any remedy?

 

I opened the X3 up and left it in rice (brown) overnight and both channels work again! 

post #10158 of 12952
Quote:
Originally Posted by Stuff Jones View Post
 

 

I opened the X3 up and left it in rice (brown) overnight and both channels work again! 

 

That's great!  Now, keep that thing out of the rain!

 

And I'm glad you used rice instead of hair dryer.  Whoever suggested that need to go check up on some real world facts.  Although the type of rice doesn't really matter as long as it does the job, but I think white rice may absorb more water than brown or red rice cuz of the unbroken shell.

post #10159 of 12952
Quote:
Originally Posted by Stuff Jones View Post
 

 

I opened the X3 up and left it in rice (brown) overnight and both channels work again! 

 

 

Quote:
Originally Posted by Dkhand View Post
 

 

That's great!  Now, keep that thing out of the rain!

 

And I'm glad you used rice instead of hair dryer.  Whoever suggested that need to go check up on some real world facts.  Although the type of rice doesn't really matter as long as it does the job, but I think white rice may absorb more water than brown or red rice cuz of the unbroken shell.


Great news. Any dried rice will attract the moisture, but just leaving it alone to dry out slowly would probably also work. I once rescued a mobile phone that had been through the washing machine, by leaving it for a few days in an airing cupboard.

post #10160 of 12952
Quote:
Originally Posted by Dkhand View Post
 

 

Can you elaborate a bit more as in what cable you plug in?  Have you tried plugging it into your computer? and does it respond to that?  Is your Hold switch flipped to "Hold"?  It turn itself off after 10 seconds if "Hold" is on.

I've used the usb cable included with it.

I tried plugging it in the computer, nothing.

It doesn't respond to it. It's not on Hold either.

When I received it it had no charge.

I charged it for 2 hours.

I listened to some music with it for 30 - 45 minutes.

The screen suddenly froze for 3-5 seconds and became black

Holding or pressing the reset switch doesn't do anything.

Holding the power button doesn't do anything.

When i plug it in the charge indicator will be green instead of red.

I can't charge it.

Help.

 

Will disassembling it void the warranty?

I think I'm the only person which have had this happen, this sucks. :( 

 

Also, this might have absolutely nothing to do with this problem but when i received the unit and opened the box I found a dead insect inside the box. lol


Edited by KorkiPoo - 5/14/14 at 11:58am
post #10161 of 12952
Quote:
Originally Posted by KorkiPoo View Post
 

I've used the cable included with it.

I tried plugging it in the computer, nothing.

It doesn't respond to it. It's not on Hold either.

When I received it I charged it for 2 hours.

I listened to some music with it for 30 - 45 minutes.

The screen suddenly froze for 3-5 seconds and became black

Holding or pressing the reset switch doesn't do anything.

Holding the power button doesn't do anything.

I can't charge it.

 

Will disassembling it void the warranty?

I think I'm the only person which have had this happen, this sucks. :(

 

Umm... I'm not too sure what is happening here. Normally, pushing the hard reset button on top would normally do the trick.  Have you tried to load a new FW on your MicroSD card and try to flash it?

 

Yes, opening it up will definitely void warranty. (Isn't that always the case anyways unless it's a DIY product?)  If all efforts fails, maybe contact the guy you brought it from or contact Fiio for help.

post #10162 of 12952
Quote:
Originally Posted by KorkiPoo View Post
 

I've used the cable included with it.

I tried plugging it in the computer, nothing.

It doesn't respond to it. It's not on Hold either.

When I received it I charged it for 2 hours.

I listened to some music with it for 30 - 45 minutes.

The screen suddenly froze for 3-5 seconds and became black

Holding or pressing the reset switch doesn't do anything.

Holding the power button doesn't do anything.

I can't charge it.

 

Will disassembling it void the warranty?

I think I'm the only person which have had this happen, this sucks. :(

It's possible that you've totally flattened the battery. Lithium batteries need a certain minimum charge to work at all - to make their "management" circuitry work. If it gets too discharged then you have to charge it very slowly (at least at first). Try leaving it on charge overnight.

post #10163 of 12952
Quote:
Originally Posted by tjw321 View Post
 

It's possible that you've totally flattened the battery. Lithium batteries need a certain minimum charge to work at all - to make their "management" circuitry work. If it gets too discharged then you have to charge it very slowly (at least at first). Try leaving it on charge overnight.


*sigh* Wish me luck, even though I haven't had much luck lately. Thanks for the tip.

Don't think it'll work since it thinks its full (green light)


Edited by KorkiPoo - 5/14/14 at 12:15pm
post #10164 of 12952

Good Luck! Don't worry, we'll get to the bottom of it and Fiio is an excellent company :)

post #10165 of 12952
Quote:
Originally Posted by Dkhand View Post
 

 

Umm... I'm not too sure what is happening here. Normally, pushing the hard reset button on top would normally do the trick.  Have you tried to load a new FW on your MicroSD card and try to flash it?

 

Yes, opening it up will definitely void warranty. (Isn't that always the case anyways unless it's a DIY product?)  If all efforts fails, maybe contact the guy you brought it from or contact Fiio for help.


It came with firmware 2.1 so I didn't have to update it. I've pressed the reset button many times, I even tried holding it from 10 seconds to a whole minute, nothing. The warranty papers don't say that disassembling it will void the warranty. So I wasn't sure about it.

post #10166 of 12952
Quote:
Originally Posted by KorkiPoo View Post
 


It came with firmware 2.1 so I didn't have to update it. I've pressed the reset button many times, I even tried holding it from 10 seconds to a whole minute, nothing. The warranty papers don't say that disassembling it will void the warranty. So I wasn't sure about it.

 

I wouldn't open it up unless you know for 100% sure what you are doing.  I also suspect at this point, it might be your battery might have been depleted. From the charging time you have, it is quite short.  I remember my first full charge was about 5-6 hours.  Maybe leaving it plugged in for a while before you anything else. 

post #10167 of 12952

Do you have any other way to try and charge it other than your computer? If not, then charging by computer might take a few hours. I'd try leaving it to charge for a while and see if that solves it. If not then we must delve deeper.

post #10168 of 12952
Quote:
Originally Posted by KorkiPoo View Post


It came with firmware 2.1 so I didn't have to update it. I've pressed the reset button many times, I even tried holding it from 10 seconds to a whole minute, nothing. The warranty papers don't say that disassembling it will void the warranty. So I wasn't sure about it.

I can promise you that for all and every device you take apart, the warranty becomes void.


I hope your device'll be fixed. I take it you tried turning it on without headphones connected too?
post #10169 of 12952
Quote:
Originally Posted by CH23 View Post


I can promise you that for all and every device you take apart, the warranty becomes void.


I hope your device'll be fixed. I take it you tried turning it on without headphones connected too?


Yeah, tried it without and with, then tried it with usb and headphones connected. Tried everything. Hope it'll actually charge though, the light stays green. I'm using a 1.5A adapter so that should be enough.

post #10170 of 12952

I find the X3 is not as detailed as I'd like, I'm using the E17 with it and I'm liking the sound but what headphone amp can I use that's more detailed than the E17 and affordable. 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The Fiio X3 Thread.