or Connect
Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › Matrix X-Sabre DAC review and impression thread
New Posts  All Forums:Forum Nav:

Matrix X-Sabre DAC review and impression thread - Page 56

post #826 of 1164
Quote:
Originally Posted by misha0209 View Post
 

 

i'm considering only balanced solutions so far. so:

HDAV600

Bryston BHA-1

Schiit Ragnarok (especially looking forward to this one, not yet released)

 

so far these are in my price range in my part of the world.

i will accept any proposals (in fact i thank anyone providing any).

 

 

 

I recently picked up one of the new Questyle CMA800R current mode amps and have been using it for about 3 weeks with the X-Sabre and HD800.

 

It's not balanced, but I consider it superior to the Bryston or the Sennheiser amps. 

 

I'm still getting it all set up and broken in here but so far with the HD800 it's been nothing short of a revelation.

post #827 of 1164
Thread Starter 
Yeah that Questyle sure gets along nicely with the HD800. X-Sabre being a good match to that chain as well - keeps it from getting too razor sharp analytical.
post #828 of 1164
Quote:
Originally Posted by BleaK View Post
 


Thank you! I am astounded by how well the Vali plays with HD800, however I think I might prefer a SS amp going upwards. I think a GS-X is a bit out my pricerange atm. It would be nice if matrix made a high end amp for HD800 that stacks with the X-sabre :wink_face:

 

Have you tried the Quattro? I know it's not "high end" as such, but it does pair really nicely with the X-Sabre. I'm waiting on some upgrade op amps to arrive and will post some impressions on the review I did. For now though, it sounds very good with the T1s and X-Sabre.

 

http://www.head-fi.org/products/matrix-quattro-amp/reviews/10346

post #829 of 1164
Quote:
Originally Posted by Sanlitun View Post
 

 

I recently picked up one of the new Questyle CMA800R current mode amps and have been using it for about 3 weeks with the X-Sabre and HD800.

 

It's not balanced, but I consider it superior to the Bryston or the Sennheiser amps. 

 

I'm still getting it all set up and broken in here but so far with the HD800 it's been nothing short of a revelation.

 

 

Quote:

Originally Posted by project86 View Post

Yeah that Questyle sure gets along nicely with the HD800. X-Sabre being a good match to that chain as well - keeps it from getting too razor sharp analytical.

 

The Questyle looks really good. Out from your review project that chain shound sound pretty good!

 

Quote:

Originally Posted by Loquah View Post
 

 

Have you tried the Quattro? I know it's not "high end" as such, but it does pair really nicely with the X-Sabre. I'm waiting on some upgrade op amps to arrive and will post some impressions on the review I did. For now though, it sounds very good with the T1s and X-Sabre.

 

http://www.head-fi.org/products/matrix-quattro-amp/reviews/10346

 

Thank you for the tip, I'll check it out!

post #830 of 1164

Anyone else using JRiver?

 

I'm finding that after today's update to 19.0.108 DSD no longer worked with the X-Sabre ASIO driver. 

 

You have to go back into the audio device settings and check the DSD over DoP box. Seems that this was disabled by the update.


Edited by Sanlitun - 1/29/14 at 7:16pm
post #831 of 1164
I haven't noticed, but I haven't been using my X-Sabre much lately with all this demo stuff from Violectric and Matrix I've been reviewing.
post #832 of 1164

Using Daphile http://www.head-fi.org/t/650686/matrix-x-sabre-dac-review-and-impression-thread/705#post_9941741 with my X-Sabre, the new version brings improvement for DSD playback. Now you can choose between the SqueezePlay and Squeezelite player. The added player Squeezelite fills up the pause gaps with "DSD silence" while SqueezePlay switches to PCM silence (relay clicks).

 

And indeed! There are no more relay clicks to hear when skipping to the next/previous tracks and also after the last song of a DSD album or playlist the DAC remains in "DSD mode". *Thumbs up!*

 

http://www.computeraudiophile.com/f10-music-servers/call-testers-daphile-16767/

post #833 of 1164

X-sabre in the house and burning in! This thing is heavy! I went with the silver one and it is so far the best looking equipment (beside the hd800) I have owned, looks really nice. I am enjoying the sound right out of the box, so far so good!

post #834 of 1164
Quote:
Originally Posted by BleaK View Post
 

X-sabre in the house and burning in! This thing is heavy! I went with the silver one and it is so far the best looking equipment (beside the hd800) I have owned, looks really nice. I am enjoying the sound right out of the box, so far so good!

 

It gets even better (not by miles though) and it doesn't take long (10-15 hours or so I think).


Enjoy!

post #835 of 1164
Quote:
Originally Posted by Loquah View Post
 

 

It gets even better (not by miles though) and it doesn't take long (10-15 hours or so I think).


Enjoy!


Thank you! :beerchug:

post #836 of 1164
Honestly the comparability of this thing is horrendous. I have to keep going to change the playback device on Jriver MC to the xsabre, then back to speakers. If I unplug it, it doesn't go to laptop speakers automatically. It doesn't work with Firefox or ITunes. Kinda pissing me off, anyone know a fix? I'm on windows 8.


Apart from that, its pretty sweet! Much better than my M1DAC I think smily_headphones1.gif
post #837 of 1164
Quote:
Originally Posted by DutchGFX View Post

Honestly the comparability of this thing is horrendous. I have to keep going to change the playback device on Jriver MC to the xsabre, then back to speakers. If I unplug it, it doesn't go to laptop speakers automatically. It doesn't work with Firefox or ITunes. Kinda pissing me off, anyone know a fix? I'm on windows 8.

hmm, how is your system hooked up, and what output setting are you using in jriver (eg wasapi asio etc)? i never had any playback problems on win7 64bit. also hope you got the newest driver from x-sabre's website and not the one the usb stick

post #838 of 1164
Quote:
Originally Posted by Jd007 View Post

hmm, how is your system hooked up, and what output setting are you using in jriver (eg wasapi asio etc)? i never had any playback problems on win7 64bit. also hope you got the newest driver from x-sabre's website and not the one the usb stick
JRiver is fine on Wasapi and Asio, it just doesn't switch automatically to built in speakers if I unplug the DAC, which is fine. It doesn't work in iTunes or Firefox is the issue
post #839 of 1164
Quote:
Originally Posted by DutchGFX View Post
 
JRiver is fine on Wasapi and Asio, it just doesn't switch automatically to built in speakers if I unplug the DAC, which is fine. It doesn't work in iTunes or Firefox is the issue

do you have x-sabre set as the default playback device in in windows? also wasapi is exclusive, so if you have jriver on in wasapi mode, no other sound will play (need to close jriver).

 

the audio output doesn't switch part is windows' problem, it doesnt automatically fallback to another output device when the default one is unavailable. your speakers are not hooked up to the dac? do you have surround or something? i would just hook them up to the dac for convenience (use rca splitters)

post #840 of 1164
Quote:
Originally Posted by Jd007 View Post

do you have x-sabre set as the default playback device in in windows? also wasapi is exclusive, so if you have jriver on in wasapi mode, no other sound will play (need to close jriver).

the audio output doesn't switch part is windows' problem, it doesnt automatically fallback to another output device when the default one is unavailable. your speakers are not hooked up to the dac? do you have surround or something? i would just hook them up to the dac for convenience (use rca splitters)

Totally didn't think of that. Good call, I'll look at the windows defaults. I'm talking about the built in laptop crap speakers haha just so if I'm leaving my desk for some reason I usually just unplug the DAC for 15 minutes and let it play with the junky laptop speakers.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Dedicated Source Components
Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › Matrix X-Sabre DAC review and impression thread