Head-Fi.org › Forums › Equipment Forums › Cables, Power, Tweaks, Speakers, Accessories (DBT-Free Forum) › No sound in right speaker with Y-Splitter
New Posts  All Forums:Forum Nav:

No sound in right speaker with Y-Splitter

post #1 of 6
Thread Starter 

Hi all so I bought a sub recently and it has no output so have to connect it to a Y-Splitter on the soundcard. So speakers go to the Y-Splitter as well, although now there is no sound coming through the right speaker only left. So how do I get sound from the right speaker again? After some research I though a Y-Splitter is what I need but it seems I'm still missing something?

 

Also the splitter has 2 black lines so I guess it's stereo, did I need a mono splitter instead?


Edited by BoomBap - 2/8/13 at 7:14am
post #2 of 6

It sounds like you have split the left channel to the SUB for example and the right to the speakers.  If your soundcard supports it you should use the Front for the speakers and perhaps the back for the SUB.

 

Can you take a picture of the back of your PC so we can see clearly what is going on?

post #3 of 6
Thread Starter 

Yeah the cable going to the sub is only 1x rca which is plugged into the left channel of the sub.

 

Seems battery on my camera is dead, will edit post in a few hours with a pic

 


Edited by BoomBap - 2/8/13 at 11:12am
post #4 of 6

The splitter may not be a stereo to stereo splitter.  It may be a stereo to mono splitter thus separating the stereo signal into its left and right components.  I am guessing that is why you are having the issue.

 

One way to tell is to plug your headphones into one side of the splitter and take a listen at low volumes.  If you hear only one channel that is the culprit.

post #5 of 6
Thread Starter 

Sound is playing through both channels on the earphones at low volume

post #6 of 6
Thread Starter 

I will order another splitter..For now I'm using the front jack for speakers although will this be the same quality as back?

New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Cables, Power, Tweaks, Speakers, Accessories (DBT-Free Forum) › No sound in right speaker with Y-Splitter