Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › ALO Audio Continental V3 Impressions and Appreciation Thread
New Posts  All Forums:Forum Nav:

ALO Audio Continental V3 Impressions and Appreciation Thread - Page 7

post #91 of 135

I seldom to use T1 for Radiohead song, so i can not comment on this. But "15 Steps" and "Reckoner" sounded so beautiful using my HD800 + Conti V3 biggrin.gif.

I will let you know later when i am home, i will fire up my T1 using some of my amps and let you know via PM wink_face.gif

Gear mentioned in this thread:

post #92 of 135
Quote:
Originally Posted by muzic4life View Post

I seldom to use T1 for Radiohead song, so i can not comment on this. But "15 Steps" and "Reckoner" sounded so beautiful using my HD800 + Conti V3 biggrin.gif.

I will let you know later when i am home, i will fire up my T1 using some of my amps and let you know via PM wink_face.gif

I look forward to hearing back from you! I'm about to lay down the cash on the T1's so hope the combo of those + the Glacier = Radiohead heaven! :)

post #93 of 135

When in doubt go made in USA!!!

post #94 of 135

When in doubt go made in USA!!!

post #95 of 135
Having read this thread all the way through, I can't think of any reason to upgrade my Continental V2 for a V3.
Am I missing something?
post #96 of 135

I cannot understand why ALO Audio does not make the Continental amp with the bass knob like they do with the Rx Mk3-B portable amp. Then this amplifier would really be something.


Edited by zorin - 9/8/13 at 8:49am
post #97 of 135
Quote:
Originally Posted by IceClass View Post

Having read this thread all the way through, I can't think of any reason to upgrade my Continental V2 for a V3.
Am I missing something?

 

No.

post #98 of 135

Anyone experiencing channel imbalance with their Continental V3 using sensitive iems like the TG 334?

 

 

Edit: I contacted ALO and they were kind enough to arrange a new V3 for me. This new V3 had no channel imbalance.


Edited by AlanYWM - 10/26/13 at 5:49am
post #99 of 135

Would this amplifier make the HD650 sound faster or would they help the HD650 on faster, more complex tracks?


Edited by maricius - 10/25/13 at 7:55am
post #100 of 135

I am using the Continental V3, with an iPod 5.5g with the RWA iMod. Using IEM it has absolutely no hiss, dead quiet, even right out of the box.

It did take a burn in for either the iMod or the V3 to come to life.

post #101 of 135
How many hours roughly burn in would you think ? And what iems are you using ?
post #102 of 135

I have aprox. 250 hrs., I would let the battery run out. The sound improved at the 200 hr mark.

I am presently using Monster Copper turbine, but I have JH Audio JH13 on order.

post #103 of 135
Quote:
Originally Posted by aivTO View Post

I am using the Continental V3, with an iPod 5.5g with the RWA iMod. Using IEM it has absolutely no hiss, dead quiet, even right out of the box.
It did take a burn in for either the iMod or the V3 to come to life.

Quote:
Originally Posted by aivTO View Post

I have aprox. 250 hrs., I would let the battery run out. The sound improved at the 200 hr mark.
I am presently using Monster Copper turbine, but I have JH Audio JH13 on order.
Ok beautiful thank you..I thought it was up there in hours and maybe even more..mine is starting to sound better too..I let the battery run out pretty much every time..I find it really works well with dynamic driver iems..well it depends on what you like to listen to too. I use my 535's and my w4r's and they sound really good..not a lot of ..let's say v shape sounding going on with this amp ..it is a very neutral amp for sure. But with my ie80's they just shine nicely with this amp..where the other two at times can sound a little too thin I guess is the word I'm looking for. . I hope that made sence. Lol ..I also loved the way it sounded with my coopers too..except I HATE that I keep Getting driver flex with them..drives me insane..it's too bad cause like I said I think this amp pairs really well with them and my ie80's..
post #104 of 135
Quote:
Originally Posted by aivTO View Post
 

I have aprox. 250 hrs., I would let the battery run out. The sound improved at the 200 hr mark.

I am presently using Monster Copper turbine, but I have JH Audio JH13 on order.

ALERT !

If the battery runs out, do not store the amplifier with an empty battery. If you do this regularly the battery life will be shortened. If it is drained and you do not intend to use the amplifier then make sure that you recharge the battery for at least half an hour. Similarly it is not good for the battery to be fully charged and then not used. The optimal level of the electrical charge of a battery that is not being used regularly, every 2 or 3 hours, is below the full charge level, something around 80%, that means 4 hour playing time if the amplifier is new and holds 5 and half hour of playing time charge. If you use the Continental sporadically, once in every few days or more, then keep the level of charge at around 2 hours of the playing time, let's say between 1 and 3 hours. Recharge the battery to full level before the use.

Take into account the impedances of the headphones that you use. The battery will discharge faster on the low impedance headphones and slower on the high impedance headphones. On Beyerdynamic T1, which has a 600 Ohm impedance, my over one year old Continental V2 lasts 5 and 1/4 hour and on 40 Ohm headphones it lasts at least half an hour less. 


Edited by zorin - 11/10/13 at 4:29pm
post #105 of 135

Thanks zorin for the info.

I have notice a slight decrease in battery life, aprox. one hour shorter.

Is the batter replaceable?

I was surprised the amp did not come with a manual!


Edited by aivTO - 11/8/13 at 7:44am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps

Gear mentioned in this thread:

Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › ALO Audio Continental V3 Impressions and Appreciation Thread