Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › C&C BH Portable Headphone Amp (80 Hours from a Single Charge!) [Buyer Review]
New Posts  All Forums:Forum Nav:

C&C BH Portable Headphone Amp (80 Hours from a Single Charge!) [Buyer Review] - Page 221

post #3301 of 3314
Thread Starter 
Quote:
Originally Posted by goody View Post

Hi guys I bought my amp from eBay but I can't seem to remember the eBay id of the seller.. I need to get my amp sent back for warranty purposes.. The volume knob keeps cutting the sound out..anyone else experienced the same thing



Perhaps go through your PayPal transactions to find the item and locate the seller? 

I can tell you I think you need to return your amp.
 

post #3302 of 3314
Quote:
Originally Posted by goody View Post

Hi guys I bought my amp from eBay but I can't seem to remember the eBay id of the seller.. I need to get my amp sent back for warranty purposes.. The volume knob keeps cutting the sound out..anyone else experienced the same thing

If you have left a feedback for the transaction on eBay, perhaps you can try going thru your buyer or seller's feedback page and see if you could find the seller id. 

post #3303 of 3314

hey guys managed to find the seller it was pollychen0306 on ebay,..he was a good seller indeed  just sent him a message ..i need to get it fixed the volume keeps cutting out all the time like a bad connection somewhere..

post #3304 of 3314
Thread Starter 
Quote:
Originally Posted by goody View Post
 

hey guys managed to find the seller it was pollychen0306 on ebay,..he was a good seller indeed  just sent him a message ..i need to get it fixed the volume keeps cutting out all the time like a bad connection somewhere..



Excellent news. Let us know how you go with our replacment.

post #3305 of 3314
I can't believe I'm still happy with this silly cheap amp. Great little amp!
post #3306 of 3314

When I bought this little amp and paired it with my Galaxy 4.2 player (Wolfson DAC and sounds great on its own) I was extremely dissapointed in the results, the resolution sounded like it had dropped through the floor despite using 320Kbps mp3's in the galaxy. 

The BH2 made it sound like I was listening to a 80kbps mp3 file, the tone, clarity and musicality were also truely awful.

 

At first I thought I had a dodgy unit until I tried it with my Xonar ST's line out, with which, it sounds absolutely fine, almost transparent even.

 

I am confused, can anyone explain the possible technicalities as to how/why this might be?

post #3307 of 3314
Quote:
Originally Posted by Ari33 View Post
 

When I bought this little amp and paired it with my Galaxy 4.2 player (Wolfson DAC and sounds great on its own) I was extremely dissapointed in the results, the resolution sounded like it had dropped through the floor despite using 320Kbps mp3's in the galaxy. 

The BH2 made it sound like I was listening to a 80kbps mp3 file, the tone, clarity and musicality were also truely awful.

 

At first I thought I had a dodgy unit until I tried it with my Xonar ST's line out, with which, it sounds absolutely fine, almost transparent even.

 

I am confused, can anyone explain the possible technicalities as to how/why this might be?

 

Are you max out the BH2's volume and then use your Galaxy to control volume? If it is so, you need to do the opposite - max out (or at least put it to 80~90%) the volume on Galaxy, then use the amp to control volume.

post #3308 of 3314
Quote:
Originally Posted by ClieOS View Post
 

 

Are you max out the BH2's volume and then use your Galaxy to control volume? If it is so, you need to do the opposite - max out (or at least put it to 80~90%) the volume on Galaxy, then use the amp to control volume.

 

Thanks, yeah, I tried my Galaxy at different volumes and settled on 90%... on the BH2, I have tried out all the different gain/sound settings no real change for the better... and I don't max out the BH2 on any of them

 

My favoured iems are UE TF10's btw.. gonna dig out some different iems and full sized headphones.

post #3309 of 3314

:)


Edited by goody - 9/28/14 at 7:25am
post #3310 of 3314
Quote:
Originally Posted by H20Fidelity View Post
 



Excellent news. Let us know how you go with our replacment.

Sent you the amp back so hopefully will hear from you soon and very good responses on ebay as well...i really love this amp so looking forward to a fixed amp

post #3311 of 3314

Has anyone had problems with the Input jack? When i plug my 3,5 cable from iPod into it, only left channel is audible, but when i pull it outwards slightly i can hear from both channels. It is very annoying when im on the move and the plug moves about.

post #3312 of 3314
Thread Starter 
Quote:
Originally Posted by Elinore View Post

Has anyone had problems with the Input jack? When i plug my 3,5 cable from iPod into it, only left channel is audible, but when i pull it outwards slightly i can hear from both channels. It is very annoying when im on the move and the plug moves about.

Unless you're willing to slide the board out and check the solder contacts you may need a return.
post #3313 of 3314
Quote:
Originally Posted by H20Fidelity View Post


Unless you're willing to slide the board out and check the solder contacts you may need a return.

 

Might also want to try another 3.5mm cable before returning though.

post #3314 of 3314
Quote:
Originally Posted by H20Fidelity View Post


Unless you're willing to slide the board out and check the solder contacts you may need a return.


I have taken it out already from its housing and checked the soldering points, they looked fine to me. I think that the jack itself is broken, unfortunately the company that i bought it from has gone bust so i'm not sure what should i do.......I think I'm gonna buy a replacement jack and change the old input jack, if i can find one.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › C&C BH Portable Headphone Amp (80 Hours from a Single Charge!) [Buyer Review]