or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › T-PEOS H-200 - new triple hybrid IEM - Impressions thread
New Posts  All Forums:Forum Nav:

T-PEOS H-200 - new triple hybrid IEM - Impressions thread - Page 127

post #1891 of 2592
Quote:
Originally Posted by quartertone View Post

I wasn't rough at all. And the problem is at the jack, not the driver connector.

 

How are you disconnecting the jack from your source?  Are you pulling on the cable, end of the strain relief, or tip of the strain relief? 

post #1892 of 2592

I pull on the cable with my teeth. ;-)

 

I usually pull out the jack by the point of the L. 

post #1893 of 2592
Quote:
Originally Posted by quartertone View Post

I pull on the cable with my teeth. ;-)

 

I usually pull out the jack by the point of the L. 

 

Well, that's your problem, your teeth chewed through the cable.  If you got a shock while it lost connection, that means you are playing your music too loud ;) 

 

If you're pulling it at the point of the L (where it angles out), you might be stretching the strain relief and causing a disconnect that way.  Only explanation I've got.  There is, of course, still the chance that the cable was defective to begin with. 

post #1894 of 2592
Quote:
Originally Posted by quartertone View Post

I wasn't rough at all. And the problem is at the jack, not the driver connector.

Oh, I think you were.. *shakes naughty finger*
Edited by H20Fidelity - 7/21/13 at 11:30pm
post #1895 of 2592

Whatever the details, I'd say that cable failure after 2 months of normal (and not even daily) use is a bit weak. Guess I'll ask them about a replacement, seeing as the upgrade cable won't have a remote.

post #1896 of 2592
Quote:
Originally Posted by quartertone View Post

Whatever the details, I'd say that cable failure after 2 months of normal (and not even daily) use is a bit weak. Guess I'll ask them about a replacement, seeing as the upgrade cable won't have a remote.

 

i agree, my red cable from time to time loses connection on the right ear, i have to move connector gently to restore the contact, sounds weird. have to check if this is the cable or the right earpiece but perhaps i also will have to mail TPeos about this then.

post #1897 of 2592
Quote:
Originally Posted by quartertone View Post

I pull on the cable with my teeth. ;-)

 

I usually pull out the jack by the point of the L. 

I usually spin the IEM by the cable until it flies off.

 

You guys that are having trouble should email them about it.  I had this issue too and am awaiting my pair back soon.

post #1898 of 2592

Well, I mailed them and already got a response that they'll simply send me a new one, no questions asked. Pretty good service.

post #1899 of 2592
Quote:
Originally Posted by quartertone View Post

Well, I mailed them and already got a response that they'll simply send me a new one, no questions asked. Pretty good service.

 

who did you mail? please PM me, i also need ask them for this or perhaps send them back my H200 so they can check it. i hope this is cable, will check with black cable later.

post #1900 of 2592
Quote:
Originally Posted by Gintaras View Post

who did you mail? please PM me, i also need ask them for this or perhaps send them back my H200 so they can check it. i hope this is cable, will check with black cable later.




I almost sent them my left earphone with the same problem as yours. After 2 weeks of further observation, it seems to be ok now. Just had to find the right position by rotating the cable to one side every 2 days. The other 3 sides do tend to get loose contact at the jack. Still observing tho... I'm ready to ship it back if it re-occurs.
Edited by d marc0 - 7/22/13 at 6:15am
post #1901 of 2592
Quote:
Originally Posted by d marc0 View Post


You can email Sunggo: 
k1880497@swpshinwoo.com


I almost sent them my left earphone with the same problem as yours. After 2 weeks of further observation, it seems to be ok now. Just had to find the right position by rotating the cable to one side every 2 days. The other 3 sides do tend to get loose contact at the jack. Still observing tho... I'm ready to ship it back if it re-occurs.

 

thanks, this same happens to my H200, i still need to see IF this is cable or IEM itself before contacting them. anyway i am happy hearing about good support at TPeos, makes me comfortable.

post #1902 of 2592
Quote:
Originally Posted by Gintaras View Post

 

thanks, this same happens to my H200, i still need to see IF this is cable or IEM itself before contacting them. anyway i am happy hearing about good support at TPeos, makes me comfortable.

The service and communication were excellent IMO.

post #1903 of 2592

Sooo, no updates on aftermarket cables for H-200?

 

BTW, thanks again for the tips concerning, emmm, tips for these babies. I've ordered both V-Moda tips and Comply Ts 400 and received them before my vacation was over so I've had some time to experiment. Ts 400 are almost perfect as their foam nature improves the bass and isolation while not taming the highs too much and the wide bore design makes their stage good enough. V-Moda tips, on the other hand, just has NO bass for me, so they are going to rest in a box for now.

 

And now the funniest thing - I've found the most suitable tips while waiting for these two to arrive. I was trying to enjoy my girlfriend's Heir Audio 3a.i and found these small double flanged tips... And they are perfect. Good bass, wide stage, no clarity loss whatsoever and my girlfriend does not use them at all because of the fit issues. 

 

Both Comply and Heir Audio tips have absolutely no driver flex issues so now I am tip rolling these two pairs and the stock medium ones and further burning the earphones.

post #1904 of 2592
Still waiting...
post #1905 of 2592

Mine came through yesterday :)

 

Been listening to them today, they sound promising. I use the stock M sony hybrid style tips, I get driver flex right side only.

 

New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › T-PEOS H-200 - new triple hybrid IEM - Impressions thread