Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › Did I melt my e7?
New Posts  All Forums:Forum Nav:

Did I melt my e7?

post #1 of 6
Thread Starter 

It looks like my recently-purchased e7 has melted just above the mini usb port on the lower left side of the device. I had it plugged into my PC and was using it for only a few minutes when I noticed that the device had become extremely hot, and then noticed this bubble. 

 

Is this something that has happened to anyone else before? And has anyone had any experience with RMA'ing an e7 before?

 

post #2 of 6

Wow that sounds almost unbelievable, that thing really got hot. Wonder what happened and good luck with RMAing. "**** got hot and burnt up when I plugged it in" I think FiiO staff will look like a big "?"


Edited by RPGWiZaRD - 12/15/12 at 3:10pm
post #3 of 6

Is the heat and the melting point battery side?

post #4 of 6
Thread Starter 

I'm not totally sure if that's where the battery is located. The spot where the bubble appeared is just over the mini-usb port, which is what is used for charging, so I would guess that the battery isn't too far away. 

post #5 of 6

Well for now, don't use it.

Have you sent a ticket to FiiO? Is that the e7 or the e07k?

post #6 of 6

My guess is that a polar cap is the wrong way around. They do that when seeing reverse voltage. If it was still working while getting this hot, it fits but like I said, a guess.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › Did I melt my e7?