Head-Fi.org › Forums › Sponsor Announcements and Deals › This Schiit is Bananas! $99 Schiit Magni Amp and $99 Modi DAC
New Posts  All Forums:Forum Nav:

This Schiit is Bananas! $99 Schiit Magni Amp and $99 Modi DAC - Page 63

post #931 of 1366
Quote:
Originally Posted by Jason36 View Post

I just collected my Modi / Magni combo from Parcelforce this morning.

Couldn't wait to get it back to the office and I am not disappointed. These have a small footprint and sit on my work desk perfectly. The Modi connected to my PC first time and the Magni is unbelievably powerfull for its size.

These have replaced a uDAC2 and are a definate improvement sound and power wise with my HD650's.

Now I'm wondering whether the iPad will work with these connected via a camera kit with USB?

 

I have not tried it, but others have reported that it works.

post #932 of 1366

The Modi works fine with my iPad--just need to use a powered USB hub.

post #933 of 1366

Loving the M&M stack with HD-650's and HE-400's.  Power input on the back of the Magni is tempermental.  Slightest touch and get snap, crackle and pops. 

post #934 of 1366
Quote:
Originally Posted by STEALTH714 View Post

Loving the M&M stack with HD-650's and HE-400's.  ...

Agreed, with the HD-650's.

 

Quote:
Originally Posted by STEALTH714 View Post

Loving the M&M stack with HD-650's and HE-400's.  Power input on the back of the Magni is tempermental.  Slightest touch and get snap, crackle and pops. 

Mine doesn't have this issue, maybe contact Schiit to get a replacement.

post #935 of 1366

since I've got an amp while I'll keep an eye on the Asgard.

post #936 of 1366
Quote:
Originally Posted by STEALTH714 View Post

Loving the M&M stack with HD-650's and HE-400's.  Power input on the back of the Magni is tempermental.  Slightest touch and get snap, crackle and pops. 

 

Yeah, contact Schiit. Mine had a similar issue, as well as crackling in the left channel when touching the volume knob. I should have my replacement tomorrow. :)

 

They really have fantastic customer service.

post #937 of 1366
Ohhhhh very nice!!
post #938 of 1366

I've read very good things about Jason & their customer service.  

 

I unplugged from the back of the Magni and back in and now cannot replicate the issue.  I'll keep it as is for now.  If it rears its head again, i'll contact Jason.  Reminds me of the old joke

 

Patient: Doc my arm hurts when I move it like this

Doc:  Well don't move it like that

 

:)

post #939 of 1366
Quote:
Originally Posted by STEALTH714 View Post

I've read very good things about Jason & their customer service.  

 

I unplugged from the back of the Magni and back in and now cannot replicate the issue.  I'll keep it as is for now.  If it rears its head again, i'll contact Jason.  Reminds me of the old joke

 

Patient: Doc my arm hurts when I move it like this

Doc:  Well don't move it like that

 

:)

 

Curious, it's always possible you just didn't have a good connection that one time I suppose.

 

At least you know that if it does come back up you'll be taken care of, and hopefully you won't even have to worry about it.

post #940 of 1366

My Magni had to back to the shop.  The pot started acting completely wonky--I got a channel imbalance at any volume, which changed when I jiggled the knob. triportsad.gif  I'd gladly pay extra for a better pot with a more gradual taper--wonder if that's feasible?  Work is extra stressful these days, so I miss having my setup.

post #941 of 1366
Quote:
Originally Posted by Barry S View Post

My Magni had to back to the shop.  The pot started acting completely wonky--I got a channel imbalance at any volume, which changed when I jiggled the knob. triportsad.gif  I'd gladly pay extra for a better pot with a more gradual taper--wonder if that's feasible?  Work is extra stressful these days, so I miss having my setup.

I felt like I have the same issue for my newly arrived M&M stack. Even when it gets fairly loud, I felt like the left ear was louder than the right side. Me too lol, I want to pay extra for quality products rather than faulty gears for cheap.popcorn.gif

post #942 of 1366

Got my replacement Magni today, but now the Modi seems to be faulty?!? It has horrible noise, and when music plays it sounds like the music is alien, and full of noise. Incredibly strange. I'm going to leave it unplugged from USB for a few hours, but I think I'm pretty unlucky here... Anyone else have a similar issue? It's been weeks since I've been able to listen to this stack.

post #943 of 1366
Check if the output is set to 24 bits, it does weird things at 16
post #944 of 1366

Yeah it could be your configuration. For example the other day I had a program spitting out terrible crackling noises and it turned out that it just didn't like 24bit/48kHz. I changed my DAC output to 24bit/44.1kHz in the Windows sound control panel and it fixed it.

post #945 of 1366

Hi people, long time lurker here!

 

I also noticed some crackling noises, not too loud but clearly perceptible, when using PowerDVD12 + Reclock. I tried changing configurations on both programs, but nothing worked. Turns out that switching Modi from a USB 3.0 to a 2.0 port seems to have solved the problem.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sponsor Announcements and Deals
Head-Fi.org › Forums › Sponsor Announcements and Deals › This Schiit is Bananas! $99 Schiit Magni Amp and $99 Modi DAC